Remove dual monitor slowness on Cinnamon

Write tutorials here
There are more tutorials here
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
Level 1
Level 1
Posts: 1
Joined: Fri Jul 12, 2019 5:27 am

Remove dual monitor slowness on Cinnamon

Post by gj3920 » Fri Jul 12, 2019 6:00 am


This is my solution for the problem described in the old thread Dual Monitors Makes Computer Run Slow that I found when searching for speed issues when working with dual monitors on Linux Mint / Cinnamon. I had a perfectly functional dual monitor setup on Windows 7 and yet was plagued with the same issue when to switched Mint so I didn't buy in the slow hardware argument and indeed I found out that by setting a lower number of default workspaces significantly improved the situation. This should be the first step: I went from the default 4 workspaces to 1 and the situation was pretty much ok though not perfectly seamless. I did this months ago so you'll have to look around for the exact command to use. Also, I chanced upon a "Only use workspaces on primary monitor" option in the Workspaces GUI app today that may achieve the same effect without sacrificing the use of workspaces entirely.

Just today I achieved a perfectly seamless result on my computer by working directly with xrandr after reading something on the limitations of mixed DPI screens ( ... /#index7h3). Very simply, I virtually scaled my secondary display down to the exact same resolution as before:

xrandr --output DVI-I-1-1 --scale 1x1.001 --mode 1920x1080 --rate 60

It's a dirty hack and I barely understand why it works but it definitely does on my system so I wanted to share it to help others in the same situation :)
Last edited by xenopeek on Fri Jul 12, 2019 6:07 am, edited 1 time in total.
Reason: split and moved here as per forum rules

Post Reply

Return to “Tutorials”