Page 1 of 1

Rectify wifi mouse defeating Suspend

Posted: Mon Feb 24, 2020 10:18 am
by norm.h
1) Run: cat /proc/bus/input/devices to establish enabled devices.

Example:

XHC S3 *enabled pci:0000:00:14.0 - is the Logitech mouse
PWRB S3 *enabled platform:PNP0C0C:00 - is the Power button
SLPB S3 *enabled platform:PNP0C0E:00 - is the Sleep button
LID0 S3 *enabled platform:PNP0C0D:00 - is the Lid button

2) Run cat /proc/acpi/wakeup to find:

XHC S3 *enabled pci:0000:00:14.0
XDCI S4 *disabled
HDAS S4 *disabled pci:0000:00:1f.3
PWRB S3 *enabled platform:PNP0C0C:00
SLPB S3 *enabled platform:PNP0C0E:00
LID0 S3 *enabled platform:PNP0C0D:00

3) As Administrator [root], create a new file: disable-usb-wake.conf in /etc/tmpfiles.d:

sudo touch /etc/tmpfiles.d/disable-usb-wake.conf

4) Still as administrator, edit the new file:

sudo xed /etc/tmpfiles.d/disable-usb-wake.conf [assuming xed is the running file editor]

Edit by copying the following line into it:

w /proc/acpi/wakeup - - - - XHC

Save & Close

5) Reboot

6) Run cat /proc/acpi/wakeup to check:

XHC S3 *disabled pci:0000:00:14.0


Reference: viewtopic.php?f=90&t=261465

Re: Rectify wifi mouse defeating Suspend

Posted: Tue Aug 11, 2020 4:09 pm
by shooter902
This worked for me thank you! :D

My configuration looked a bit different than your example..I don't know, maybe it is the same and I'm to inexperienced to know??

1.My USB mouse, I had to look for the PCI address on 10.0
2.Then run "cat /proc/acpi/wakeup" and look for the Sysf node 10.0 which was XHC0
3.And my etc/tmpfiles.d/disable-usb-wake.conf looked like this

Thanks Again!!

Re: Rectify wifi mouse defeating Suspend

Posted: Wed Sep 16, 2020 12:52 am
by neogeo
Hello.
I have the same problem with suspend and wakening PC but, what if i wnat to disable more devices like GLAN, XHC, EHC1 and EHC2 ???
How to sintax that?
I have try to do that but sleep working only for firs line device :(
I need to sleep them all through "disable-usb-wake.conf" file...


TNX

Re: Rectify wifi mouse defeating Suspend

Posted: Wed Sep 16, 2020 4:23 am
by antikythera
neogeo wrote:
Wed Sep 16, 2020 12:52 am
Hello.
I have the same problem with suspend and wakening PC but, what if i wnat to disable more devices like GLAN, XHC, EHC1 and EHC2 ???
How to sintax that?
I have try to do that but sleep working only for firs line device :(
I need to sleep them all through "disable-usb-wake.conf" file...


TNX
Please open a new topic. What you are asking is far more complex and merits it's own more thorough discussion and approach to the above.