Page 1 of 1

Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Mon Aug 16, 2010 10:40 am
by cra1g321
How to Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome only) :twisted:

Back with another tutorial, this time how to add support to rhythmbox for the latest iOS4 software 8)

This how to will tell you how to add iOS4 (ipod/iphone operating system) support to Linux Mint 9 Gnome Edition, by installing a newer version of libimobiledevice as the current version in LM9 does not support iOS4.
This how to has been tested using a ipod touch 3rd gen running iOS 4.0
Dont be put off by the size of the how to. It may seem long because I have outlined every step to make it as easy for everyone as possible.

Notes -
Make sure you are connected to the internet
Don't have any ipods/iphones connected while doing this how to.
Best to bookmark this page as you will need to restart your computer during the how to.


**Now to begin -

Step 1 (Add libmobiledevice ppa) – Open the Synaptic Package Manager by clicking on the Mint menu, then move your cursor over 'Administration' in the middle column then scroll down and click 'Synaptic Package Manger' from the list to the right. Enter your password if you are asked for it. The Synaptic Package Manger will now open, click 'Settings' from the toolbar at the top and then click 'Repositories' from the drop-down menu.
A window will appear called 'Software Sources' click on the 'Other Software' tab, then click the 'Add...' button near the bottom. Another small window will appear, copy and paste ppa:pmcenery/ppa into the text box, then click the 'Add Source' button. The will automatically close, click the 'Close' button on the Software Sources window. A warning may appear after telling you that repository have changed, this is ok as where the ones that have changed them. Just click the 'Close' button again. Now click the 'Reload' button on the Synaptic Package Manger window to reload the new repository that we just added, into the Synaptic Package Manger. You will know it is done reloading when the window disappears and the list reappears in the Synaptic Package Manger.

Step 2 (Installing the new libimobiledevice) – Copy and paste libimobiledevice1 into the quick search box of the Synaptic Package Manager. You should then see two packages in the main window list. One will be called libimobiledevice1 the other libimobiledevice1-dbg. Double-click on both from the list to mark them for installation. You should notice that both have turned green. Now click the 'Apply' button of the Synaptic Package Manager then click 'Apply' again when the 'Summary' window appears. The software will now be downloaded and installed. You will know when it is finished when the window displays 'Changes applied' go ahead and click 'close'

Step 3 (Installing additional software needed) – Clear the quick search box in the Synaptic Package Manager so that it is left blank. You will notice that the list will change again. Now click on the 'Status' button located to the botom-left of the window (it may already be selected), Then click 'Installed (Upgradable)' from the list above it. The list to the right should change.
Locate and mark the following list of packages for installation by right-clicking on each one from the list and clicking 'Mark for Upgrade' (you may get a popup for some, just click the 'Mark' button on the popup. Here's the list of packages you will need to mark for upgrade -
gvfs
gvfs-backends
gvfs-bin
gvfs-fuse
libgpod-common
libgpod4
libplist1
libusbmuxd1
usbmuxd

After you have done that, click the 'Apply' button of the Synaptic Package Manager, and click the 'Apply' button on the Summary window again. The packages you marked for upgrade will now be upgraded to their newest version. Once again you will know it is done when the window displays 'Changes applied'. When you see this go ahread and close the window then close the Synaptic Package Manger.
Now restart your computer by clicking on the Mint menu, clicking 'quit' then click 'Restart'.

Step 4 (Testing if everything works) - After you have restarted your computer and logged back in, make sure that rhymbox IS NOT open, then connect your ipod/iphone as you normally would. You should see it mounted on the desktop and two popups should appear onscreen. Click the 'Cancel' button on both of them.
Check that you are able to see files that on are on your ipod/iphone by right-clicking its icon the desktop and clicking 'Browse folder' from the menu. If a window appears immediately after you done that then you are now looking at the files and folders that are on your ipod/iphone (best not to touch them).
Now close that window and open Rhythmbox by clicking the Mint menu, hovering your cursor over 'Sound & Video' in the middle column then scrolling and clicking 'Rhythmbox' from the list to the right.
When it opens your ipod/iphone will most likely unmount (no longer on the desktop) this always happens to me the 1st time so dont worry.
Close rhythmbox now by clicking its icon from the panel and clicking 'quit' from the menu. Now disconnect your ipod/iphone and reconnect it again. As before you should see it mounted again on the desktop and two popup windows should appear, as before click 'Cancel' on both of them.
Now open Rhythmbox the same way as you just done before, this time however your ipod/iphone should remain mounted and shown on the desktop.
In the rhythmbox window you should see your ipod/iphone listed under 'Devices'. Click on its name to see all the songs and videos listed on it.
If you see your songs then you have successfully added support for iOS4 to rhythmbox :)
If you want to add music to your ipod/iphone just click 'Music' to see your music library and just drag and drop the songs by clicking on the song/album from its list then holding down your mouse click and moving your cursor over the your devices name till it is highlighted then unclick your mouse. You should then see transferring track 1 of 1, for example in the bottom right of the rhythmbox window. After that is done you should then see a couple of seconds later 'Sync in Progress' shown on your ipod/iphone.

After this you can now disconnect your ipod/iphone by right-clicking its name in rhythmbox and clicking 'Eject' from the menu. It should then disappear from rhythmbox and from your desktop.

Now you can follow Step 4 each time to transfer songs to your ipod/iphone. (easy to remember what to do)

Important notes -


DO NOT DISCONNECT your ipod/iphone before or during the 'Sync in Progress' message. If you do the songs will not sync and transfer correctly onto the ipod/iphone.
It is always best NOT to have rhythmbox open before connecting your ipod/iphone.
If your transferring a lot of songs it best to wait a while after rhythmbox is done transferring them as the 'Sync in Progress' can be shown more than once after.

**please reply if this how to worked for you or if you run into any problems during the how to and don't forget to tell other people about it. Im also open to any improvements that could be made to the how to.


Thanks :D

cra1g321

***Update - (Quick way to sync to ipod) - I noticed a few days ago that if you right-click on your ipod/iphone udner devices then click 'Sync with library' a window will show, tick the box next to music then click 'sync with device' then any new songs in the library will be copied over to the ipod/iphone

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Sun Aug 29, 2010 2:03 am
by Jarame
This didn't work for me. And I've tried other tutorials out there as well. I'm running LM 9 KDE with an iTouch 3G 32GB on iOS 4.0 jailbroken. Linux 9 has always recognized it as a camera, but never as an audio player. LM 8 worked fine with my iTouch, but LM 9 isn't. And I followed everything you said EXACTLY how you said it. Any other solutions?

Thanks for the all the info, btw.

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Sun Aug 29, 2010 8:50 am
by cra1g321
This tutorial was for the gnome version of LM9 only. I think kde uses different packages. I've never reli used kde that much so I cant reli help you, sorry. Check out http://www.libimobiledevice.org/ and see if it mentions
Anything about kde

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Sun Aug 29, 2010 11:58 am
by Jarame
Yeah there's a link for a KDE install, but it doesn't work. I like KDE a lot, but I use my iPod ALL the time, and that's something I want to be able to do in Linux...sync it.

Thanks for the help

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Sun Sep 26, 2010 2:50 pm
by cra1g321
Added a way to easily sync any new songs in the library to the ipod/iphone :)

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Tue Sep 28, 2010 5:40 pm
by kevinmckay
Worked great the first time.

Thank you for taking the time to clearly document all the steps.

Well done,

-Kevin

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Tue Oct 12, 2010 11:34 am
by cra1g321
kevinmckay wrote:Worked great the first time.

Thank you for taking the time to clearly document all the steps.

Well done,

-Kevin


Thnx alot, just trying to make it easier for others 8)

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Mon Dec 06, 2010 1:26 pm
by xzero
i just registered to thank you for this!!!.. it solved the major problem of the ipod not beign recognized by rythmbox however now i cant drag and drop songs into it... any idea why this might be happening?

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Mon Dec 06, 2010 6:15 pm
by cra1g321
xzero wrote:i just registered to thank you for this!!!.. it solved the major problem of the ipod not beign recognized by rythmbox however now i cant drag and drop songs into it... any idea why this might be happening?


i honestly dont know. Its never done that for me, im afraid i cant really help you as i havent used LM9 for months (on lM10/ubuntu10.10 )

the only thing i can think of is make sure that you initialized the ipod on windows 1st (only need to do this if its the 1st time you are using the ipod)
and i reconmend transferring a few songs over using itunes on a windows pc then connecting it to LM then trying to copy over songs.

Though i would also reconmend using LM10 as my ipod touch works straight away without any problems :)

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Mon Mar 28, 2011 10:16 am
by madhatter4119
This was far to easy to do for me in LM10...Keep up the great work...Thanks a Million

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Tue Feb 21, 2012 9:05 am
by minty34
Thank you for this useful tuto !
In addition I found a great app "Remote 4 Media Player" that allows me to remotely control Rhythmbox with my iPhone.

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Wed Feb 22, 2012 8:13 pm
by osxaberlite
What a fabulous little tutorial!

Thanks so much for taking the time to put up the detailed info. It worked for me on LM-Julia. I did get one error message at one point and I just ignored it.
Also the following four files in step 3 were not listed under 'upgradable' but 'all'
gvfs
gvfs-backends
gvfs-bin
gvfs-fuse

Thought I should put it out there - it is the least I could do compared to what you've done :)

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Thu Mar 29, 2012 6:17 pm
by Black_Ninja
So I followed the instructions and it is not working. Ipod touch is 5.0.1 and the comp is not recognizing it at all. :(

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Fri Mar 30, 2012 9:23 am
by AlbertP
Your device or iOS version is probably not yet supported (or you could try it in a newer Mint version than 9).

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Thu May 17, 2012 7:15 pm
by Black_Ninja
AlbertP wrote:Your device or iOS version is probably not yet supported (or you could try it in a newer Mint version than 9).

I upgraded to LM 12 and now it works :) :D

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Thu May 31, 2012 4:06 pm
by cra1g321
Wow can't believe I wrote this tutorial 2 years ago, I must say i rather forgot about it. Though i doubt many people are using LM9 since the new LTS is now out.

madhatter4119 wrote:This was far to easy to do for me in LM10...Keep up the great work...Thanks a Million

minty34 wrote:Thank you for this useful tuto !

osxaberlite wrote:What a fabulous little tutorial!


Thank you for the comments :D

Black_Ninja wrote:I upgraded to LM 12 and now it works :) :D


Glad to hear you got it working :D

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Fri Jul 12, 2013 2:44 am
by NDER
Will these steps, primarily 1-3, work on LM15 for an iPod Touch Sec. Gen. running iOS4? I want to use Banshee but I can't even get my iPod to mount.

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Fri Jul 12, 2013 6:05 am
by AlbertP
@ NDER: The mentioned PPA does not contain packages for todays Mint releases, only for 11 and before.

Re: Add ipod/iphone iOS4 support to Rhythmbox (LM9 Gnome)

Posted: Fri Jul 12, 2013 12:31 pm
by NDER
That is disappointing. Anybody feel up to writing a tutorial like this for Mint 15? I would love to have full use of my iPod again (without dual-boot or VM).