How to fix the pidgin-data 2.7.8 error

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
ridin
Level 1
Level 1
Posts: 3
Joined: Tue Sep 07, 2010 11:47 pm

How to fix the pidgin-data 2.7.8 error

Post by ridin » Wed Dec 22, 2010 12:06 am

If you got the latest pidgin from removed you'll have an error about an image being the same in pidgin-facebookchat. Here's how I got it working, however you'll not be able to install pidgin-facebookchat again:

First thing I did was deactivate all repos from the Software Sources (Menu -> Administration -> Software Sources)
Click the Tab where it says "Other software" and uncheck everything you see there.

Next, open up /etc/apt/sources.list as root and add a # in front of each line. DO NOT DELETE IT!

Open up a terminal and type in sudo apt-get update. If it hits and repos, you missed something.

Next,

Code: Select all

sudo apt-get -f install
, which should remove pidgin and libnotify-bin. It also tells you that pidgin-data isn't needed anymore, but you don't need to worry about that.

sudo apt-get remove pidgin-facebookchat , it might tell you that some directories are not empty, but that's okay.

now,

Code: Select all

cd /var/cache/apt/archives

Code: Select all

sudo dpkg -i pidgin-data_1%3a2.7.8-1~removed1_all.deb
(If it says file not found then you'll need to renable the removed repo from the Software Sources then sudo apt-get install pidgin-data instead)

Activate all the repos again, by removing the #'s in /etc/apt/sources.list and from the and Software Sources. Then sudo apt-get update && sudo apt-get install pidgin.

Happy "Pidgining"!

User avatar
bug67
Level 2
Level 2
Posts: 92
Joined: Thu Feb 25, 2010 10:11 am
Location: Anchorage, AK
Contact:

Re: How to fix the pidgin-data 2.7.8 error

Post by bug67 » Wed Dec 22, 2010 11:14 am

Yay! This fixed my issue with Pidgin! :D

The only thing I would would be that, I had to completely uninstall Pidgin before I began your procedure. After that, it worked like a charm! :mrgreen:
Asus X550CA Linux Mint 18.3 Cinnamon
CPU: Intel Core i3-3217U @ 1.80GHz x2
RAM: 12 GiB, SSD: 250 GiB
http://www.vegetablesandwich.com/

henry_700
Level 1
Level 1
Posts: 4
Joined: Tue Dec 21, 2010 8:58 pm

Re: How to fix the pidgin-data 2.7.8 error

Post by henry_700 » Wed Dec 22, 2010 10:24 pm

During application of this procedure, I have lost two packages from my system: mint-meta-gnome and mint-meta-x64 - command line output below.
Have opened new topic to confirm that this solution is final and stable: http://forums.linuxmint.com/viewtopic.php?f=47&t=62367

Code: Select all

black ~ # apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  mint-meta-gnome mint-meta-x64 pidgin pidgin-libnotify
0 upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 2,208kB disk space will be freed.
Do you want to continue [Y/n]? 
(Reading database ... 149094 files and directories currently installed.)
Removing pidgin-libnotify ...
Removing mint-meta-x64 ...
Removing mint-meta-gnome ...
Removing pidgin ...
Processing triggers for man-db ...

ridin
Level 1
Level 1
Posts: 3
Joined: Tue Sep 07, 2010 11:47 pm

Re: How to fix the pidgin-data 2.7.8 error

Post by ridin » Thu Dec 23, 2010 6:40 pm

Oh, I forgot about the meta packages. It's totally fine, you don't need to worry. Pidgin doesn't need mint-meta packages, however that package needs pidgin since it's included inside mint by default.

User avatar
ibm450
Level 5
Level 5
Posts: 603
Joined: Sun Jan 11, 2009 6:56 am
Location: Kwinana, Western Australia

Re: How to fix the pidgin-data 2.7.8 error

Post by ibm450 » Fri Dec 24, 2010 9:19 am

my word!!!!

all this just to install a app in linux........ :shock: :shock:
Asus UL50VT laptop ~ LM10 - Unity 12.04 - Win 7
Image

User avatar
WSiaB
Level 1
Level 1
Posts: 2
Joined: Thu Dec 30, 2010 4:57 am
Location: Concord, CA USA

Re: How to fix the pidgin-data 2.7.8 error

Post by WSiaB » Thu Dec 30, 2010 5:16 am

Not to install an app, rather to fix a problem with an app. Pidgin is creating internal conflict problems.

User avatar
ibm450
Level 5
Level 5
Posts: 603
Joined: Sun Jan 11, 2009 6:56 am
Location: Kwinana, Western Australia

Re: How to fix the pidgin-data 2.7.8 error

Post by ibm450 » Thu Dec 30, 2010 9:44 am

mine finally worked after uninstalling the facebook plugin for pidgin
Asus UL50VT laptop ~ LM10 - Unity 12.04 - Win 7
Image

Post Reply

Return to “Tutorials”