HOWTO: Get your VIA EX10000EG running in Mint.

Write tutorials here
There are more tutorials here
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Level 3
Level 3
Posts: 104
Joined: Fri Dec 14, 2007 11:59 am

HOWTO: Get your VIA EX10000EG running in Mint.

Postby chowanec » Sun Dec 23, 2007 3:26 am

HOWTO: Get your VIA EX10000EG (and probably the EX15000EG) to load Mint


Hi there. I had a HELL of a time getting this working, learning ALL about linux in the process. So, I'm not some super-rockstar linux user. I'm a guy who got tired of Windows and then got cocky. And then relied on the wisdom of the folks at and to bail me out. :) Anyways, if you're setup is anything like mine, see if this works for you!

I've never written one of these before, so bear with me. But I learned so much of what to do, that I wanted to spare someone else the pain. :)

If it doesn't work, please let me know where. For any of you wise veterans, please let me know where I've gone wrong, and I'll fix it.


Special Thanks:
TuxCrafter: your is a life-saver to someone who knows NOTHING of linux.
Husse, Acid7711, Darkone, NewW2 at again, your patience is a god-send. :)
Blueridgedog and the bunch: hard to complain when you get an OS for free...even harder to fathom the willingess of strangers to help.



Do yourself a favor and before you start, do the following:

1. Go here and grab the latest

Code: Select all

2. Put both of these things on a memory stick or a floppy or something. I used a memory stick.

3. Write these down:

Code: Select all

nano /var/log/Xorg.0.conf
nano /etc/X11/xorg.conf

The first is the logfile from when the graphical environment (GNOME) tries to start. I constantly was checking this for information. The second is your xorg.conf file... you might be editing it frequently.

4. Go grab the latest Linux Mint distribution and burn it to disc.

Code: Select all


Step 1: Install Linux Mint 4.0 LIVE CD from a working PC
I used my Vista PC to do this from -- I had major issues with the built-in video on the motherboard, so I decided to give it a shot to install the OS on another machine altogether and then just move the HDD to the case for the EX10000EG. I wasn't anticipating this working and then the linux community reminded me this wasn't windows and that you could change the hardware out and still have the install work. God bless common sense.

I just blast through it using mostly the defaults -- set my timezone, keyboard, etc. This should all be pretty straightforward.

Once done, shut down your "instll PC" and move your HDD over to your EX10000EG. Power that up, but keep your fingers ready to interrupt the GRUB menu.

Step 2: Set the right boot device
This may not be an issue for you, it was for me. After moving the HDD into the EX10000EG motherboard I couldn't boot as the "default" boot device from my install PC didn't match the EX10000EG. Relatively simple fix, really. At the GRUB Boot menu, I had to replace sda with hda. This allowed me to boot into the shell. To do this, wait until the GRUB boot menu shows up and then hit the DOWN arrow to select "Safe Recover" option. Once on that menu item, use the arrow keys to replace (in my case) /dev/sda1 with /dev/hda1

This will allow you to boot to the shell. Once at the shell, login with the credentials you set during the initial install.

At your command prompt, do this:

Code: Select all

sudo nano /boot/grub/menu.lst

All the way at the bottom of the file, you should make the changes you JUST made to get this far -- replace "sda1" with "hda1" -- if in fact your default boot device doesn't already say "hda1". I had to do this in two places -- once for the "normal boot" and once for the "safe recovery" option.

NOTE: Don't search for "sda1" -- your install PC might have done something different.

Ctrl-X to save and exit nano. Say "yes" when overwriting.

Step 3: Get your GNOME on...
From the same command line you edited the menu.lst file from, let's go and make some changes to your xorg.conf. My big issue was that it would never boot the X server (what drives the GNOME environment). It would fail 6 times in 90 seconds. Wait two minutes and try again. It was never-ending... and totally frustrating. Our goal at this moment is to just get into GNOME in safe-graphics mode. Here's how I did it, from the command line:

Backup the exisiting xorg.conf:

Code: Select all

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup.howto

Now edit the xorg.conf to add some valid video modes:

Code: Select all

sudo nano /etc/X11/xorg.conf

I entered some valid modes (for my display) under:

Code: Select all

Device   "Screens"
   ... <there will already be something here>
   Modes "1024x768" "800x600" "640x480"

Ctrl-X to save. Say "yes" when overwriting.

Go ahead and try to start the graphical desktop. From the command line type:

Code: Select all

init 5

Congrats -- the hardest part (hopefully!) is over.

Step 4: Install the OpenChrome drivers
Remember that prep-work from earlier? Well, we're going to use it now. Go to the directory/folder/drive that you stored that file. Remember that path. Open a terminal window (right click on the Mint desktop and select "Open Terminal"), navigate to the folder where lives and type:

Code: Select all

sudo sh

It is now going to ask you a HUGE amount of questions. I selected YES to each of them.

At this point, I run the reconfigure for xorg by typing:

Code: Select all

dpkg-reconfigure xserver-xorg

Follow the instructions, pay close attention, this is where I get the actual drivers to work on reboot. When presented with the video device options, scroll up/down until you find "OpenChrome" select that one. If you're using DVI Out, add this to your xorg.conf under the "Device" section:

Code: Select all

Option      "VBEModes"      "true"

Also, add this to xorg.conf (I add it at the top.) If you have a Module section already, check to see if any of these modules are already listed as "Load" and change them to "Disable". In my case, I had to add the entire section. This disables the 3D rendering for the OpenChrome drivers, as of Dec-22-2007, they would cause corruption/freezing in GNOME.

Code: Select all

Section "Module"
    Disable "glx"
    Disable "xtrap"
    Disable "record"
    Disable "GLcore"
    Disable "dri"

Since you're already (hopefully) in GNOME, you can restart it by pressing:

Code: Select all


Or, if you prefer to be safe, like me, reboot the PC.

Step 5: Beverage break!
If you are of legal drinking age, open a beer. The HARDEST part is over. Upon reboot/reinit of GNOME, you should see a much faster desktop environment. Movies will playback at a decent clip, etc.

Step 6: Having Audio Issues?
I had audio issues with this motherboard as well. All of my audio was playing at an incredibly low volume. Sluething on the internet, revlealed this... from a terminal window type:

Code: Select all


Use the left/right arrows to change categories and UP/DOWN to increase the volume of those inputs. I maxed everything out. On reboot, you should be working now. From here... well, it's about package installation, etc. I'll let someone else handle that stuff.

Step 7: What the Hell...
Have another cold one. Everything should (mostly) work now. :)



Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: HOWTO: Get your VIA EX10000EG running in Mint.

Postby Husse » Sun Dec 23, 2007 8:13 am

The command line did not eat you for breakfast :)
If this does not work for you read it through slowly and make some small adjustments - it looks very promising
Don't fix it if it ain't broken, don't break it if you can't fix it

Return to “Tutorials”