Remove fortune message from console MiniHowto

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
linuxrev
Level 1
Level 1
Posts: 5
Joined: Sun Jul 24, 2011 1:49 pm
Location: Wildervank, The Netherlands
Contact:

Remove fortune message from console MiniHowto

Postby linuxrev » Sun Oct 16, 2011 4:09 pm

By default a fortune message will appear if you open a terminal or go to the console (e.g. Alt+F1). Some like it, some loathe it. How to disable this fun thingy if you don't like it? Here is what I found, summarizing the confusing list of posts on this subject. (Makes you wonder why there is no easy checkbox somewhere in Control Panel or System Settings?)

1. LinuxMint 11x:

Edit as root: /etc/bash.bashrc and comment out its last line
('/usr/bin/mint-fortune')

2. LinuxMint 10x:

Edit as root: /usr/bin/mint-fortune and comment out its last line
('/usr/games/fortune | $command -f $cow')

NOTE:
'Edit as root' means:
- open a terminal
- type (GNOME): $ gksudo gedit [path+filename]
or (KDE): $ gksudo kwrite [path+filename]

NOTE:
'comment out' means:
adding a '#' at the very beginning of a line of code

I hope this is helpful for LinuxMint newbies like me.

--
linuxrev

:: cogito quod sum ::
linuxrev
--
cogito quod sum

User avatar
xenopeek
Level 23
Level 23
Posts: 19032
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Remove fortune message from console MiniHowto

Postby xenopeek » Sun Oct 16, 2011 4:14 pm

Uh, that is a bit more complex then needed for Linux Mint 11. You can just go to Menu > Control Center > Desktop Settings, select the Terminal tab, and remove the checkmark in front of "Show fortune cookies" :wink:
Image

linuxrev
Level 1
Level 1
Posts: 5
Joined: Sun Jul 24, 2011 1:49 pm
Location: Wildervank, The Netherlands
Contact:

Re: Remove fortune message from console MiniHowto

Postby linuxrev » Mon Sep 03, 2012 3:07 pm

True, but only if you run GNOME desktop. I'm stuck to KDE, which doesn't have that easy checkbox. Nevertheless, since we have arrived at LinuxMint 13 now, the whole issue is obsolete.
linuxrev
--
cogito quod sum


Return to “Tutorials”

Who is online

Users browsing this forum: Google Feedfetcher and 5 guests