Grub doesn't work Asus S550C

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
silveringking
Level 2
Level 2
Posts: 70
Joined: Sun Jul 31, 2011 9:52 pm
Location: Fafe, Portugal

Grub doesn't work Asus S550C

Postby silveringking » Tue May 30, 2017 4:35 am

Hi, here is the problem, I had Mint installed on my laptop. I wanted to install it parallel to my Windows 10, however after installation, grub doesn't seem to work, my computer automatically loads Windows 10. I have tried to do a parallel install of Mint in the traditional way (letting Mint define the partitions), and I tried to define my partitions with Gparted and using the "one more thing" to choose myself the partitions, both ways don't work at all. It seems to be that either grub was installed in the wrong partition or wasn't installed at all.

Can you help me?

Thanks!

User avatar
Pjotr
Level 17
Level 17
Posts: 7944
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Grub doesn't work Asus S550C

Postby Pjotr » Tue May 30, 2017 5:15 am

In the UEFI settings, move Windows Boot Manager to the bottom of the boot priority list:
https://sites.google.com/site/easylinux ... rity-order
(item 2.2, left column)

Sometimes it's called OS Boot Manager; in that case, expand that category and put Windows Boot Manager at the bottom.
Tip: 10 things to do after installing Linux Mint 18.2 Sonya
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

michael louwe
Level 5
Level 5
Posts: 510
Joined: Sun Sep 11, 2016 11:18 pm

Re: Grub doesn't work Asus S550C

Postby michael louwe » Tue May 30, 2017 10:08 am

@ silveringking

Please refer to Steps 17 & 18 of this link .......
https://www.tecmint.com/install-linux-m ... uefi-mode/

silveringking
Level 2
Level 2
Posts: 70
Joined: Sun Jul 31, 2011 9:52 pm
Location: Fafe, Portugal

Re: Grub doesn't work Asus S550C

Postby silveringking » Sun Jun 18, 2017 11:46 am

Pjotr wrote:In the UEFI settings, move Windows Boot Manager to the bottom of the boot priority list:
https://sites.google.com/site/easylinux ... rity-order
(item 2.2, left column)

Sometimes it's called OS Boot Manager; in that case, expand that category and put Windows Boot Manager at the bottom.


Hi I did some testing today (sorry for taking so long).

Long story, it didn't work.

I have two boot options in my uefi, my dvd player and windows. I tried switch it asked my to reboot the pc and switch it back, I also tried to disable it and it didn't work, plus my UEFI doesn't have a safe boot option, so I couldn't disable that.

Any help would be nice.

Thanks!

Ps: I once managed to install an older version of mint on my laptop, don't remember exactly what I did.

michael louwe
Level 5
Level 5
Posts: 510
Joined: Sun Sep 11, 2016 11:18 pm

Re: Grub doesn't work Asus S550C

Postby michael louwe » Sun Jun 18, 2017 12:43 pm

@ silveringking

Try disable Fast Startup in Win 10 through the Power Options menu, then see if LM can be booted through the Grub menu during computer startup.

fabien85
Level 5
Level 5
Posts: 860
Joined: Tue Mar 11, 2014 4:30 pm

Re: Grub doesn't work Asus S550C

Postby fabien85 » Mon Jun 19, 2017 4:09 am

Definitively disable fast startup in windows : https://www.tenforums.com/tutorials/4189-turn-off-fast-startup-windows-10-a.html
Note that this is a windows thing, and it's different from fast boot, which is a setting in the machine firmware (and may or not be there for you, and has no influence on your capability to boot linux).

However that wont be enough :
I have two boot options in my uefi, my dvd player and windows.

it seems grub didnt get registered in the UEFI. There are basically two possible reasons why :
- there was a mistake during install, e.g. the live USB was booted in Legacy mode instead of UEFI, or you didnt indicate the good partition in "device for bootloader installation".
- the firmware is buggy, either the linux utility efibootmgr cannot interact with it or the firmware "forgets" boot entries which are not windows ones. We do see that type of problem from time to time on the forum.

The simplest option which should solve everything : install the refind boot manager, manually from windows.

User avatar
Laurent85
Level 12
Level 12
Posts: 4402
Joined: Tue May 26, 2015 10:11 am
Location: Vendée, France

Re: Grub doesn't work Asus S550C

Postby Laurent85 » Mon Jun 19, 2017 9:52 am

Acer computer, see the computer configuration setup, you need to enable booting from Mint see https://ubuntuforums.org/showthread.php ... st13628297
Image
H: Pedro, est-ce le chant du fufu ou l'odeur du poivrier,
H: Je me sens une autre femme ?
P: Honorine, viens sous les palétuviers.
H: Sous les palétuviers ? Oh ! Vous en avez de ces mots.

hcentaur13
Level 1
Level 1
Posts: 19
Joined: Sat May 18, 2013 5:13 pm

Re: Grub doesn't work Asus S550C

Postby hcentaur13 » Tue Jun 20, 2017 2:03 pm

The problem is the difference between plain old DOS and UEFI. When one system is installed in UEFI mode then all systems have to be installed using UEFI. The easiest way to get it is boot up UEFI for install UEFI or msdos for plain old DOS mode.

You needs to boot up the installer in UEFI or BIOS mode respectively to let the installer do it right. That works so fpr wwindows 7 and 10 and Linux.

Depending on your BIOS you may need to hold F9, F2, F10 or F12 to get the BIOS to shou up the BIOS-boot-menue or go to BIOS setup for that.


Return to “Installation & Boot”

Who is online

Users browsing this forum: Chizim, RobertX and 9 guests