Dual Boot with Windows 10: no Mint GUI; only GRUB4DOS

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Ken355
Level 1
Level 1
Posts: 4
Joined: Sat Jan 20, 2018 9:44 pm

Dual Boot with Windows 10: no Mint GUI; only GRUB4DOS

Post by Ken355 » Sat Jan 20, 2018 10:21 pm

I created a dual boot laptop with Windows 10 and Mint 18.3 xfce. I followed the video instructions, and everything went well. But when I reboot the PC, Windows 10 starts automatically; it doesn't ask which OS I want. I followed the instructions on the "Easy Linux Tips Project" website with regard to moving OS Boot Manager to the bottom of the boot order in the BIOS. That didn't work; it was already at the bottom.

So, I installed "EasyBCD" Boot manager. I followed a setup video from YouTube. Now, I have a choice on startup to boot to Windows 10 or Linux Mint. The problem, is if I choose Linux Mint, I don't get the Mint GUI. I get a black screen that the first line says is "GRUB4DOS 0.4.5c". I cannot get the Mint GUI to start. Help!

Windows 10
Linux Mint 18.3 xfce
HP Elitebook 8440p

User avatar
michael louwe
Level 8
Level 8
Posts: 2141
Joined: Sun Sep 11, 2016 11:18 pm

Re: Dual Boot with Windows 10: no Mint GUI; only GRUB4DOS

Post by michael louwe » Sun Jan 21, 2018 2:55 am

@ Ken355, .......
Ken355 wrote:...
.
The actual problem may lie with your Nvidia graphics card. Please refer to ... https://linuxmint.com/rel_sonya_cinnamon.php
viewtopic.php?f=46&t=122257
.
For Nvidia, if still unsuccessful, try modprobe.blacklist=nouveau
.
.
Windows cannot read Linux files but Linux can read Windows files = install Linux after Windows to let Linux Grub controls the boot process. Windows Boot Manager cannot boot Linux. I think you should not have used EasyBCD to solve the boot problem.

In your case, if EasyBCD or other methods does not solve the boot problem, try reinstalling LM 18.3 Xfce. Use the manual "Something else" install method, delete all the Linux partitions to create a new free-space, partition the free-space accordingly( viewtopic.php?f=42&t=122276 ) and ensure that the "Device for boot loader installation" is the internal hard-drive, ie /sda.(since you have a Legacy BIOS computer from around 2010)
... After installation, repeatedly press the SHIFT or ESC key during startup to force the Grub Menu to appear.

Mute Ant
Level 13
Level 13
Posts: 4721
Joined: Tue Sep 03, 2013 7:45 pm

Re: Dual Boot with Windows 10: no Mint GUI; only GRUB4DOS

Post by Mute Ant » Sun Jan 21, 2018 1:04 pm

The GRUB4DOS loader is 'legacy GRUB'. It understands MBR partitioned drives but not GPT. It's worth finding out which sort of partitioning you are using. I suspect a Windows 10 machine uses GPT partitions and UEFI to boot. If that's the case, GRUB4DOS is useless.
Right at the bottom, all alone in the centre of the bright cold floor, was a lemon drop.

Ken355
Level 1
Level 1
Posts: 4
Joined: Sat Jan 20, 2018 9:44 pm

Re: Dual Boot with Windows 10: no Mint GUI; only GRUB4DOS

Post by Ken355 » Sun Jan 21, 2018 1:35 pm

Michael, thanks for your response. I fixed the issue by reinstalling Mint as you suggested at the bottom of your response. Prior to that, I uninstalled EasyBCD, because it wasn't helping me at all.

I should have started out by saying my experience with Linux is less than one week, so I still don't understand a lot of responses I have been getting on various forums. :(
For Nvidia, if still unsuccessful, try modprobe.blacklist=nouveau
Is this a Terminal command? Apparently I don't need it now anyway.

So now when I start the PC, I get a menu with the title "GNU GRUB" at the top. Is there a way to edit this menu to, for example, increase the countdown time? And since this menu is present, does it still matter how the boot order is set in the BIOS?

Mute Ant, my laptop has an option in BIOS to enable or disable UEFI. By default it's disabled. When enabling it, HP recommends not using it. With my issue it didn't seem to make a difference either way. And, GRUB4DOS is useless to me anyway, as I don't know what it is or how to use it. :wink:

User avatar
michael louwe
Level 8
Level 8
Posts: 2141
Joined: Sun Sep 11, 2016 11:18 pm

Re: Dual Boot with Windows 10: no Mint GUI; only GRUB4DOS

Post by michael louwe » Sun Jan 21, 2018 2:50 pm

@ Ken355, .......
Ken355 wrote:For Nvidia, if still unsuccessful, try modprobe.blacklist=nouveau
Is this a Terminal command? Apparently I don't need it now anyway. ...
It's the same as setting the nomodeset kernel boot parameter.
.
So now when I start the PC, I get a menu with the title "GNU GRUB" at the top. Is there a way to edit this menu to, for example, increase the countdown time? And since this menu is present, does it still matter how the boot order is set in the BIOS?
Please refer to ... https://community.linuxmint.com/tutorial/view/1977 (changing Grub timeout) and https://sites.google.com/site/easylinux ... -boot-menu (change default OS to Windows - use gedit which is preinstalled in LM = no need for the leafpad text editor)

I do not get your latter question about boot order. Normally, the BIOS Boot order setting is to allow the users to boot first from certain devices, eg internal hard-drive or DVD-drive or USB flash-drive, Floppy drive, Networked drive, etc.
... The Grub menu only allows the users to boot whichever selected OS that are on the internal hard-drive, ie after the computer has already booted from the internal hard-drive. Actually, the Grub menu is being read from a file on the Root partition of LM, ie it is not being read from BIOS firmware. BIOS Boot order setting is being read from BIOS firmware.

Ken355
Level 1
Level 1
Posts: 4
Joined: Sat Jan 20, 2018 9:44 pm

Re: Dual Boot with Windows 10: no Mint GUI; only GRUB4DOS

Post by Ken355 » Sun Jan 21, 2018 5:19 pm

Michael, at the link you referred to with regard to changing the GRUB timeout;
sudo gedit /etc/default/grub
this results in a "command not found" error. I did find other instructions for changing the timeout, but the change doesn't stick after a reboot. Is it "grub" or "grub2"?

rickNS
Level 3
Level 3
Posts: 145
Joined: Tue Jan 25, 2011 11:59 pm

Re: Dual Boot with Windows 10: no Mint GUI; only GRUB4DOS

Post by rickNS » Sun Jan 21, 2018 7:35 pm

The error is because mint 18.* doesn't come with gedit. The mint 18.* text editor is called xed. so

sudo xed /etc/default/grub
Mint 18 mate on 2 identical Thinkpad T420's

User avatar
michael louwe
Level 8
Level 8
Posts: 2141
Joined: Sun Sep 11, 2016 11:18 pm

Re: Dual Boot with Windows 10: no Mint GUI; only GRUB4DOS

Post by michael louwe » Mon Jan 22, 2018 2:24 am

@ Ken355, .......
Ken355 wrote:...
.
Did you "save" the changes in the xed text editor.?

Did you "sudo update-grub".?

Ken355
Level 1
Level 1
Posts: 4
Joined: Sat Jan 20, 2018 9:44 pm

Re: Dual Boot with Windows 10: no Mint GUI; only GRUB4DOS

Post by Ken355 » Mon Jan 22, 2018 6:46 am

Yes, I figured it out. All is well for now; thanks!

Post Reply

Return to “Installation & Boot”