Boot leads to guest session (Solved)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Julien_Skrobek
Level 1
Level 1
Posts: 9
Joined: Sat Apr 21, 2018 12:42 pm

Boot leads to guest session (Solved)

Post by Julien_Skrobek » Sat Apr 21, 2018 12:52 pm

Hello,

I am new to Linux. I am running linuxmint-18.1-cinnamon-64bit on a lenovo T410.

Here is my problem:

When I switch on my computer it automatically opens in a guest session.

I log out of the session and am redirected to the connection window where the only login possible is the administrator one (which I want and select).

But I'm sure there is a way to solve this issue and land directly on the connection window or the admin. session.

Thanks in advance for your help !
Last edited by Julien_Skrobek on Sun Apr 22, 2018 1:57 pm, edited 1 time in total.

Cosmo.
Level 23
Level 23
Posts: 17824
Joined: Sat Dec 06, 2014 7:34 am

Re: Boot leads to guest session

Post by Cosmo. » Sat Apr 21, 2018 3:59 pm

I cannot follow. Mint 18.1 uses the mdm display manager, which does not have a guest session.

To confirm, what you really have do this:
Open a terminal and enter:

Code: Select all

inxi -Szxx
Paste the output here.

Julien_Skrobek
Level 1
Level 1
Posts: 9
Joined: Sat Apr 21, 2018 12:42 pm

Re: Boot leads to guest session

Post by Julien_Skrobek » Sun Apr 22, 2018 4:52 am

Cosmo. wrote:
Sat Apr 21, 2018 3:59 pm
I cannot follow. Mint 18.1 uses the mdm display manager, which does not have a guest session.

To confirm, what you really have do this:
Open a terminal and enter:

Code: Select all

inxi -Szxx
Paste the output here.
Hello, thank you for your reply.

You were right, I used the command you indicated and I have Mint 18.3

I still have the same problem and I can't seem to find a command that would tell the system to boot on admin.session.

Cosmo.
Level 23
Level 23
Posts: 17824
Joined: Sat Dec 06, 2014 7:34 am

Re: Boot leads to guest session

Post by Cosmo. » Sun Apr 22, 2018 5:45 am

Open the login screen settings -> users -> enter in the last section our user name. Reboot.

Julien_Skrobek
Level 1
Level 1
Posts: 9
Joined: Sat Apr 21, 2018 12:42 pm

Re: Boot leads to guest session

Post by Julien_Skrobek » Sun Apr 22, 2018 6:21 am

Thanks for your input.

I opened login session.

Manual connection = enabled
Allow guest to login: disabled
Automatic login: my admin. user ID

I still have the same problem after reboot with these parameters.

Cosmo.
Level 23
Level 23
Posts: 17824
Joined: Sat Dec 06, 2014 7:34 am

Re: Boot leads to guest session

Post by Cosmo. » Sun Apr 22, 2018 6:44 am

Julien_Skrobek wrote:
Sun Apr 22, 2018 6:21 am
Manual connection = enabled
Allow guest to login: disabled
Automatic login: my admin. user ID
The first option should not matter, default is off.
With the second option disabled you should not ne able to enter a guest session. What makes you think, that you are in a guest session?
Regarding the third: Open a terminal and enter whoami. Enter the user name exactly, as whoami presents it.

Julien_Skrobek
Level 1
Level 1
Posts: 9
Joined: Sat Apr 21, 2018 12:42 pm

Re: Boot leads to guest session

Post by Julien_Skrobek » Sun Apr 22, 2018 6:52 am

Cosmo. wrote:
Sun Apr 22, 2018 6:44 am
What makes you think, that you are in a guest session?
My changes have no durability if I work in the session that opens at boot. In this case, at reboot the session is a clean slate.

If I logout and relog with my user name (which is correct, I tested using the command you indicated) everything is as I left it when I logged out of my previous session.

Cosmo.
Level 23
Level 23
Posts: 17824
Joined: Sat Dec 06, 2014 7:34 am

Re: Boot leads to guest session

Post by Cosmo. » Sun Apr 22, 2018 7:00 am

What does whoami give in the supposed guest session?

Julien_Skrobek
Level 1
Level 1
Posts: 9
Joined: Sat Apr 21, 2018 12:42 pm

Re: Boot leads to guest session

Post by Julien_Skrobek » Sun Apr 22, 2018 7:32 am

Cosmo. wrote:
Sun Apr 22, 2018 7:00 am
What does whoami give in the supposed guest session?
whoami command gives my admin. user name.

It seems all my changes remain this time, except for the wallpaper of the desk. I have tried multiple times to change it but each time I reboot it goes back to the standard Mint wallpaper.

The rest has durability.

I now believe you are right and there is one single session.

But why do I have to log out and relog to find the changed wallpaper again ?

Admittedly this is a much smaller problem that I first thought, but I still don't understand what goes on at reboot.

Cosmo.
Level 23
Level 23
Posts: 17824
Joined: Sat Dec 06, 2014 7:34 am

Re: Boot leads to guest session

Post by Cosmo. » Sun Apr 22, 2018 9:16 am

Julien_Skrobek wrote:
Sun Apr 22, 2018 7:32 am
I now believe you are right and there is one single session.
You can bet on it. whoami does not lie.

The problem is possibly caused by some wrong ownership of files and folders in your whom. To inspect this:
Mark the following command and press ctrl-c

Code: Select all

find $HOME ! -user $USER -type f
open a terminal and press ctrl-shift-V
Mark the complete result inclusive the command with the mouse and press ctrl-shift-C
In the forum click the Code-button (looks like </>) above the text edit box, than press ctrl-v.

Report in case, that there is no output.

Julien_Skrobek
Level 1
Level 1
Posts: 9
Joined: Sat Apr 21, 2018 12:42 pm

Re: Boot leads to guest session

Post by Julien_Skrobek » Sun Apr 22, 2018 10:25 am

OK, your comment made me realize I had not specified that the wallpaper was located on an external drive.

I copied the jpeg into LM image folder and it works fine now, there is permanence.

However, if the problem was really this, it still doesn't explain to me why the wallpaper I chose came back when I logged out/re-logged.

Perhaps the os doesn't have the time to load the external drive at automatic login but logging out/login in gives it time to do it.

But now it works.

Cosmo.
Level 23
Level 23
Posts: 17824
Joined: Sat Dec 06, 2014 7:34 am

Re: Boot leads to guest session

Post by Cosmo. » Sun Apr 22, 2018 2:23 pm

Julien_Skrobek wrote:
Sun Apr 22, 2018 10:25 am
Perhaps the os doesn't have the time to load the external drive at automatic login but logging out/login in gives it time to do it.
You have fond it. Very good.

Julien_Skrobek
Level 1
Level 1
Posts: 9
Joined: Sat Apr 21, 2018 12:42 pm

Re: Boot leads to guest session (Solved)

Post by Julien_Skrobek » Sun Apr 22, 2018 2:40 pm

Thank you Cosmo, you really led me to that conclusion by telling me to check the path :)

Post Reply

Return to “Installation & Boot”