New build prime b350-plus W Ryzen 2200g no go

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
bhoth
Level 1
Level 1
Posts: 16
Joined: Fri Nov 04, 2011 9:17 am

New build prime b350-plus W Ryzen 2200g no go

Post by bhoth » Mon Sep 24, 2018 11:30 pm

Hi all, brand new build with the components listed in the subject and Linux Mint Mate 19 will not install. Getting a bunch of different errors.
I did some searching and it looks like maybe I need a newer kernal but how do you start a clean install with a newer kernal?

User avatar
rev667
Level 1
Level 1
Posts: 29
Joined: Fri Mar 21, 2014 12:50 pm

Re: New build prime b350-plus W Ryzen 2200g no go

Post by rev667 » Tue Sep 25, 2018 1:58 am

Hi,
I'm having similar issues. B350 mainboard + Ryzen 2400G

I dual boot so might be different. The steps I took were to install in compatibility mode, this got me to a software rendered desktop.
Then I added "ukuu" which lets you use new kernels.

Code: Select all

sudo add-apt-repository ppa:teejee2008/ppa
sudo apt-get update
sudo apt-get install ukuu 
I grabbed the latest stable kernel 4.18.8

Next I added the latest MESA for the graphics.

Code: Select all

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update
It's stable when it boots, but sometimes hangs during boot and shutdown.

I'm fairly happy to run with this, I'm sure Ryzen support will catch up.
Personally I suspect my mainboard for the boot hangs, I'll keep checking for a BIOS update. Oh and the temperature sensors don't work on mine.

Hope this helps, or points you at another idea.

Rev
Kernel: 4.18.8-041808-generic x86_64
Linux Mint 19 Tara Cinnamon 3.8.9
Mobo: MSI B350M GAMING PRO
CPU: Quad core AMD Ryzen 5 2400G with Vega Graphics
Graphics: [AMD/ATI] Vega - 1920x1080@60hz
OpenGL: AMD RAVEN Mesa 18.3.0-devel

bhoth
Level 1
Level 1
Posts: 16
Joined: Fri Nov 04, 2011 9:17 am

Re: New build prime b350-plus W Ryzen 2200g no go

Post by bhoth » Tue Sep 25, 2018 3:49 pm

Hi, after calling Asus I can finally get the install disk to run. Now I get up to this screen. The screen is split with a second rendering of the first (Split):

How do I resolve this? This is a Linux Mint Mate 19 64bit install DVD disk.

Thank you for any help!
Image

MatNieuw
Level 1
Level 1
Posts: 29
Joined: Sun Mar 11, 2018 4:45 pm

Re: New build prime b350-plus W Ryzen 2200g no go

Post by MatNieuw » Fri Sep 28, 2018 7:32 am

Hi,
I had the same "split screen problem" with an Asrock B450 motherboard with Ryzen 3 2200G CPU. At install time, I could get around it by choosing "Start in compatibility mode" .
After install, the same problem is there, but a workaround is to choose from the grub menu "Advanced options -> Recovery mode" . You get some scrolling text, then a "Recovery menu" . There choose "resume", and on the next screen "Ok". Some more scrolling text and then the display is OK. It is then using the vesa screen driver ("inxi -F" will show it). It must have something to do with the screen mode switching, both "journalctl" and "dmesg" show an error:
[drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.

Mat

MatNieuw
Level 1
Level 1
Posts: 29
Joined: Sun Mar 11, 2018 4:45 pm

Re: New build prime b350-plus W Ryzen 2200g no go

Post by MatNieuw » Fri Oct 26, 2018 8:38 am

Hi,

this morning (2018-10-26) I installed the latest update for Mint 19. This included kernel 4.15.0-38 and some X.org module, in which the changelog mentioned AMD mode setting.
Now, all works fine, the split screen has disappeared and the system boots to the login in 7 seconds. According to inxi -F the graphics driver is now "ati,amdgpu", previously it was vesa.

So, I'm a happy camper.

Mat

Post Reply

Return to “Installation & Boot”