Black screen after booting Mint19

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Jm3881
Level 1
Level 1
Posts: 3
Joined: Tue Jul 03, 2018 2:41 pm

Black screen after booting Mint19

Post by Jm3881 » Tue Jul 03, 2018 2:53 pm

Hi,

Mint 19 64bit. Cinnamon. Closed Nvidia driver, latest updates installed.

The system has been working just fine until today. I shut down normally via red button in menu and got this normal dialog with options to reboot etc. I choosed 'shut down' but then another almost similar dialog appeared. There was options to 'wait' or 'shut down' i recall. After pressed to shut down, my system will not start x anymore. Screen stays black. I can press ctrl+number and log in. Startx gives graphical dialog with text 'Could not acquire name on session bus'.

I can provide some log file if someone could help me with this.

User avatar
michael louwe
Level 9
Level 9
Posts: 2795
Joined: Sun Sep 11, 2016 11:18 pm

Re: Black screen after booting Mint19

Post by michael louwe » Wed Jul 04, 2018 4:10 am

Jm3881 wrote:.
.
An update borked your LM 19 system.?

Try Recovery with Timeshift.? = boot the Live LM 19 USB/DVD, launch Timeshift and recover.?

Try reverting to previous Linux kernel via Grub Menu >Advanced options, by pressing SHIFT or ESC key during startup.?

gm10
Level 12
Level 12
Posts: 4186
Joined: Thu Jun 21, 2018 5:11 pm

Re: Black screen after booting Mint19

Post by gm10 » Wed Jul 04, 2018 4:24 am

If you're on the -24 revision kernel (uname -r) then that's the likely cause, it's been problematic for many nvidia users.

Switch to a previous revision via the GRUB boot menu and remove -24, should be fine then.

Jm3881
Level 1
Level 1
Posts: 3
Joined: Tue Jul 03, 2018 2:41 pm

Re: Black screen after booting Mint19

Post by Jm3881 » Fri Jul 06, 2018 7:27 am

Little update.

Yes, the problem seems to be that kernel version. My system actually starts up but it takes so long time that i was thinking it wont boot.

Now the question is how to open GRUB menu on booting so that i can choose older kernel? I have tried SHIFT (both sides) and ESC on boot but nothing happens. Here is my /etc/default/grub:

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=1
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Any ideas?
Last edited by WharfRat on Fri Jul 06, 2018 7:49 am, edited 1 time in total.
Reason: Added code tag

Mattyboy
Level 6
Level 6
Posts: 1196
Joined: Thu Mar 26, 2015 2:17 pm

Re: Black screen after booting Mint19

Post by Mattyboy » Fri Jul 06, 2018 7:46 am

https://askubuntu.com/questions/148095/ ... try#148097

replace gksudo with

Code: Select all

admin://
and gedit with

Code: Select all

xed
Don't forget to run

Code: Select all

sudo update-grub
after you've made the edits.
Last edited by Mattyboy on Fri Jul 06, 2018 7:47 am, edited 1 time in total.

User avatar
WharfRat
Level 20
Level 20
Posts: 11725
Joined: Thu Apr 07, 2011 8:15 pm

Re: Black screen after booting Mint19

Post by WharfRat » Fri Jul 06, 2018 7:47 am

Jm3881 wrote:
Fri Jul 06, 2018 7:27 am
Now the question is how to open GRUB menu on booting so that i can choose older kernel? I have tried SHIFT (both sides) and ESC on boot but nothing happens. Here is my /etc/default/grub:

Any ideas?
Add the line GRUB_TIMEOUT_STYLE="menu" above the GRUB_DEFAULT=1 line.

Then run sudo update-grub
ImageImage

Jm3881
Level 1
Level 1
Posts: 3
Joined: Tue Jul 03, 2018 2:41 pm

Re: Black screen after booting Mint19

Post by Jm3881 » Fri Jul 06, 2018 8:07 am

Add the line GRUB_TIMEOUT_STYLE="menu" above the GRUB_DEFAULT=1 line.

Thanks, this did it. I choosed previous kernel and it bootet normally (fast, that is). Because this seems to consider quite many users, i think Ubuntu will fix this in the future kernel update.

But i have to say that NVIDIA drivers and usual updates should not cause this kind of problem if there was any quality control before releasing updates. I mean i havent modify any config files etc, just using default options (NVIDIA driver was "recommended") and this should be the LTS release. Well, hope that nothing more will go broken.

Thanks for all the help!

gm10
Level 12
Level 12
Posts: 4186
Joined: Thu Jun 21, 2018 5:11 pm

Re: Black screen after booting Mint19

Post by gm10 » Fri Jul 06, 2018 8:26 am

Kernel 4.15.0-26 in the bionic-proposed branch probably will, looking good so far. Feel free to try it out to contribute to the testing if you're feeling adventurous despite this experience.

And I agree this should not happen, but if software was perfect then we wouldn't need updates at all. So to mitigate such things on your end you can just wait a few days before applying a kernel update, see if problems come up before you update yourself. In this case Ubuntu pulled the faulty kernel from the repositories again after 2 or 3 days. With a more lazy update strategy on your end you'd never have noticed. Let the early adopters weed out the bugs. ;)

kblexel
Level 1
Level 1
Posts: 5
Joined: Sun Jul 08, 2018 1:42 am

Re: Black screen after booting Mint19

Post by kblexel » Sun Jul 08, 2018 2:42 am

I register to thank you!I just installed mint19 yesterday,its new for a windows user,and i solved many problems by search engine , but not include the black screen.I felt bad with the 3-4minutes black screen,I tried to turn off the NVIDA, but its too hard for a newbie. I almost return back to win10.And finally i searched in this forum, I tried to go back to thank you and the asker so much !

Wikibear
Level 1
Level 1
Posts: 1
Joined: Wed Jul 11, 2018 6:27 am

Re: Black screen after booting Mint19

Post by Wikibear » Wed Jul 11, 2018 6:32 am

Hello together,

have the same issue as reported. After boot get black screen. My solution was to start console, that works, login in and restart lightdm....

sudo service lightdm restart.

Thereafter i get my desktop.

twodogs
Level 4
Level 4
Posts: 289
Joined: Sat Jun 09, 2007 9:18 pm

Re: Black screen after booting Mint19

Post by twodogs » Sun Oct 21, 2018 7:45 pm

Wikibear wrote:
Wed Jul 11, 2018 6:32 am
Hello together,

have the same issue as reported. After boot get black screen. My solution was to start console, that works, login in and restart lightdm....

sudo service lightdm restart.

Thereafter i get my desktop.
Do you still have this problem? Right now, I am on Mint 19 Cinnamon. When I boot up I end up looking at a blank, black screen. I could ctrl+alt+F but I thought to just enter my password and hit enter. It worked! I went straight to my desktop. So, my understanding is that lightdm is working, I just can't 'see' it.

Post Reply

Return to “Installation & Boot”