Too long boot time

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
amogh123789
Level 1
Level 1
Posts: 15
Joined: Sun Feb 10, 2019 1:28 am

Too long boot time

Post by amogh123789 » Sun Feb 10, 2019 11:38 pm

Hi,

I have recently set up dual boot of LM 19.1 cinnamon and win 10 by creating separate partitions.
My boot time is a bit long i believe. The grub2 boot menu appears fairly quickly , but after selecting the mint entry, it takes a long time for the login window to appear. Takes even more time to load desktop after typing passsword.

Here is a output of systemd-analyze:

Code: Select all

 Startup finished in 6.884s (kernel) + 29.393s (userspace) = 36.277s
graphical.target reached after 29.380s in userspace 
It is normal for dual boot setups? or can I do something to optimize boot time. Kindly advice.
LM 19.1 Cinnamon 64 bit
HP 15q-BU004TU - Core i3 - 4 GB ram

deepakdeshp
Level 13
Level 13
Posts: 4938
Joined: Sun Aug 09, 2015 10:00 am

Re: Too long boot time

Post by deepakdeshp » Mon Feb 11, 2019 4:15 am

The sytemd blame and analyze will give a better idea about the delay. Post the outputs of these commands.
https://www.google.com/amp/s/www.tecmin ... mance/amp/
Also post output of

Code: Select all

inxi -Fxz
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19.1 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

amogh123789
Level 1
Level 1
Posts: 15
Joined: Sun Feb 10, 2019 1:28 am

Re: Too long boot time

Post by amogh123789 » Mon Feb 11, 2019 6:01 am

Here is the output of inxi -Fxz

Code: Select all

System:    Host: amogh-HP-Laptop-15q-bu0xx Kernel: 4.15.0-45-generic x86_64 bits: 64 compiler: gcc v: 7.3.0 
           Desktop: Cinnamon 4.0.9 Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:   Type: Laptop System: HP product: HP Laptop 15q-bu0xx v: Type1ProductConfigId serial: <filter> 
           Mobo: HP model: 8328 v: 23.37 serial: <filter> UEFI [Legacy]: Insyde v: F.21 date: 07/04/2017 
Battery:   ID-1: BAT1 charge: 35.9 Wh condition: 39.9/41.6 Wh (96%) model: Hewlett-Packard PABAS0241231 status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i3-6006U bits: 64 type: MT MCP arch: Skylake rev: 3 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15936 
           Speed: 506 MHz min/max: 400/2000 MHz Core speeds (MHz): 1: 806 2: 515 3: 524 4: 625 
Graphics:  Device-1: Intel HD Graphics 520 vendor: Hewlett-Packard Skylake GT2 driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) v: 4.5 Mesa 18.2.2 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k4.15.0-45-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 
           v: 2.3LK-NAPI port: 4000 bus ID: 01:00.0 
           IF: eno1 state: down mac: <filter> 
           Device-2: Realtek vendor: Hewlett-Packard driver: rtl8723de v: kernel port: 3000 bus ID: 02:00.0 
           IF: wlo1 state: up mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 70.20 GiB (7.5%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10JPVX-60JC3T1 size: 931.51 GiB 
Partition: ID-1: / size: 36.41 GiB used: 10.21 GiB (28.0%) fs: ext4 dev: /dev/sda6 
           ID-2: /home size: 91.17 GiB used: 10.90 GiB (12.0%) fs: ext4 dev: /dev/sda8 
           ID-3: swap-1 size: 4.66 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda7 
Sensors:   System Temperatures: cpu: 39.0 C mobo: 29.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 219 Uptime: 14m Memory: 3.77 GiB used: 929.3 MiB (24.1%) Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 
           Shell: bash v: 4.4.19 inxi: 3.0.27 
The other outputs are attached since they are large.
critical-chain.txt
(1.01 KiB) Downloaded 22 times
blame.txt
(3.21 KiB) Downloaded 25 times
Please unpack this file for the boot_analysis.svg image:
boot_analysis.tar.gz
(16.05 KiB) Downloaded 18 times
The latest boot took even longer around 55 secs
LM 19.1 Cinnamon 64 bit
HP 15q-BU004TU - Core i3 - 4 GB ram

User avatar
Flemur
Level 16
Level 16
Posts: 6833
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Too long boot time

Post by Flemur » Mon Feb 11, 2019 3:14 pm

amogh123789 wrote:
Mon Feb 11, 2019 6:01 am
The other outputs are attached since they are large.
critical-chain.txt
blame.txt

Please unpack this file for the boot_analysis.svg image:
boot_analysis.tar.gz

The latest boot took even longer around 55 secs
You can disable NetworkManager-wait-online.service.
and disable lvm2-monitor.service IF you're not using LVM.

Code: Select all

sudo systemctl disable NetworkManager-wait-online.service
Edit: You also have the "every service takes 10 to 20 times longer to start than it should" syndrome which seems to mostly happen with Cinnamon.

E.g.
Yours: 9.645s systemd-journal-flush.service; 1.515s mnt-Data.mount
Mine: 391ms systemd-journal-flush.service; 21ms mnt-DATA.mount

FWIW, I have an 10 year-old, low-end computer.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

amogh123789
Level 1
Level 1
Posts: 15
Joined: Sun Feb 10, 2019 1:28 am

Re: Too long boot time

Post by amogh123789 » Mon Feb 11, 2019 11:20 pm

Flemur wrote:
Mon Feb 11, 2019 3:14 pm

You can disable NetworkManager-wait-online.service.
and disable lvm2-monitor.service IF you're not using LVM.
I'm sorry but I dont quite know much about this services. NetworkManager-wait-online.service : Disabling this will not stop wifi/Lan networking correct?
lvm2-monitor.service IF you're not using LVM: Again I'm not sure what this service does. How to know if I'm using LVM or not?
LM 19.1 Cinnamon 64 bit
HP 15q-BU004TU - Core i3 - 4 GB ram

deepakdeshp
Level 13
Level 13
Posts: 4938
Joined: Sun Aug 09, 2015 10:00 am

Re: Too long boot time

Post by deepakdeshp » Tue Feb 12, 2019 2:24 am

While installing Mint did you opt for LVM,?
What output do you get with mount command?
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19.1 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

all41
Level 14
Level 14
Posts: 5289
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Too long boot time

Post by all41 » Tue Feb 12, 2019 2:46 am

Also do not judge your blame results based on first boot, but after a subsequent reboot
Proud to be a supporter and monthly contributor to Mint.

amogh123789
Level 1
Level 1
Posts: 15
Joined: Sun Feb 10, 2019 1:28 am

Re: Too long boot time

Post by amogh123789 » Tue Feb 12, 2019 5:53 am

deepakdeshp wrote:
Tue Feb 12, 2019 2:24 am
While installing Mint did you opt for LVM,?
What output do you get with mount command?
I don't remember about LVM while installing right now. Can't be sure :(

The mount output is:

Code: Select all

~$ mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=1945304k,nr_inodes=486326,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=395508k,mode=755)
/dev/sda6 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/rdma type cgroup (rw,nosuid,nodev,noexec,relatime,rdma)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=36,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=1761)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/sda4 on /mnt/Other-Videos type ext4 (rw,nosuid,nodev,relatime,data=ordered,x-gvfs-show)
/dev/sda8 on /home type ext4 (rw,relatime,data=ordered)
/dev/sda5 on /mnt/Data type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096,x-gvfs-show)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=395504k,mode=700,uid=1000,gid=1000)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
Also even after disabling NetworkManager-wait-online.service it still shows again in blame output on next boot. Seems like it is not getting disabled or restarting automatically. It delays boot by more than 14 secs even now.
LM 19.1 Cinnamon 64 bit
HP 15q-BU004TU - Core i3 - 4 GB ram

amogh123789
Level 1
Level 1
Posts: 15
Joined: Sun Feb 10, 2019 1:28 am

Re: Too long boot time

Post by amogh123789 » Tue Feb 12, 2019 5:55 am

all41 wrote:
Tue Feb 12, 2019 2:46 am
Also do not judge your blame results based on first boot, but after a subsequent reboot
Yes, I checked blame output on next reboot. Still NetworkManager-wait-online.service is present even after disabling it on previous boot.
LM 19.1 Cinnamon 64 bit
HP 15q-BU004TU - Core i3 - 4 GB ram

deepakdeshp
Level 13
Level 13
Posts: 4938
Joined: Sun Aug 09, 2015 10:00 am

Re: Too long boot time

Post by deepakdeshp » Tue Feb 12, 2019 6:07 am

You don't have lvm, looks like
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19.1 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
Flemur
Level 16
Level 16
Posts: 6833
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Too long boot time

Post by Flemur » Tue Feb 12, 2019 11:09 am

amogh123789 wrote:
Tue Feb 12, 2019 5:55 am
all41 wrote:
Tue Feb 12, 2019 2:46 am
Also do not judge your blame results based on first boot, but after a subsequent reboot
Yes, I checked blame output on next reboot. Still NetworkManager-wait-online.service is present even after disabling it on previous boot.
Some of them come back - in this case it *might* be because you've enabled the apt/update service (though I didn't see it in your boot info), which require the 'net.
Change 'disable' to 'mask';

Code: Select all

sudo systemctl mask NetworkManager-wait-online.service
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

amogh123789
Level 1
Level 1
Posts: 15
Joined: Sun Feb 10, 2019 1:28 am

Re: Too long boot time

Post by amogh123789 » Tue Feb 12, 2019 11:45 am

After using mask option, it stopped appearing in the blame. Now can I also disable the lvm service?
LM 19.1 Cinnamon 64 bit
HP 15q-BU004TU - Core i3 - 4 GB ram

Post Reply

Return to “Installation & Boot”