Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Anna
Level 1
Level 1
Posts: 28
Joined: Wed Jun 12, 2019 2:21 am

Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by Anna » Wed Jun 12, 2019 2:45 am

Please forgive me if I missed this topic anywhere in this forum, but I have unsuccessfully been trying to find a solution here and on other websites during the past few days. The posts on boot time and tty1 I found could not really solve my problem.

My Problem: On one of my laptops, Linux Mint takes two minutes to boot – even though it is installed on an (otherwise fast) SSD. (Windows 7, which is installed on an old (and much slower) HDD on the same computer, boots considerably quicker.)

I find this all the more strange when comparing it to my new computer, on which starting LM only takes a few seconds. The hardware is faster, of course, but not to an extent that could explain the difference.

Even though I installed Linux in exactly the same way on both computers (dual boot with Win 7 and Win 10 respectively), the boot process is different: For example, there is no (addtionally time consuming) tty1 login on the Windows 10 computer. I have no idea why.

On the new (Windows 10, UEFI) Computer, LM starts within 17 seconds: 7 seconds black/"Press F2" screen, 3 seconds boot menu (reduced from the default 10), 7 seconds black/LM logo screen (no tty1)

On the old (Windows 7, BIOS) Computer, the startup takes about two minutes: 6 seconds black screen, 17 seconds "Press F2" screen, 3 seconds boot menu (reduced from the default 10), 41 seconds black screen, 23 seconds tty1 login, 18 seconds black/LM logo screen.

I would like to give the old laptop to a Linux-sceptic friend who has to replace her old Windows 7 computer and don't want to scare her off even before Linux Mint has booted.

Does anybody know what makes it so slow - and if there is a cure?

Best, Anna
Last edited by karlchen on Wed Jun 26, 2019 4:12 am, edited 1 time in total.
Reason: title: appended " on Packard Bell EasyNote LJ75", because the thread is precisely about this specific notebook type

RIH
Level 4
Level 4
Posts: 440
Joined: Sat Aug 22, 2015 3:47 am

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by RIH » Wed Jun 12, 2019 3:03 am

Code: Select all

systemd-analyze blame
Will show what is taking time during boot..

Code: Select all

inxi -Fxz
Will give details of your machine, as there may be some clues there as well..
Aspire-TC-705 Kernel: 4.15.0-66-generic x86_64 bits: 64
compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.2.3
Distro: Linux Mint 19.2

User avatar
karlchen
Level 20
Level 20
Posts: 11342
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Linux Mint starts/boots very slowly

Post by karlchen » Wed Jun 12, 2019 4:54 am

Hello, Anna.

In addition to what RIH had rightly asked for, please, also execute the command

Code: Select all

systemd-analyze
and post its output. - Yes, this is right, we need the output of systemd-analyze pure, no arguments, and of systemd-analyze blame.

Best regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

Anna
Level 1
Level 1
Posts: 28
Joined: Wed Jun 12, 2019 2:21 am

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by Anna » Wed Jun 12, 2019 12:04 pm

Dear RIH, dear Karl,

thank you for your quick replies :-)

The output is as follows:

Code: Select all

systemd-analyze
Startup finished in 19.600s (kernel) + 24.777s (userspace) = 44.377s
graphical.target reached after 21.711s in userspace

Code: Select all

systemd-analyze blame
         13.175s plymouth-quit-wait.service
         12.832s apt-daily.service
          9.258s gpu-manager.service
          6.075s NetworkManager-wait-online.service
          4.899s lightdm.service
          4.633s setvtrgb.service
          3.874s colord.service
          3.371s dev-sda1.device
          2.975s upower.service
          2.691s grub-common.service
          2.463s systemd-udev-trigger.service
          2.126s speech-dispatcher.service
          2.103s apport.service
          2.024s virtualbox.service
          1.949s hddtemp.service
           979ms udisks2.service
           955ms apt-daily-upgrade.service
           845ms ModemManager.service
           717ms ufw.service
           642ms lm-sensors.service
           632ms ubuntu-system-adjustments.service
           619ms pppd-dns.service
           618ms rsyslog.service

Code: Select all

inxi -Fxz
System:
  Host: N-Lx Kernel: 4.15.0-51-generic x86_64 bits: 64 compiler: gcc 
  v: 7.3.0 Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: Packard Bell product: EasyNote LJ75 v: V1.05 
  serial: <filter> 
  Mobo: Packard Bell model: EasyNote LJ75 v: V1.05 serial: <filter> 
  BIOS: Packard Bell v: 1.05 date: 01/05/2010 
Battery:
  ID-1: BAT0 charge: 14.1 Wh condition: 14.1/48.8 Wh (29%) 
  model: SANYO Li_Ion_4000mA status: Full 
CPU:
  Topology: Dual Core model: Intel Core i5 M 430 bits: 64 type: MT MCP 
  arch: Nehalem rev: 2 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18087 
  Speed: 1283 MHz min/max: 1199/2267 MHz Core speeds (MHz): 1: 1248 2: 1292 
  3: 1231 4: 1234 
Graphics:
  Device-1: AMD Park [Mobility Radeon HD 5430/5450/5470] 
  vendor: Acer Incorporated ALI driver: radeon v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.19.6 driver: ati,radeon 
  unloaded: fbdev,modesetting,vesa resolution: 1600x900~60Hz 
  OpenGL: renderer: AMD CEDAR (DRM 2.50.0 / 4.15.0-51-generic LLVM 7.0.0) 
  v: 3.3 Mesa 18.2.8 direct render: Yes 
Audio:
  Device-1: Intel 5 Series/3400 Series High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 
  Device-2: AMD Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series] 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 
  Sound Server: ALSA v: k4.15.0-51-generic 
Network:
  Device-1: Broadcom and subsidiaries NetLink BCM57780 Gigabit Ethernet PCIe 
  vendor: Acer Incorporated ALI driver: tg3 v: 3.137 port: 3000 
  bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros AR928X Wireless Network Adapter vendor: Lite-On 
  driver: ath9k v: kernel port: 3000 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 521.67 GiB used: 38.16 GiB (7.3%) 
  ID-1: /dev/sda vendor: SanDisk model: SSD PLUS 240GB size: 223.58 GiB 
  ID-2: /dev/sdb vendor: Western Digital model: WD3200BEVT-22ZCT0 
  size: 298.09 GiB 
Partition:
  ID-1: / size: 219.07 GiB used: 38.16 GiB (17.4%) fs: ext4 dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A gpu: radeon temp: 45 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 192 Uptime: 17m Memory: 7.66 GiB used: 995.5 MiB (12.7%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27
Can you make heads or tails of it?

Best,
A
Last edited by Anna on Fri Jun 14, 2019 1:54 am, edited 2 times in total.

Anna
Level 1
Level 1
Posts: 28
Joined: Wed Jun 12, 2019 2:21 am

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by Anna » Wed Jun 12, 2019 12:08 pm

Sorry, some of the blame was missing. Here it is:

Code: Select all

618ms rsyslog.service
           598ms thermald.service
           590ms systemd-journal-flush.service
           558ms systemd-logind.service
           392ms NetworkManager.service
           246ms accounts-daemon.service
           245ms networkd-dispatcher.service
           212ms apparmor.service
           192ms keyboard-setup.service
           186ms wpa_supplicant.service
           178ms lvm2-monitor.service
           174ms systemd-udevd.service
           167ms systemd-timesyncd.service
           158ms systemd-resolved.service
           156ms avahi-daemon.service
           148ms systemd-tmpfiles-setup-dev.service
           141ms systemd-journald.service
           131ms swapfile.swap
           117ms dns-clean.service
           111ms networking.service
            92ms systemd-sysctl.service
            90ms systemd-modules-load.service
            77ms alsa-restore.service
            74ms user@1000.service
            69ms packagekit.service
            63ms systemd-tmpfiles-setup.service
            48ms systemd-tmpfiles-clean.service
            48ms polkit.service
            33ms dev-mqueue.mount
            30ms blk-availability.service
            27ms dev-hugepages.mount
            27ms plymouth-read-write.service
            19ms kerneloops.service
            18ms plymouth-start.service
            16ms kmod-static-nodes.service
            16ms systemd-backlight@backlight:acpi_video0.service
            15ms systemd-random-seed.service
            15ms systemd-remount-fs.service
            12ms systemd-update-utmp.service
            11ms ureadahead-stop.service
            11ms sys-kernel-debug.mount
             8ms systemd-rfkill.service
             8ms console-setup.service
             8ms systemd-backlight@backlight:radeon_bl0.service
             8ms systemd-update-utmp-runlevel.service
             8ms rtkit-daemon.service
             6ms systemd-user-sessions.service
             5ms sys-kernel-config.mount
             4ms sys-fs-fuse-connections.mount
             3ms openvpn.service

User avatar
Larry78723
Level 6
Level 6
Posts: 1403
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by Larry78723 » Wed Jun 12, 2019 12:22 pm

Please open a terminal full screen and run the following commands

Code: Select all

lsblk

Code: Select all

blkid
Highlight the results and copy them (ctrl-shift-c) and enclose the results between the code markers by selecting </> from the mini toolbar above the textbox where you type your reply then paste (ctrl-v) them in your reply.

The results will help us to help you.
Image

Anna
Level 1
Level 1
Posts: 28
Joined: Wed Jun 12, 2019 2:21 am

Re: Linux Mint starts/boots very slowly

Post by Anna » Wed Jun 12, 2019 12:29 pm

Thank you, Larry!

Here we go:

Code: Select all

lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 223,6G  0 disk 
└─sda1   8:1    0 223,6G  0 part /
sdb      8:16   0 298,1G  0 disk 
├─sdb1   8:17   0    12G  0 part 
├─sdb2   8:18   0   102M  0 part 
└─sdb3   8:19   0   286G  0 part 
sr0     11:0    1  1024M  0 rom  

blkid
/dev/sda1: UUID="8845606d-c5a1-433a-baf7-3e6e9725a3ed" TYPE="ext4" PARTUUID="ed1a29e1-01"
/dev/sdb1: LABEL="PQSERVICE" UUID="C6F4EEB3F4EEA4C1" TYPE="ntfs" PARTUUID="ad09a287-01"
/dev/sdb2: LABEL="SYSTEM RESERVED" UUID="AAD4EF36D4EF0403" TYPE="ntfs" PARTUUID="ad09a287-02"
/dev/sdb3: LABEL="Packard Bell" UUID="6A70956E7095422D" TYPE="ntfs" PARTUUID="ad09a287-03"

User avatar
Larry78723
Level 6
Level 6
Posts: 1403
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by Larry78723 » Wed Jun 12, 2019 1:43 pm

On the old (Windows 7, BIOS) Computer, the startup takes about two minutes: 6 seconds black screen, 17 seconds "Press F2" screen, 3 seconds boot menu (reduced from the default 10), 41 seconds black screen, 23 seconds tty1 login, 18 seconds black/LM logo screen.
Anna, I'm no expert but that sounds like a GRUB problem. Hopefully, one of the experts will chime in soon. You might want to modify the subject in your original post to something like "Mint boots slowly (GRUB Problem?)
Image

User avatar
karlchen
Level 20
Level 20
Posts: 11342
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by karlchen » Wed Jun 12, 2019 2:12 pm

Hello, Anna.

Code: Select all

systemd-analyze
Startup finished in 19.600s (kernel) + 24.777s (userspace) = 44.377s
graphical.target reached after 21.711s in userspace
The overall time, 45 sec., is not bad for your old notebook from 2010.
Yet, It is a bit weird that kernel loading takes 19.6 seconds, almost as long as userspace startup, 24.5 seconds.
Something like 10-11 seonds for kernel and 25 for user space would more expected. I.e. kernel loading is frequently much shorter than userspace startup on older computers.

Without inspecting the output of journalctl -b --no-pager it will not be possible to tell why kernel loading took longer than I would expect.
Moreover it would be necessary to have the corresponding kernel startup and user space startup times from more than one boot.
Else we might easily start assuming a problem, where there actually is none.

--
About a suspected Grub problem:
These times happen before Grub is even invoked: 6 seconds black screen, 17 seconds "Press F2" screen - not a Grub problem
3 seconds boot menu (reduced from the default 10 - Grub displaying menu and passing on control to boot image . No Grub problem here.
41 seconds black screen, 23 seconds tty1 login, 18 seconds black/LM logo screen. - This is almost twice as long as the startup time reported by systemd-analyze.

I have my doubts about the Grub problem. I'd rather assume that unpacking the initrd boot image takes longer than it should.

Yet, it would be useful to make the startup more verbose. I.e. make the startup display all the messages, which are suppressed by default.
This might help find out what is going on and whether the process gets stuck somewhere.
journalctl -b --no-pager output might be helpful as well. But it can only log what happens after the logging daemon has been started.

Best regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

Anna
Level 1
Level 1
Posts: 28
Joined: Wed Jun 12, 2019 2:21 am

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by Anna » Wed Jun 12, 2019 3:29 pm

Wow, thats a lot of output! Way to much to post it, so I can only copy a small part (its more than 140.000 characters,) Hope that will provide some insight:

Code: Select all

journalctl -b --no-pager
-- Logs begin at Wed 2019-06-05 19:05:52 CEST, end at Wed 2019-06-12 21:26:21 CEST. --
Jun 12 21:24:31 N-Lx kernel: microcode: microcode updated early to revision 0x11, date = 2018-05-08
Jun 12 21:24:31 N-Lx kernel: Linux version 4.15.0-51-generic (buildd@lgw01-amd64-059) (gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)) #55-Ubuntu SMP Wed May 15 14:27:21 UTC 2019 (Ubuntu 4.15.0-51.55-generic 4.15.18)
Jun 12 21:24:31 N-Lx kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-51-generic root=UUID=8845606d-c5a1-433a-baf7-3e6e9725a3ed ro quiet splash vt.handoff=1
Jun 12 21:24:31 N-Lx kernel: KERNEL supported cpus:
Jun 12 21:24:31 N-Lx kernel:   Intel GenuineIntel
Jun 12 21:24:31 N-Lx kernel:   AMD AuthenticAMD
Jun 12 21:24:31 N-Lx kernel:   Centaur CentaurHauls
Jun 12 21:24:31 N-Lx kernel: x86/fpu: x87 FPU will use FXSAVE
Jun 12 21:24:31 N-Lx kernel: e820: BIOS-provided physical RAM map:
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009cfff] usable
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x000000000009d000-0x000000000009ffff] reserved
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000000e0000-0x00000000000fffff] reserved
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x0000000000100000-0x00000000bf680fff] usable
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000bf681000-0x00000000bf6befff] reserved
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000bf6bf000-0x00000000bf745fff] usable
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000bf746000-0x00000000bf7befff] ACPI NVS
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000bf7bf000-0x00000000bf7dffff] usable
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000bf7e0000-0x00000000bf7fefff] ACPI data
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000bf7ff000-0x00000000bf7fffff] usable
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000bf800000-0x00000000bfffffff] reserved
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000e0000000-0x00000000efffffff] reserved
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000feb00000-0x00000000feb03fff] reserved
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000fed10000-0x00000000fed13fff] reserved
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000fed18000-0x00000000fed19fff] reserved
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000fed1b000-0x00000000fed1ffff] reserved
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000000ffe80000-0x00000000ffffffff] reserved
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x0000000100000000-0x00000001fbffffff] usable
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x00000001fc000000-0x00000001ffffffff] reserved
Jun 12 21:24:31 N-Lx kernel: BIOS-e820: [mem 0x0000000200000000-0x000000023bffffff] usable
Jun 12 21:24:31 N-Lx kernel: NX (Execute Disable) protection: active
Jun 12 21:24:31 N-Lx kernel: SMBIOS 2.6 present.
Jun 12 21:24:31 N-Lx kernel: DMI: Packard Bell     EasyNote LJ75   /EasyNote LJ75   , BIOS V1.05 01/05/2010
Jun 12 21:24:31 N-Lx kernel: e820: update [mem 0x00000000-0x00000fff] usable ==> reserved
Jun 12 21:24:31 N-Lx kernel: e820: remove [mem 0x000a0000-0x000fffff] usable
Jun 12 21:24:31 N-Lx kernel: e820: last_pfn = 0x23c000 max_arch_pfn = 0x400000000
Jun 12 21:24:31 N-Lx kernel: MTRR default type: uncachable
Jun 12 21:24:31 N-Lx kernel: MTRR fixed ranges enabled:
Jun 12 21:24:31 N-Lx kernel:   00000-9FFFF write-back
Jun 12 21:24:31 N-Lx kernel:   A0000-BFFFF uncachable
Jun 12 21:24:31 N-Lx kernel:   C0000-FFFFF write-protect
Jun 12 21:24:31 N-Lx kernel: MTRR variable ranges enabled:
Jun 12 21:24:31 N-Lx kernel:   0 base 000000000 mask F80000000 write-back
Jun 12 21:24:31 N-Lx kernel:   1 base 0FFE00000 mask FFFE00000 write-protect
Jun 12 21:24:31 N-Lx kernel:   2 base 080000000 mask FC0000000 write-back
Jun 12 21:24:31 N-Lx kernel:   3 base 0BF800000 mask FFF800000 uncachable
Jun 12 21:24:31 N-Lx kernel:   4 base 100000000 mask F00000000 write-back
Jun 12 21:24:31 N-Lx kernel:   5 base 200000000 mask FC0000000 write-back
Jun 12 21:24:31 N-Lx kernel:   6 disabled
Jun 12 21:24:31 N-Lx kernel:   7 disabled
Jun 12 21:24:31 N-Lx kernel: x86/PAT: Configuration [0-7]: WB  WC  UC- UC  WB  WP  UC- WT  
Jun 12 21:24:31 N-Lx kernel: e820: last_pfn = 0xbf800 max_arch_pfn = 0x400000000
Jun 12 21:24:31 N-Lx kernel: Scanning 1 areas for low memory corruption
Jun 12 21:24:31 N-Lx kernel: Base memory trampoline at [        (ptrval)] 97000 size 24576
Jun 12 21:24:31 N-Lx kernel: BRK [0x9a93f000, 0x9a93ffff] PGTABLE
Jun 12 21:24:31 N-Lx kernel: BRK [0x9a940000, 0x9a940fff] PGTABLE
Jun 12 21:24:31 N-Lx kernel: BRK [0x9a941000, 0x9a941fff] PGTABLE
Jun 12 21:24:31 N-Lx kernel: BRK [0x9a942000, 0x9a942fff] PGTABLE
Jun 12 21:24:31 N-Lx kernel: BRK [0x9a943000, 0x9a943fff] PGTABLE
Jun 12 21:24:31 N-Lx kernel: BRK [0x9a944000, 0x9a944fff] PGTABLE
Jun 12 21:24:31 N-Lx kernel: BRK [0x9a945000, 0x9a945fff] PGTABLE
Jun 12 21:24:31 N-Lx kernel: BRK [0x9a946000, 0x9a946fff] PGTABLE
Jun 12 21:24:31 N-Lx kernel: BRK [0x9a947000, 0x9a947fff] PGTABLE
Jun 12 21:24:31 N-Lx kernel: RAMDISK: [mem 0x30c29000-0x3460bfff]
Jun 12 21:24:31 N-Lx kernel: ACPI: Early table checksum verification disabled
Jun 12 21:24:31 N-Lx kernel: ACPI: RSDP 0x00000000000FE020 000024 (v02 ACRSYS)
Jun 12 21:24:31 N-Lx kernel: ACPI: XSDT 0x00000000BF7FE120 000084 (v01 ACRSYS ACRPRDCT 00000001      01000013)
Jun 12 21:24:31 N-Lx kernel: ACPI: FACP 0x00000000BF7FC000 0000F4 (v04 ACRSYS ACRPRDCT 00000001 1025 01000013)
Jun 12 21:24:31 N-Lx kernel: ACPI: DSDT 0x00000000BF7EC000 00C2EB (v02 ACRSYS ACRPRDCT 00000001 1025 01000013)
Jun 12 21:24:31 N-Lx kernel: ACPI: FACS 0x00000000BF759000 000040
Jun 12 21:24:31 N-Lx kernel: ACPI: FACS 0x00000000BF759000 000040
Jun 12 21:24:31 N-Lx kernel: ACPI: ASF! 0x00000000BF7FD000 0000A5 (v32 ACRSYS ACRPRDCT 00000001 1025 01000013)

User avatar
karlchen
Level 20
Level 20
Posts: 11342
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by karlchen » Wed Jun 12, 2019 5:06 pm

Hello, Anna.

Sorry, uhm, my mistake of not providing immediately the steps on how to publish the complete text, which the command journalctl -b --no-pager will display. As you had noticed the output will have more lines than you can paste into a forum post. And a partial journalctl output will not be really helpful.
So some extra steps are required in order to publish the complete output.

How to provide your journalctl output to us for inspection:
  • Open a terminal window.
  • Execute the following commandline, please:

    Code: Select all

    journalctl --no-pager -b 0 > journalctl_anna.txt
    This command will write the whole current system log to the file journalctl_anna.txt. The file will be located in your $HOME directory (very likely /home/anna).
  • Now gzip the file journalctl_anna.txt by executing the commandline:

    Code: Select all

    gzip journalctl_anna.txt
    The resulting .gz file will be named journalctl_anna.txt.gz.
  • Attach this file to your next reply, please.
If we are lucky the systemlog will put us on the right track. Hopefully.

Regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

Anna
Level 1
Level 1
Posts: 28
Joined: Wed Jun 12, 2019 2:21 am

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by Anna » Thu Jun 13, 2019 12:40 am

Dear Karl,

thank you so much for taking all this effort!

The file is attached (plus the journalctl I had saved yesterday).

Best,
A
Attachments
journalcl_daybefore.txt.gz
(26.82 KiB) Downloaded 49 times
journalctl_anna.txt.gz
(27.53 KiB) Downloaded 45 times

User avatar
Larry78723
Level 6
Level 6
Posts: 1403
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by Larry78723 » Thu Jun 13, 2019 7:05 am

Here are the delays I found while reviewing your latest journalctl file:

Code: Select all

Jun 13 06:19:41 N-Lx systemd[1]: Started Daemon for power management.
Jun 13 06:19:41 N-Lx lightdm[1344]: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Jun 13 06:19:41 N-Lx lightdm[1344]: PAM adding faulty module: pam_kwallet.so
Jun 13 06:19:41 N-Lx lightdm[1344]: PAM unable to dlopen(pam_kwallet5.so): /lib/security/pam_kwallet5.so: cannot open shared object file: No such file or directory
Jun 13 06:19:41 N-Lx lightdm[1344]: PAM adding faulty module: pam_kwallet5.so
Jun 13 06:19:41 N-Lx lightdm[1344]: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "n"
                                                              <----- 4 minute delay
Jun 13 06:23:45 N-Lx anacron[893]: Job `cron.daily' started
Jun 13 06:23:45 N-Lx anacron[1352]: Updated timestamp for job `cron.daily' to 2019-06-13



Jun 13 06:25:35 N-Lx pulseaudio[2288]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
                                                              <------ 1 minute delay
Jun 13 06:26:35 N-Lx kernel: [UFW BLOCK] IN=wlp3s0 OUT= MAC=70:1a:04:be:3c:65:34:2c:c4:16:c5:c6:08:00 SRC=136.243.32.90 



Jun 13 06:27:34 N-Lx kernel: [UFW BLOCK] IN=wlp3s0 OUT= MAC=70:1a:04:be:3c:65:34:2c:c4:16:c5:c6:08:00 SRC=128.65.210.184 DST=192.168.0.164 LEN=40 TOS=0x08 PREC=0x00 TTL=57 ID=44506 DF PROTO=TCP SPT=443 DPT=51512 WINDOW=0 RES=0x00 RST URGP=0 
                                                                 <----- 1 minute delay
Jun 13 06:28:31 N-Lx dbus-daemon[2152]: [session uid=1000 pid=2152] Activating via systemd: service name='org.gnome.Terminal' unit='gnome-terminal-server.service' requested by ':1.66' (uid=1000 pid=2849 comm="/usr/bin/gnome-terminal.real " label="unconfined")
Hopefully, this will shed some light for Karl
Image

User avatar
Pierre
Level 19
Level 19
Posts: 9075
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by Pierre » Thu Jun 13, 2019 7:22 am

what strikes myself is :
- - Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa
base: Ubuntu 18.04 bionic

- - CPU: Speed: 1283 MHz min/max: 1199/2267 MHz Core speeds (MHz): 1: 1248 2: 1292
3: 1231 4: 1234

- - Memory: 7.66 GiB used: 995.5 MiB (12.7%)

so - it probably should be running the Mate Desktop,, rather than that Cinnamon Desktop:
- which would be just fine, on the newer machine, but not so on that much older machine.

you can add-in the Mate Desktop, if desired, rather than doing an complete re-install, again.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Anna
Level 1
Level 1
Posts: 28
Joined: Wed Jun 12, 2019 2:21 am

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by Anna » Thu Jun 13, 2019 11:59 am

Wow, this is really complicated... :shock:

Thank you, Larry, for going through those endless columns of data.

Sorry, Pierre, I am not sure if I get your assessment right: Should I use Mate because the hardware is too old for Cinnamon? (Once the System has finally booted, everything runs smoothly, though: The applications start quickly and work flawlessly, the OS responds without delay or glitches.)

Best, A

User avatar
karlchen
Level 20
Level 20
Posts: 11342
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by karlchen » Fri Jun 14, 2019 5:54 am

Hello, Anna. Hello, Pierre. Hello, Larry78723.

First: sorry for not replying any sooner, but with more than a day delay. :oops:

Thanks, Anna, for providing the 2 full "journalctl -b" outputs.
~~~

Pierre, I cannot agree with you that this computer should not be strong enough to run the Cinnamon desktop.

I had inspected the full inxi report as well.
I admit I fail to see why this Packard Bell EasyNote LJ75 from 2010 should not be able to run Cinnamon.
I run Cinnamon without problems on an even older desktop, cf. here, please.
And Anna does not complain that Mint runs in a sluggish way or that Cinnamon crashes. It is only the startup time, which she considers too long.

Again, comparing it, the startup time, to my ancient Medion desktop, the real difference is that my machine loads the kernel much faster, but uses more time for the user space startup. In the end, comparing the overall startup times, my Medion is the loser, it takes more total time to complete its startup.

In brief: nothing wrong with using Cinnamon on the this Packard Bell EasyNote LJ75. My point of view at least.
~~~

Larry78723, I am afraid I do not get your point.
While the system is idle, longer gaps in terms of time between log entries are normal and no cause for alarm.

The entries which you point us to, are from the file journalctl_anna.txt.
They have been logged after this line 1298:
Jun 13 06:18:55 N-Lx systemd[1]: Startup finished in 19.706s (kernel) + 13.748s (userspace) = 33.454s.
I.e. what you point us to happened after the system considers the startup comple.
There are no obvious gaps in terms of time in lines 1 to 1298, however.
Sadly I have not been able to identify why the kernel takes almost 20 seconds to load instead of 10 to 11 like on my old Medion Quadcore.

~~~
Looking at the vmlinuz startup commandline, I have got an idea, though.

I have switched off the most recent kernel security routines, which are meant to make the system immune against Microarchitectural Data Sampling (MDS) vulnerabilities.
This is my decision to trust that these vulnerabilties can hardly be exploited on my home machines (no server services offered).
  • My Atom CPU's are not vulnerable according to Intel anyway. - Why accept further slow down, if your CPU cannot be attacked?
  • My QuadCore could be attacked, theoretically. Yet, it does no get the needed Intel microcode updates any longer. - Why accept further kernel slow down, although Intel is unwilling to update the Intel microcode? So no full protection possible. Plus, no hyperthreading. 4 full cores only. :lol:
Anyway.
The relevant updated kernels are likely to work noticeably more slowly, if MDS protection remains enabled (default).
So I switched it off by
- adding MDS=off to the parameter GRUB_CMDLINE_LINUX in the file /etc/default/grub
- executing sudo update-grub to make sure Linux kernel vmlinuz is started up with the option MSD=off.

The difference can be told from the journalctl -b output:
  • Anna's machine. Line 4:
    Jun 13 06:18:42 N-Lx kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-51-generic root=UUID=8845606d-c5a1-433a-baf7-3e6e9725a3ed ro quiet splash vt.handoff=1
    (No MDS=off, so it will be MDS=auto (or is it MSD=full?), i.e. on, but multi-threading still switched on.
  • My system:
    Jun 14 09:22:10 unimatrix0 kernel: [ 0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-51-generic root=UUID=9011a709-fac8-4091-94ca-d512de25bc5f ro locale=de_DE mds=off splash
Assumption:
I assume, and this is a hypothesis as long as it has not been tried, that booting your machine, Anna, with MDS=off will reduce the kernel load time.
Whether MDS=off will improve overall performance noticeably or just in particular situations, I dare not promise so.

Will be your decision to try or not.

As this is a somewhat lengthy and maybe confusing post, I will give (hopefully concise) instructions on what to do in the next post below. :wink:

Best regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

User avatar
karlchen
Level 20
Level 20
Posts: 11342
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by karlchen » Fri Jun 14, 2019 6:15 am

Hi, Anna.

Before telling you what to do change and how, I would like to read the content of your file /etc/default/grub, please.
Please, execute the terminal command cat /etc/default/grub and paste the complete text output here.

Regards,
Karl
--
P.S.:
The idea is to change 2 things in a particular line in that file:
- replace quiet by splash to avoid the long "black" startup phase
- add MDS=off in order to make the kernel load faster (hopefully)
But in order to do so I need to know what is in the file currenty in order to make sure to give the steps correctly.
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

Anna
Level 1
Level 1
Posts: 28
Joined: Wed Jun 12, 2019 2:21 am

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by Anna » Fri Jun 14, 2019 1:27 pm

Dear Karl,

here it is:

Code: Select all

n@N-Lx:~$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Now that I take a look at those different options (which I don't really understand): Is it also possible to switch off that tt1-login that shows up on this computer for more than 20 seconds (and that doesn't really seem to be necessary given that it's not there on the other computer)?

Best, A

User avatar
karlchen
Level 20
Level 20
Posts: 11342
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by karlchen » Fri Jun 14, 2019 3:37 pm

Hello, Anna.

Answer on disabling tty1 login prompt:

No, you should not try to do so and you cannot really do so.
The first thing, which starts up on Linux, is the kernel and the 6 text-only console monitors tty1 to tty6.
Only afterwards, the graphical components are started up.
The good thing about it is that you can still use the console monitors in order to log in and troubleshoot, in case the GUI should not come up at all.

Suggested changes to file /etc/default/grub:

Please, follow these steps:
  • Open a terminal window.
    .
  • Edit the file /etc/default/grub with root privileges by executing the commandline sudoedit /etc/default/grub
    sudoedit will ask for your password, before launching the editor nano and opening the file /etc/default/grub.
    .
  • Change the line which currently reads GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    to read GRUB_CMDLINE_LINUX_DEFAULT="splash MDS=off" instead.
    Make sure you do not remove the double quotes around splash MDS=off
    They are important.
    Explanation:
    MDS=off : will disable the MDS related security routines thus hopefully speeding up kernel loading and kernel operations
    deleting quiet: makes the startup display more messages during startup. Helpful in case of troubleshooting
    Because of splash, the Mint logo should hide most of the startup messages.
    If you press <ESC> while the Mint logo is displayed, the logo should go away, making the startup messages visible.
    .
  • Once you have edited the file /etc/default/grub as explained above, press <Ctrl>x.
    nano will ask whether you want to save the changes. Press y for yes.
    nano will save the changed file and exit.
    .
  • Once nano has terminated, execute the commandline sudo update-grub to make Grub rebuild its configuration.
    .
  • Once sudo update-grub has finished its work, you may test whether the system boots faster now and without the long black phases.
    I.e. restart Linux Mint now.
During reboot, the Mint logo should be visible most of the time, not just flash briefly.
In case this does not happen, we may have to change one more Grub parameter. Yet, I would have to find out the correct value first on my own Packard Bell EasyNote LJ75.

Once Mint has come up from reboot and once you have logged in successfully, please, execute another systemd-analyze and post its result.

Also, please, let us know whether any old problem has persisted or a new problem occurred.

Best regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

Anna
Level 1
Level 1
Posts: 28
Joined: Wed Jun 12, 2019 2:21 am

Re: Linux Mint starts/boots very slowly on Packard Bell EasyNote LJ75

Post by Anna » Sat Jun 15, 2019 4:28 am

Hi Karl,

thank you!

The results, well, break down as follows:

6 seconds black screen,
17 seconds "Press F2" screen,
2 seconds boot menu
48 seconds black/“loading drivers“ screen (previously 41 seconds for black/LM logo screen.)
23 seconds tty1 login,
17 seconds black

So basically no change, except that the period between boot menu and tty1 is seven seconds longer. :lol: :lol: :lol:

Here are the details:

Code: Select all

Startup finished in 19.580s (kernel) + 21.840s (userspace) = 41.421s
graphical.target reached after 21.828s in userspace

Code: Select all

12.917s plymouth-quit-wait.service
          8.798s gpu-manager.service
          6.078s NetworkManager-wait-online.service
          4.903s lightdm.service
          4.629s setvtrgb.service
          3.971s colord.service
          3.844s dev-sda1.device
          2.942s upower.service
          2.472s systemd-udev-trigger.service
          2.132s apport.service
          2.126s virtualbox.service
          2.117s speech-dispatcher.service
          2.114s grub-common.service
          2.026s hddtemp.service
          1.303s ModemManager.service
          1.291s accounts-daemon.service
           760ms systemd-logind.service
           727ms ubuntu-system-adjustments.service
           720ms udisks2.service
           711ms NetworkManager.service
           701ms ufw.service
           652ms lm-sensors.service
           635ms thermald.service
           618ms networkd-dispatcher.service
           526ms systemd-journal-flush.service
           517ms polkit.service
           201ms wpa_supplicant.service
           200ms lvm2-monitor.service
           174ms systemd-timesyncd.service
           174ms keyboard-setup.service
           172ms avahi-daemon.service
           170ms systemd-resolved.service
           164ms systemd-udevd.service
           162ms systemd-tmpfiles-setup-dev.service
           149ms swapfile.swap
           124ms systemd-journald.service
           116ms apparmor.service
           103ms dns-clean.service
            98ms networking.service
            96ms systemd-sysctl.service
            92ms systemd-modules-load.service
            74ms user@1000.service
            69ms alsa-restore.service
            69ms systemd-tmpfiles-setup.service
            49ms pppd-dns.service
            37ms dev-mqueue.mount
            36ms rsyslog.service
            35ms dev-hugepages.mount
            30ms kmod-static-nodes.service
            24ms systemd-remount-fs.service
            24ms plymouth-read-write.service
            18ms plymouth-start.service
            18ms kerneloops.service
            17ms systemd-random-seed.service
            12ms sys-kernel-debug.mount
            12ms ureadahead-stop.service
            10ms blk-availability.service
            10ms systemd-update-utmp-runlevel.service
            10ms systemd-rfkill.service
             9ms console-setup.service
             9ms systemd-update-utmp.service
             8ms systemd-backlight@backlight:acpi_video0.service
             7ms rtkit-daemon.service
             7ms systemd-backlight@backlight:radeon_bl0.service
             7ms openvpn.service
             7ms systemd-user-sessions.service
             5ms sys-kernel-config.mount
             4ms sys-fs-fuse-connections.mount
lines 46-68/68 (END)
Best, A

Post Reply

Return to “Installation & Boot”