[SOLVED] SSD is not recognizable during Linux Mint 19.3 installation

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
strider2038
Level 1
Level 1
Posts: 4
Joined: Thu Feb 13, 2020 1:14 am

[SOLVED] SSD is not recognizable during Linux Mint 19.3 installation

Post by strider2038 »

I'm trying to install latest Linux Mint 19.3 Cinnamon on laptop Acer Predator Triton 300 (produced in late 2019), but SSD is not recognized. No information about drive in GParted, it is not listed in the output of inxi -Fxzd. I'm booting in UEFI mode, secure boot is disabled. Don't know what to do. Can anyone help?
Last edited by strider2038 on Fri Feb 14, 2020 1:41 am, edited 1 time in total.

User avatar
smurphos
Level 15
Level 15
Posts: 5618
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: SSD is not recognizable during Linux Mint 19.3 installation

Post by smurphos »

Hi,

Welome to the forums.

Make sure the SATA is set to AHCI mode in your BIOS and not RAID / Optane or similar.

Also see viewtopic.php?p=1665465#p1665465

If you intend to dual boot see https://support.thinkcritical.com/kb/ar ... de-to-ahci
Last edited by smurphos on Thu Feb 13, 2020 3:05 am, edited 2 times in total.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

asinoro
Level 4
Level 4
Posts: 437
Joined: Mon Feb 12, 2018 11:43 am

Re: SSD is not recognizable during Linux Mint 19.3 installation

Post by asinoro »

Can you post:

Code: Select all

sudo parted -l

all41
Level 15
Level 15
Posts: 5877
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: SSD is not recognizable during Linux Mint 19.3 installation

Post by all41 »

strider2038 wrote:
Thu Feb 13, 2020 1:26 am
I'm trying to install latest Linux Mint 19.3 Cinnamon on laptop Acer Predator Triton 300 (produced in late 2019), but SSD is not recognized. No information about drive in GParted, it is not listed in the output of inxi -Fxzd. I'm booting in UEFI mode, secure boot is disabled. Don't know what to do. Can anyone help?
Firstly make sure you have a verifiable backup of all your personal files beforehand (make doubly sure).

When you go into the install routine from the live desktop and progress to the install choices screen
are you selecting 'something else' here? Please say more regarding this step.

strider2038
Level 1
Level 1
Posts: 4
Joined: Thu Feb 13, 2020 1:14 am

Re: SSD is not recognizable during Linux Mint 19.3 installation

Post by strider2038 »

Output of inxi -Fxzd

Code: Select all

System:    Host: mint Kernel: 5.0.0-32-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.4.5 
           Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:   Type: Laptop System: Acer product: Predator PT315-51 v: V1.03 serial: <filter> 
           Mobo: CFL model: Auris_CFS v: V1.03 serial: <filter> UEFI: Insyde v: 1.03 date: 09/05/2019 
Battery:   ID-1: BAT1 charge: 59.8 Wh condition: 59.8/58.8 Wh (102%) model: Simplo PABAS0241231 status: Full 
CPU:       Topology: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Kaby Lake rev: D L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38400 
           Speed: 900 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 
Graphics:  Device-1: Intel vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA vendor: Acer Incorporated ALI driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 19.0.8 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Device-2: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k5.0.0-32-generic 
Network:   Device-1: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Acer Incorporated ALI driver: alx v: kernel 
           port: 3000 bus ID: 06:00.0 
           IF: enp6s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-2: Intel vendor: Bigfoot Networks driver: N/A port: 3000 bus ID: 07:00.0 
Drives:    Local Storage: total: 7.50 GiB used: 111.0 MiB (1.4%) 
           ID-1: /dev/sda type: USB model: General size: 7.50 GiB 
           Message: No Optical or Floppy data was found. 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:17.0 
Partition: ID-1: / size: 3.82 GiB used: 111.0 MiB (2.8%) fs: overlay source: ERR-102 
Sensors:   System Temperatures: cpu: 51.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 242 Uptime: 10m Memory: 7.63 GiB used: 1.17 GiB (15.4%) Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 
           Shell: bash v: 4.4.20 inxi: 3.0.32 

Output of sudo parted -l

Code: Select all

Warning: The driver descriptor says the physical block size is 2048 bytes, but
Linux says it is 512 bytes.
Ignore/Cancel? Ignore                                                     
Model: General UDisk (scsi)
Disk /dev/sda: 32.2GB
Sector size (logical/physical): 2048B/512B
Partition Table: mac
Disk Flags: 

Number  Start  End     Size    File system  Name   Flags
 1      2048B  6143B   4096B                Apple
 2      348kB  2871kB  2523kB               EFI

strider2038
Level 1
Level 1
Posts: 4
Joined: Thu Feb 13, 2020 1:14 am

Re: SSD is not recognizable during Linux Mint 19.3 installation

Post by strider2038 »

SSD drive is clean, there are no any pre-installed OS. Linux Mint from Live USB can see only USB stick.
Make sure the SATA is set to AHCI mode in your BIOS and not RAID / Optane or similar.
I see that SATA mode is set to "Optane with RAID" in BIOS information, but I can't find any options to change it.

strider2038
Level 1
Level 1
Posts: 4
Joined: Thu Feb 13, 2020 1:14 am

Re: SSD is not recognizable during Linux Mint 19.3 installation

Post by strider2038 »

Thanks to all! Problem was solved. I need to press CTRL+S in BIOS to enable option for choosing SATA mode. This helps.

https://community.acer.com/en/discussio ... 5-54k-59nz

User avatar
smurphos
Level 15
Level 15
Posts: 5618
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: SSD is not recognizable during Linux Mint 19.3 installation

Post by smurphos »

Glad you sorted it :). Editing the title of your post to include [SOLVED] will help other users with the same problem.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

Post Reply

Return to “Installation & Boot”