[SOLVED] Install dual boot Windows 7 and Mint mate 20 problem

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
deepakdeshp
Level 17
Level 17
Posts: 7946
Joined: Sun Aug 09, 2015 10:00 am

[SOLVED] Install dual boot Windows 7 and Mint mate 20 problem

Post by deepakdeshp »

Hello,
The setup is 3 Windows NTFS partitions and extended partition. Under extended partition I created ext4 partition which was chosen to install Mint as /. No other separate partitions are created. Installation gives an error asking to make an efi partition for boot loader. I created separate fat32 400MB partiton but there is no option to make it bootable and EFI.
I will try using efi as the mount point for this fat32 partition.
The computer laptop is from 2015 How do I proceed?
Last edited by deepakdeshp on Sat Aug 01, 2020 11:45 am, edited 1 time in total.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 20 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB
linux-rox
Level 4
Level 4
Posts: 327
Joined: Sun Jul 19, 2020 9:17 pm

Re: Install dual boot Windows 7 and Mint mate 20 problem

Post by linux-rox »

You're booting the live session in UEFI mode. You need to use BIOS/legacy mode. That's an option somewhere in the firmware boot menu.
ZakGordon
Level 5
Level 5
Posts: 828
Joined: Thu Feb 12, 2015 11:07 am

Re: Install dual boot Windows 7 and Mint mate 20 problem

Post by ZakGordon »

I had to do the same in my current Win7/Mint 19.1 dual boot system. It would only work if i picked 'legacy' in the Bios options, under UEFI it was a no go. This might be in relation to the new hardware (mobo) and running Win 7 on it.
Laptop overheating? Check link here:itsfoss guide . A move from Cinnamon to XFCE can give a -5 to -10 degrees C change on overheating hardware.

Build a modern dual-boot Ryzen Win7/Linux Mint PC:Tutorial
User avatar
AndyMH
Level 12
Level 12
Posts: 4247
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Install dual boot Windows 7 and Mint mate 20 problem

Post by AndyMH »

Go into BIOS and make sure that the boot mode is set to legacy. You are getting this problem because your BIOS has UEFI as the first boot option.
I created separate fat32 400MB partiton but there is no option to make it bootable and EFI.
Delete it - not needed.

During install choose the 'something else' option and point the installer at the ext4 partition you created and tell it to use it for /.

Note - from the information provided, win7 was installed in legacy mode on a legacy/msdos drive - you need to install mint in the same mode.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
deepakdeshp
Level 17
Level 17
Posts: 7946
Joined: Sun Aug 09, 2015 10:00 am

Re: Install dual boot Windows 7 and Mint mate 20 problem

Post by deepakdeshp »

AndyMH wrote:
Sat Aug 01, 2020 9:50 am
Go into BIOS and make sure that the boot mode is set to legacy. You are getting this problem because your BIOS has UEFI as the first boot option.
I created separate fat32 400MB partiton but there is no option to make it bootable and EFI.
Delete it - not needed.

During install choose the 'something else' option and point the installer at the ext4 partition you created and tell it to use it for /.

Note - from the information provided, win7 was installed in legacy mode on a legacy/msdos drive - you need to install mint in the same mode.
Thank you. That solved it.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 20 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB
Post Reply

Return to “Installation & Boot”