LM20 failed to boot- black screen with no such file or directory m

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
ashraz
Level 1
Level 1
Posts: 8
Joined: Tue Nov 17, 2020 6:20 am

LM20 failed to boot- black screen with no such file or directory m

Post by ashraz »

hi all!

Installed LM20 with windows 10 64bit - dual boot. everything went fine. but when try to boot for the first time, lines of messages "no such file or directory" keep scrolling for a while then it will boot and everything runs perfectly. after that i restart the laptop and the same thing happen but this time i wont boot at all! i attached pictures below: im kinda new with linux mint. appreciate help with this
error message.JPG
error message2.JPG
THANKS IN ADVANCE!
ashraz
Level 1
Level 1
Posts: 8
Joined: Tue Nov 17, 2020 6:20 am

Re: LM20 failed to boot- black screen with no such file or directory m

Post by ashraz »

anybody??.... :cry:
User avatar
Larry78723
Level 10
Level 10
Posts: 3016
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: LM20 failed to boot- black screen with no such file or directory m

Post by Larry78723 »

Because we don't know anything about your machine we can only guess what may be causing the problem. Is secure boot disabled in your bios? Is fast start disabled in Windows? Can you boot from your install USB/DVD?
Image
User avatar
JoeFootball
Level 9
Level 9
Posts: 2913
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: LM20 failed to boot- black screen with no such file or directory m

Post by JoeFootball »

ashraz wrote: appreciate help with this
I don't know for sure, but given that the file system appears to be attempting to recover from journal, I suspect file system corruption, which could be caused by a number of things.

With this being a new install, would an option be to try installing it again? And did you verify the ISO before you created the installation media?
ashraz
Level 1
Level 1
Posts: 8
Joined: Tue Nov 17, 2020 6:20 am

Re: LM20 failed to boot- black screen with no such file or directory m

Post by ashraz »

I guess i will need to reinstall it again. oh damn...i didnt verify my ISO before installing it.
ashraz
Level 1
Level 1
Posts: 8
Joined: Tue Nov 17, 2020 6:20 am

Re: LM20 failed to boot- black screen with no such file or directory m

Post by ashraz »

i uninstalled LM20. verify my ISO and reinstalled it using "install along with windows 10" option. the same problem persist. same messages showing on the first reboot. what else could it be?
User avatar
JoeFootball
Level 9
Level 9
Posts: 2913
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: LM20 failed to boot- black screen with no such file or directory m

Post by JoeFootball »

ashraz wrote: what else could it be?
The fact that it's attempting to recover from the journal makes me suspect file system corruption. It could be that the hard drive itself has a bad block at where it's looking for this file. How old is the hard drive?
ashraz
Level 1
Level 1
Posts: 8
Joined: Tue Nov 17, 2020 6:20 am

Re: LM20 failed to boot- black screen with no such file or directory m

Post by ashraz »

upgraded from HDD to SSD this year in march. cloned my HDD to SSD. perhaps i need to clean install windows 10?
User avatar
JoeFootball
Level 9
Level 9
Posts: 2913
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: LM20 failed to boot- black screen with no such file or directory m

Post by JoeFootball »

ashraz wrote: perhaps i need to clean install windows 10?
I don't think that Windows is the issue here, but I don't know much of Windows, nor SSDs, so feel free to try.

From what I can discern, Plymouth (the graphical bootscreen that LM uses) cannot start because a file or directory cannot be found. As such, LM cannot boot.

This is followed by a disk recovery attempt from journal. This led me to believe that it's file system corruption. But this is a fairly new SSD, and this is a new installation of LM.

Someone may want the details of your system, so you can boot to a live session and post the output of inxi -Fxxxrz here between [code][/code] tags.
ashraz
Level 1
Level 1
Posts: 8
Joined: Tue Nov 17, 2020 6:20 am

Re: LM20 failed to boot- black screen with no such file or directory m

Post by ashraz »

here are the output:

Code: Select all

mint@mint:~$ inxi -Fxxxrz
System:
  Kernel: 5.4.0-26-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.6 wm: muffin 4.6.2 dm: LightDM 1.30.0 
  Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:
  Type: Laptop System: Hewlett-Packard 
  product: Compaq Presario CQ40 Notebook PC v: F.24 serial: <filter> 
  Chassis: Compal type: 10 serial: <filter> 
  Mobo: Compal model: 3607 v: 99.87 serial: <filter> BIOS: Hewlett-Packard 
  v: F.24 date: 11/24/2008 
CPU:
  Topology: Dual Core model: Pentium T4200 bits: 64 type: MCP arch: Penryn 
  rev: A L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 7979 
  Speed: 1197 MHz min/max: 1200/2000 MHz Core speeds (MHz): 1: 1197 2: 1197 
Graphics:
  Device-1: Intel Mobile 4 Series Integrated Graphics 
  vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:2a42 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1280x800~60Hz 
  OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express (CTG) 
  v: 2.1 Mesa 20.0.4 direct render: Yes 
Audio:
  Device-1: Intel 82801I HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:293e 
  Sound Server: ALSA v: k5.4.0-26-generic 
Network:
  Device-1: Broadcom and subsidiaries BCM4312 802.11b/g LP-PHY 
  vendor: Hewlett-Packard driver: b43-pci-bridge v: N/A port: 7000 
  bus ID: 03:00.0 chip ID: 14e4:4315 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 04:00.0 
  chip ID: 10ec:8136 
  IF: enp4s0 state: down mac: <filter> 
  Device-3: Realtek 802.11ac NIC type: USB driver: usb-network bus ID: 2-2:2 
  chip ID: 0bda:c811 serial: <filter> 
Drives:
  Local Storage: total: 237.89 GiB used: 1.88 GiB (0.8%) 
  ID-1: /dev/sda vendor: A-Data model: SU650 size: 223.57 GiB 
  speed: 3.0 Gb/s serial: <filter> rev: E1.2 temp: 33 C scheme: MBR 
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Ultra size: 14.32 GiB 
  speed: 3.0 Gb/s serial: <filter> rev: 1.00 scheme: MBR 
Partition:
  ID-1: / size: 1.90 GiB used: 26.8 MiB (1.4%) fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 56.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Repos:
  Active apt repos in: /etc/apt/sources.list 
  1: deb cdrom:[Linux Mint 20 _Ulyana_ - Release amd64 20200624]/ focal contrib main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com ulyana main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner
Info:
  Processes: 166 Uptime: 5m Memory: 3.81 GiB used: 593.4 MiB (15.2%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash 
  v: 5.0.16 running in: gnome-terminal inxi: 3.0.38
User avatar
JoeFootball
Level 9
Level 9
Posts: 2913
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: LM20 failed to boot- black screen with no such file or directory m

Post by JoeFootball »

ashraz wrote: System:
Kernel: 5.4.0-26-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Cinnamon 4.6.6 wm: muffin 4.6.2 dm: LightDM 1.30.0
Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal

Machine:
Type: Laptop System: Hewlett-Packard
product: Compaq Presario CQ40 Notebook PC v: F.24 serial: <filter>

CPU:
Topology: Dual Core model: Pentium T4200 bits: 64

Graphics:
Device-1: Intel Mobile 4 Series Integrated Graphics
vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0

Info:
Processes: 166 Uptime: 5m Memory: 3.81 GiB used: 593.4 MiB (15.2%)
Rather than the "heaviest" version/desktop of LM available, your can try LM 19.2 Xfce as it will do better with hardware from 2009.
ashraz
Level 1
Level 1
Posts: 8
Joined: Tue Nov 17, 2020 6:20 am

Re: LM20 failed to boot- black screen with no such file or directory m

Post by ashraz »

Thanks for the feedback. any other distro other than LM for my old machine that you would recommend?
User avatar
JoeFootball
Level 9
Level 9
Posts: 2913
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: LM20 failed to boot- black screen with no such file or directory m

Post by JoeFootball »

ashraz wrote: any other distro other than LM for my old machine that you would recommend?
Not that I could personally recommend, but I've heard that MX Linux is good for older hardware.

That said, I do think that LM 19.2 Xfce will do well for that, and it's supported until April 2023.

Edit: Just fyi, the reason I recommended 19.2 instead of 19.3 is because 19.2 comes with the 4.15.x kernel series that seems to work better on older systems.
Post Reply

Return to “Installation & Boot”