Linux Tara Ethernet but no WIFI connection after installation

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Tara
Level 1
Level 1
Posts: 28
Joined: Thu May 06, 2021 7:35 am

Linux Tara Ethernet but no WIFI connection after installation

Post by Tara »

I am new to Linux and not a tech guy. Would like help on how to connect Linux mint to WIFI. I installed Linux mint XFCE on my dell laptop with windows vista on a bootable USB. After installation, Linux mint does not have Wifi connection and I am running into issues setting up the WIFI connection. The internet is working fine on other devices. The command: sudo lshw -C network shows that I have internet and my driver-b44. I tried now to use the command: gksu gedit /etc/pm/config.d/unload_modules" to enter my driver into root file but I learned that the command gksu was removed. This is where I got stuck.
User avatar
Pierre
Level 20
Level 20
Posts: 11713
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by Pierre »

Hi Tara,
welcome to our forum.
:)

do tell us something about your machine:
viewtopic.php?f=90&t=318644
copy the result of that, back here, on your reply.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.
bodge99

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by bodge99 »

Hi,

Pierre is correct here.. We need more information. The Broadcom b44 driver/firmware packages for Linux cover a few different wifi card models.
Some specific wifi chipsets have to be set up slightly differently from other (apparently virtually identical) cards. It should be fairly easy to get yours working..

How old are the instructions that you are following??

Bodge99
Tara
Level 1
Level 1
Posts: 28
Joined: Thu May 06, 2021 7:35 am

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by Tara »

Thanks, I am not connected to the network. Need to purchase a lan cable and provide information as soon as possible
Tara
Level 1
Level 1
Posts: 28
Joined: Thu May 06, 2021 7:35 am

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by Tara »

Hello,
the system information report application does not run the information report. It only shows: 1) Set up the system restore utility.
Tara
Level 1
Level 1
Posts: 28
Joined: Thu May 06, 2021 7:35 am

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by Tara »

Hello.
I entered the Inixi Fxz command and received the following information. Please let me know if this helps.

Thank you,

___________________________________

mint@mint:~$ inixi - Fxz

Command 'inixi' not found, did you mean:

command 'inxi' from deb inxi

Try: sudo apt install <deb name>

mint@mint:~$ inxi -Fxz
System: Host: mint Kernel: 4.15.0-20-generic i686 bits: 32 gcc: 7.3.0
Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Linux Mint 19 Tara
Machine: Device: portable System: Dell product: Vostro 1500 serial: N/A
Mobo: Dell model: 0WY040 serial: N/A
BIOS: Dell v: A01 date: 08/02/2007
CPU: Dual core Intel Core2 Duo T7250 (-MCP-)
arch: Conroe rev.13 cache: 2048 KB
flags: (lm nx pae sse sse2 sse3 ssse3 vmx) bmips: 7978
clock speeds: max: 2001 MHz 1: 1044 MHz 2: 1044 MHz
Graphics: Card: NVIDIA G84M [GeForce 8600M GT] bus-ID: 01:00.0
Display Server: x11 (X.Org 1.19.6 )
drivers: nouveau (unloaded: modesetting,fbdev,vesa)
Resolution: 1280x800@60.01hz
OpenGL: renderer: NV84
version: 3.3 Mesa 18.0.0-rc5 Direct Render: Yes
Audio: Card Intel 82801H (ICH8 Family) HD Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network: Card-1: Broadcom Limited BCM4401-B0 100Base-TX
driver: b44 v: 2.0 bus-ID: 03:00.0
IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Card-2: Broadcom Limited BCM4311 802.11b/g WLAN
driver: b43-pci-bridge bus-ID: 0c:00.0
IF: N/A state: N/A mac: N/A
Drives: HDD Total Size: 311.9GB (0.6% used)
ID-1: /dev/sda model: WDC_WD2500BEVS size: 250.1GB temp: 41C
ID-2: USB /dev/sdb model: USB_Flash_Drive size: 61.9GB temp: 0C
Partition: ID-1: / size: 1006M used: 423M (42%) fs: overlay dev: N/A
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 44.0C mobo: N/A gpu: 64.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 161 Uptime: 42 min Memory: 453.2/2010.4MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56
mint@mint:~$
bodge99

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by bodge99 »

Hi,

You appear to have a Broadcom BCM4311 wifi card.

Try this:

Open "Software Manager". Search for "Firmware-b43-installer".
Install this and reboot. Now try your wifi..

If this fails, could you post the output of:

Code: Select all

dmesg | grep b43
Bodge99
Tara
Level 1
Level 1
Posts: 28
Joined: Thu May 06, 2021 7:35 am

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by Tara »

Hi bodge99,
1) I installed Firmware-b43-Installer and did not receive an error message after installation
2) I re-booted my computer but there is still no WIFI connection
3) I run dmesg | grep b43 - Please find result below.
_______________________________________________________

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

mint@mint:~$ dmesg | grep b43
[ 29.857938] b43-phy0: Broadcom 4311 WLAN found (core revision 10)
[ 29.908117] b43-phy0: Found PHY: Analog 4, Type 2 (G), Revision 8
[ 29.908139] b43-phy0: Found Radio: Manuf 0x17F, ID 0x2050, Revision 2, Version 0
[ 29.924557] b43 ssb0:0: Direct firmware load for b43/ucode5.fw failed with error -2
[ 29.924576] b43 ssb0:0: Direct firmware load for b43/ucode5.fw failed with error -2
[ 29.924606] b43 ssb0:0: Direct firmware load for b43-open/ucode5.fw failed with error -2
[ 29.924622] b43 ssb0:0: Direct firmware load for b43-open/ucode5.fw failed with error -2
[ 29.924624] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
[ 29.924629] b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
[ 29.924632] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Dri ... cefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
mint@mint:~$
bodge99

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by bodge99 »

Hi,

At least the kernel is recognising the wifi card.. It would appear you are missing firmware.
I'll check this out tomorrow morning.. Tired, but still fixing a system for someone.

Nearly there !!

Bodge99
Tara
Level 1
Level 1
Posts: 28
Joined: Thu May 06, 2021 7:35 am

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by Tara »

Hi Bodge99,

Thank you for getting back to me. Have a good rest and hopefully we talk tomorrow.
bodge99

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by bodge99 »

Hi,

I fixed the computer in 10 minutes.. A "repair shop" had it for a week and couldn't... Go figure!!

See https://github.com/OpenELEC/wlan-firmwa ... /ucode5.fw

Download this file to somewhere safe (e.g. '/home/tara/Downloads'). Your user Downloads directory... and sorry, I'm just guessing the user name.

There should be a firmware file of this name already existing in '/lib/firmware'.. The downloaded one is slightly different. We'll rename the existing one later ({if necessary) and copy the downloaded one over. First off, check that you do actually do have an existing firmware file and see if we can use this one.

Now open a terminal:

Code: Select all

sudo su
ls /lib/firmware/b43/ucode5*  
If you see 'ucode5.fw' within the output then continue.

Code: Select all

depmod b43
Can you note any error message please.

Don't restart... Just unplug your ethernet cable for a couple of minutes.
Now see if your wifi is working.

If it is, then it would appear that your driver is blacklisted.. Don't worry about this.. We'll sort this later.
If the wifi works now, then it probably won't after a reboot.. You'll need to 'depmod' again.

I'll stop here until I hear from you exactly what is happening..

Bodge99
sleeper12
Level 16
Level 16
Posts: 6546
Joined: Thu May 25, 2017 3:22 pm

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by sleeper12 »

Try:

Edit: corrected

Code: Select all

 sudo apt purge bcmwl-kernel-source && sudo apt install --reinstall firmware-b43-installer 
Reboot
Last edited by sleeper12 on Wed May 12, 2021 12:18 pm, edited 1 time in total.
bodge99

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by bodge99 »

Hi,

sleeper12: Yes, this was going to be the next thing to try... 'dmesg' indicates that there is no firmware at '/lib/firmware/b43' ... but I'd like to see exactly what is there.

Broadcom wifi cards can sometimes be a little fiddly to get going sometimes for two reasons:

The firmware for all of the Broadcom cards is proprietary. Broadcom originally refused to supply firmware with any sort of open licence.. and some distro's refused to package unlicensed or restrictive licence code.
Users had to extract the actual firmware from a Windows driver and manually install it.

Some Broadcom wifi cards use slightly different firmware for certain chipset revisions.. In a couple of cases you need to know the exact chipset revision before you could get the card working properly. Thankfully these particular cards are quite rare.. I've only ever seen one of the "more difficult" ones.
I'm guessing that Broadcom decided that the use of multiple firmwares for what appears to be identical cards was a stupid idea.. It's either that or it's possible that some engineering samples managed to enter the supply chain..

We will "get there".

Bodge99
Last edited by bodge99 on Wed May 12, 2021 1:26 am, edited 1 time in total.
sleeper12
Level 16
Level 16
Posts: 6546
Joined: Thu May 25, 2017 3:22 pm

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by sleeper12 »

You have a very old kernel (4.15.0-20), so you might want to update that to 4.15.0-143.
Tara
Level 1
Level 1
Posts: 28
Joined: Thu May 06, 2021 7:35 am

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by Tara »

Hi Bodge99,
The system did not let me past your command from the forum therefore I entered it manually. Pls check if i entered it correct.

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

mint@mint:~$ sudo su ls /lib/firmware/b43/ucode5
No passwd entry for user 'ls'
mint@mint:~$ sudo su
root@mint:/home/mint# ls /lib/firmware/b43/ucode5
ls: cannot access '/lib/firmware/b43/ucode5': No such file or directory
root@mint:/home/mint#
Tara
Level 1
Level 1
Posts: 28
Joined: Thu May 06, 2021 7:35 am

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by Tara »

Hi Sleeper12,

How can i upgrade the kernel to update that to 4.15.0-143.?
Thank you,
bodge99

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by bodge99 »

Hi,

This should allow you to become Root i.e. the system administrator aka God. This assumes that 'sudo' is correctly set up on your system.
an alternative is below.

Code: Select all

sudo su {and press enter}

Code: Select all

su -
You have become 'Root' successfully, as shown by the changed prompt:

Code: Select all

mint@mint:  {Normal user prompt}

root@mint: {Root user prompt}
You have made a typo on the command and missed a character.. It should be:

Code: Select all

ls /lib/firmware/b43/ucode5*
Note the star character after the '5'.. No, it isn't muck on your screen ;>)
This says: List the contents of the directory '/lib/firmware/b43/' . It then specifies 'ucode5*' .
This means any filename beginning with 'ucode5' . The 'star' is a 'wild card' which means 'anything'.
**If they existed** here, then ucode5Staple.list, ucode5566.fw etc. would be listed. I'm specifically looking for the file 'ucode5.fw' .
Sometimes filenames are changed (as part of the evolutionary process)..
This file almost certainly does **not** exist here.. But I would like to check.
Now try (in the same terminal (because you are Root here)

Code: Select all

depmod b43
Now test to see if your wifi is working.
Could you update here exactly what happens please.

Bodge99
bodge99

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by bodge99 »

Hi,

I've just located a similar wifi card to yours. I'll stick in in a laptop and pull a 32-bit Mint 19 Xfce image off of the NAS..
I'll then be able to see better exactly what's going on.

Bodge99
Tara
Level 1
Level 1
Posts: 28
Joined: Thu May 06, 2021 7:35 am

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by Tara »

Hi Bodge99,
It still cannot find the firmware. I entered it both ways, once with a blanc after ls and the second time without.

mint@mint:~$ sudo su
root@mint:/home/mint# ls /lib/firmware/b43/ucode5*
ls: cannot access '/lib/firmware/b43/ucode5*': No such file or directory
root@mint:/home/mint# ^C
root@mint:/home/mint# ls/lib/firmware/b43/ucode5*
bash: ls/lib/firmware/b43/ucode5*: No such file or directory
root@mint:/home/mint#
Tara
Level 1
Level 1
Posts: 28
Joined: Thu May 06, 2021 7:35 am

Re: Linux Tara Ethernet but no WIFI connection after installation

Post by Tara »

Hello,
I tried to upgrade the kernel and received the following information

mint@mint:~$ sudo apt purge bcmwl-kernel-source && sudo apt install --reinstall b43 installer
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'bcmwl-kernel-source' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package b43
E: Unable to locate package installer
mint@mint:~$
Post Reply