SOLVED System Won't Resume from Sleep/Suspend (Black Screen)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
deepakdeshp
Level 19
Level 19
Posts: 9363
Joined: Sun Aug 09, 2015 10:00 am

Re: System Won't Resume from Sleep/Suspend (Black Screen)

Post by deepakdeshp »

Kudos SMG for analyzing the issue well.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

Mint 20.1 Cinnamon 64 bit with AMD A8/7410 / 8GB
Mint 20.1 Cinnamon AMD Ryzen3500U/8gb
qed
Level 1
Level 1
Posts: 18
Joined: Sun Apr 04, 2021 10:59 pm

Re: System Won't Resume from Sleep/Suspend (Black Screen)

Post by qed »

My apologies, but my issue still persists! When I leave the system idle for longer than 30 min, I can't boot back into the linux desktop. The last time it happened, I couldn't get back into a terminal command prompt when I hit alt + ctrl + f1. I checked my power settings and I have it set so that the screen turns off after 30 minutes. I can't imagine that this is the issue however, because the screen SHOULD turn on after I wake up the computer, correct? The computer is set to NEVER suspect when inactive (although I'd like it to).

This is the second distro I've been through and this issue is still a problem. Honestly I love LM, but I think I'm just cursed :( Can anyone help?
User avatar
SMG
Level 15
Level 15
Posts: 5551
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: System Won't Resume from Sleep/Suspend (Black Screen)

Post by SMG »

qed wrote:
Sun Apr 18, 2021 8:53 pm
My apologies, but my issue still persists! When I leave the system idle for longer than 30 min, I can't boot back into the linux desktop.
What do you mean by idle? Like when you just go away from the computer for more than 30 minutes and just let the default settings work? Or do you mean after the computer has been asleep for more than 30 minutes.
qed wrote:
Sun Apr 18, 2021 8:53 pm
The last time it happened, I couldn't get back into a terminal command prompt when I hit alt + ctrl + f1. I checked my power settings and I have it set so that the screen turns off after 30 minutes. I can't imagine that this is the issue however, because the screen SHOULD turn on after I wake up the computer, correct? The computer is set to NEVER suspect when inactive (although I'd like it to).
I do not know anything about your monitor, so I do not know what is "should" do. Not all monitors are designed the same way.
A woman typing on a laptop with LM20.1 Cinnamon.
FooYoungHi
Level 1
Level 1
Posts: 12
Joined: Sat Feb 01, 2020 5:20 pm

Re: System Won't Resume from Sleep/Suspend (Black Screen)

Post by FooYoungHi »

I think I'm having the same issues. On windows everything works fine, and on Mint it suddenly stopped working a few weeks ago.
Even if I just turn off my display, it won't come back on. It will just go back to standby after showing a 'no signal' message. It is hooked up by HDMI.
I've been messing around with different kernels (found out today you can change them at boot), and I found that up to 5.4.0-66 everything works fine, but after that one, the screen won't turn back on when waking up from sleep or standby. I tried the latest 5.8 kernel, but the issue remains.
The system doesn't crash or anything, it's just the monitor that doesn't turn back on. I can press the power button on my PC (set to ask what to do), press Enter and it will shut down.
Whatever it is (handshake issue?), it seemingly happened in 5.4.0-67.
User avatar
SMG
Level 15
Level 15
Posts: 5551
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: System Won't Resume from Sleep/Suspend (Black Screen)

Post by SMG »

FooYoungHi wrote:
Fri Apr 23, 2021 7:52 am
I think I'm having the same issues.
Do you have the exact same hardware? If not, please create your own thread for your issue. There are a number of things which can cause this type of issue.
Example: There is an issue with computers with AMD graphics not resuming from sleep which started with kernel 5.4.0-66. Kernel 5.4.0-66 - monitor doesn't wake from sleep which is a known bug and does not apply to the OP of this thread. The fact you are seeing your issue consistently while the OP of this thread is not makes it likely your issue is different.
A woman typing on a laptop with LM20.1 Cinnamon.
qed
Level 1
Level 1
Posts: 18
Joined: Sun Apr 04, 2021 10:59 pm

Re: System Won't Resume from Sleep/Suspend (Black Screen)

Post by qed »

Hello, sorry for the late reply! I nearly gave up on this VERY frustrating issue.
SMG wrote:
Mon Apr 19, 2021 3:48 pm
What do you mean by idle?
When I leave the computer idol for more than 30 min and let the default settings work, the screen goes black. If I try to wake it up, the screen stays black, and my monitor displays a message that says "no input signal received".

Sometimes I can get into a tty by pressing CTRL + ALT + F1. CTRL + ALT + Backspace does not do anything.

I'm just totally clueless about what to do about this.
User avatar
SMG
Level 15
Level 15
Posts: 5551
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: System Won't Resume from Sleep/Suspend (Black Screen)

Post by SMG »

Some people found their laptops were having issues with the Nvidia-460 and suspend. When they used the Nvidia-450 everything worked properly. I do not know if that might apply in your case or even if you are still using the same driver version you were earlier in the thread. It's possible an updated graphics driver (if available) might help.

Please supply the current inxi -SMCGx.
A woman typing on a laptop with LM20.1 Cinnamon.
qed
Level 1
Level 1
Posts: 18
Joined: Sun Apr 04, 2021 10:59 pm

Re: System Won't Resume from Sleep/Suspend (Black Screen)

Post by qed »

OK, here is the result of my

Code: Select all

inxi -SMCGx
:

Code: Select all

System:
  Host: nick-Z390-AORUS-PRO-WIFI Kernel: 5.8.0-53-generic x86_64 bits: 64 
  compiler: N/A Desktop: Cinnamon 4.8.6 Distro: Linux Mint 20.1 Ulyssa 
  base: Ubuntu 20.04 focal 
Machine:
  Type: Desktop System: Gigabyte product: Z390 AORUS PRO WIFI v: N/A 
  serial: <superuser/root required> 
  Mobo: Gigabyte model: Z390 AORUS PRO WIFI-CF v: x.x 
  serial: <superuser/root required> UEFI: American Megatrends v: F12k 
  date: 01/19/2021 
CPU:
  Topology: 6-Core model: Intel Core i5-9600K bits: 64 type: MCP 
  arch: Kaby Lake rev: D L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 44398 
  Speed: 800 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 801 6: 800 
Graphics:
  Device-1: NVIDIA TU104 [GeForce RTX 2080 SUPER] vendor: eVga.com. 
  driver: nvidia v: 460.73.01 bus ID: 02:00.0 
  Display: x11 server: X.Org 1.20.9 driver: nvidia 
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 2560x1440~100Hz 
  OpenGL: renderer: GeForce RTX 2080 SUPER/PCIe/SSE2 
  v: 4.6.0 NVIDIA 460.73.01 direct render: Yes 
I just updated to the latest Nvidia driver (460.73.01). I was using an earlier version of the 460 driver before.

Oddly enough, I have the power settings set so that the machine never goes into stand-by mode. I just want the display to turn off after 30 min, that's it!

Thanks for your continued support :)
qed
Level 1
Level 1
Posts: 18
Joined: Sun Apr 04, 2021 10:59 pm

Re: System Won't Resume from Sleep/Suspend (Black Screen)

Post by qed »

I tried following the advice given here: https://askubuntu.com/questions/477138/ ... tor-off-on

I created an xorg.conf file in my /etc/X11 directory using nvidia-xconf. I modified the xorg.conf file, adding Option "UseHotplugEvents" "false" but the issue persists. This is only an issue when I have the monitor set to turn off after a specified time. When I press CTRL + ALT + F7, I'm able to get back into the desktop. VERY strange issue.
User avatar
SMG
Level 15
Level 15
Posts: 5551
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: System Won't Resume from Sleep/Suspend (Black Screen)

Post by SMG »

qed wrote:
Thu May 13, 2021 3:19 pm
I tried following the advice given here: https://askubuntu.com/questions/477138/ ... tor-off-on

I created an xorg.conf file in my /etc/X11 directory using nvidia-xconf. I modified the xorg.conf file, adding Option "UseHotplugEvents" "false" but the issue persists. This is only an issue when I have the monitor set to turn off after a specified time. When I press CTRL + ALT + F7, I'm able to get back into the desktop. VERY strange issue.
Your system is based on Ubuntu 20.04 which means the advice you followed in that thread is very, very old. There have been a lot of changes to the underlying code since then. We generally do not recommend following advice that old.

Also, the setting in Power Management is to blank the screen and not turn off the monitor. If you have the monitor set to turn off, then that seems like it would be a setting on the monitor.
qed wrote:
Thu May 13, 2021 1:29 pm
I just updated to the latest Nvidia driver (460.73.01). I was using an earlier version of the 460 driver before.
So you have not yet tried the Nvidia-450?
qed wrote:
Thu May 13, 2021 1:29 pm
Oddly enough, I have the power settings set so that the machine never goes into stand-by mode. I just want the display to turn off after 30 min, that's it!
There are settings in both the Screensaver app and the Power Management app. You will want to make sure neither is suspending the computer.
A woman typing on a laptop with LM20.1 Cinnamon.
qed
Level 1
Level 1
Posts: 18
Joined: Sun Apr 04, 2021 10:59 pm

Re: System Won't Resume from Sleep/Suspend (Black Screen)

Post by qed »

I can't believe it, but downgrading from the nvidia 460 to the 450 fixed the issue. Not sure what the difference is between the two versions other than the number, but it works!

Thanks again!
User avatar
Larry78723
Level 11
Level 11
Posts: 3884
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: System Won't Resume from Sleep/Suspend (Black Screen)

Post by Larry78723 »

If you have found the solution to your initial post, please open your original post, click on the pencil, and add (Solved) to the Subject.
Image
Post Reply