(Solved) No Video after LM21 upgrade.

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
ronsmeyer
Level 2
Level 2
Posts: 55
Joined: Thu Aug 13, 2015 5:28 pm

(Solved) No Video after LM21 upgrade.

Post by ronsmeyer »

The LM21 upgrade completed successfully. But, when I rebooted, there was no video.
The monitor was saying no HDMI signal. But all was well with LM20.3.

The monitor is a fairly new ASUS Pro Art PA279CV and the monitor only has HDMI and Display Port connectors.
However, I built this computer in 2009 and the old NVIDIA GTX-275 card only has DVI and VGA.
So for about a year, I've had the monitor connected using a DVI to HDMI adapter.

I have an old small Dell monitor that uses DVI and when I connected it, the video worked just fine with the LM21 upgrade.
When I Timeshifted out the upgrade and went back to LM20.3, my Pro Art monitor "saw" the HDMI signal and worked again.

It seems to me the adapter or the connection cannot be bad if it works with 20.3, doesn't work with 21, but then works again when 20.3 is restored.

What could possibly be in LM21 that keeps my monitor from even "seeing" the HDMI signal, but yet it does "see" it with 20.3.
There are no other drivers available on the drivers page.

Does anyone have any idea what is happening?

Thank you.

Code: Select all

System:    Kernel: 5.4.0-122-generic x86_64 bits: 64 compiler: gcc v: 9.4.0 Desktop: Cinnamon 5.2.7 wm: muffin 5.2.1 
           dm: LightDM 1.30.0 Distro: Linux Mint 20.3 Una base: Ubuntu 20.04 focal 
Machine:   Type: Desktop Mobo: EVGA model: 132-BL-E758 v: Tylersburg serial: <filter> BIOS: Phoenix v: 6.00 PG 
           date: 04/20/2011 
CPU:       Topology: Quad Core model: Intel Core i7 920 bits: 64 type: MT MCP arch: Nehalem rev: 5 
           L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 42451 
           Speed: 1697 MHz min/max: 1596/2661 MHz boost: enabled Core speeds (MHz): 1: 1781 2: 1809 3: 1875 4: 1758 
           5: 1879 6: 1811 7: 1888 8: 1863 
Graphics:  Device-1: NVIDIA GT200b [GeForce GTX 275] vendor: eVga.com. driver: nvidia v: 340.108 bus ID: 02:00.0 
           chip ID: 10de:05e6 
           Display: x11 server: X.Org 1.20.13 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 275/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108 direct render: Yes 
Last edited by ronsmeyer on Wed Oct 12, 2022 2:30 pm, edited 1 time in total.
Cosmo.
Level 24
Level 24
Posts: 22055
Joined: Sat Dec 06, 2014 7:34 am

Re: No Video after LM21 upgrade.

Post by Cosmo. »

Your computer is about 10 years old, possibly too old for the kernel in LM 21.
Gotcha!
User avatar
mikaelrask
Level 5
Level 5
Posts: 644
Joined: Wed Mar 13, 2019 7:38 am
Location: Sweden
Contact:

Re: No Video after LM21 upgrade.

Post by mikaelrask »

Hey i believe the problem for you on linux mint 21 is that it comes with a new driver of NVIDIA 515 https://www.nvidia.com/Download/driverR ... 043/en-us/. witch does not support your NVIDIA card. but you can try using the open source driver that comes with the kernel if you wanna give linux mint 21 another go. or keep using Linux mint 20, 3 it supported until 2025. witch have a older NVIDIA driver that support your NVIDIA card.
CPU Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
Graphic Card: NVIDIA 2070 super
Ram 32 GB
Kernel: 5.15.0-56 generic
LM Mate 21.

Laptop:
CPU Intel(R) Core(TM) i5-245m
Ram 4 gb
LM xfce 21
Kernel 5.15.0-56-generic
User avatar
MiZoG
Level 5
Level 5
Posts: 586
Joined: Fri Jan 26, 2018 8:30 pm

Re: No Video after LM21 upgrade.

Post by MiZoG »

Loss of nvidia v: 340.108 may be accountable for your problem. The legacy driver has been "decommissioned" and therefore not supported by nvidia on newer kernels. This is a source of trouble for people upgrading their old machines to Ubuntu Jammy / LM 21. Nouveau, the open source driver and sole alternative right now, beyond crippled 3D performance we already knew about, proves very inefficient in power management. The blame is on nvidia of course unwilling to disclose information and leading nouveau development to an essential halt. Lately, nvidia published a good deal of documentation about their older chips but it will take some time for nouveau developers to catch up if they are ever going to catch up.
Stick with 20.3 until "end of life". Otherwise, a ppa has shown up. Its maintainer builds the legacy driver for newer kernels. At least one user on this forum reports success but you have to be warned you're going to use this third-party repository at your own risk.
ronsmeyer
Level 2
Level 2
Posts: 55
Joined: Thu Aug 13, 2015 5:28 pm

Re: No Video after LM21 upgrade.

Post by ronsmeyer »

What is really strange about this is, if I boot LM21 from a USB stick, it works! The video is fine. Booting from USB would use the same driver as an actual upgrade, wouldn't it? Or does a USB boot use something different?

What is also strange, is after the actual upgrade, when I plugged in that old Dell monitor, it is going from the DVI port on the video card to an old VGA connector on the monitor, and that works too. If I hadn't had this monitor, I would have been screwed because otherwise, the screen is just black.

I think I'll give it a go again, in the next few days and see if the 340 driver might work.

I'm telling you...to whoever is responsible for Timeshift, you've saved me a number of times! Thanks.
User avatar
SMG
Level 23
Level 23
Posts: 18954
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: No Video after LM21 upgrade.

Post by SMG »

ronsmeyer wrote:
Sun Sep 25, 2022 9:39 pm
What is really strange about this is, if I boot LM21 from a USB stick, it works! The video is fine. Booting from USB would use the same driver as an actual upgrade, wouldn't it? Or does a USB boot use something different?
The USB/live session uses the open-source nouveau graphics drivers.

The Nvidia-340 driver is not supported in LM21. Did you remove that driver before you upgraded from LM20.3 to LM21 and install the open-source one?
Image
A woman typing on a laptop with LM20.3 Cinnamon.
User avatar
SMG
Level 23
Level 23
Posts: 18954
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: No Video after LM21 upgrade.

Post by SMG »

mikaelrask wrote:
Sun Sep 25, 2022 1:42 am
Hey i believe the problem for you on linux mint 21 is that it comes with a new driver of NVIDIA 515 https://www.nvidia.com/Download/driverR ... 043/en-us/. witch does not support your NVIDIA card.
Linux Mint 21 does not come with any proprietary Nvidia drivers. It only comes with the open-source one.
Image
A woman typing on a laptop with LM20.3 Cinnamon.
ronsmeyer
Level 2
Level 2
Posts: 55
Joined: Thu Aug 13, 2015 5:28 pm

Re: No Video after LM21 upgrade.

Post by ronsmeyer »

SMG wrote:
Sun Sep 25, 2022 10:01 pm
ronsmeyer wrote:
Sun Sep 25, 2022 9:39 pm
What is really strange about this is, if I boot LM21 from a USB stick, it works! The video is fine. Booting from USB would use the same driver as an actual upgrade, wouldn't it? Or does a USB boot use something different?
The USB/live session uses the open-source nouveau graphics drivers.

The Nvidia-340 driver is not supported in LM21. Did you remove that driver before you upgraded from LM20.3 to LM21 and install the open-source one?
I did not see anything that told me I was supposed to remove the Nvidia driver from 20.3, so no, I didn't remove it. But, I will do so on the next try. Thanks for the tip. Shouldn't the upgrade have removed any Nvidia drivers if they don't come with the upgrade?
Hoser Rob
Level 19
Level 19
Posts: 9429
Joined: Sat Dec 15, 2012 8:57 am

Re: No Video after LM21 upgrade.

Post by Hoser Rob »

ronsmeyer wrote:
Sun Sep 25, 2022 10:34 pm
... I did not see anything that told me I was supposed to remove the Nvidia driver from 20.3, so no, I didn't remove it. But, I will do so on the next try. Thanks for the tip. Shouldn't the upgrade have removed any Nvidia drivers if they don't come with the upgrade?
All I can say is, welcome to Linux Land. That's just how things work. Windows will tell you you're the administrator but you aren't, Windows is. In Linux you really are. You're never going to get anything like those "your computer will not run WIndows 11" messages when updating in Linux. So you need to research these things. Especially with old boxes.
rambo919
Level 5
Level 5
Posts: 620
Joined: Wed May 22, 2013 3:11 pm

Re: No Video after LM21 upgrade.

Post by rambo919 »

He has a point though, checking the video driver should have been part of the automated upgrade process.... it's just that no one thought to add it probably due to pressure from people to get the upgrade out fast as possible.
User avatar
Pjotr
Level 23
Level 23
Posts: 18163
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland) 🇳🇱
Contact:

Re: No Video after LM21 upgrade.

Post by Pjotr »

A fresh clean installation of Mint 21 is technically always the best option; better than upgrading in-place from 20.x. So that's what I recommend in this case as well.

See it as a blessing in disguise. :mrgreen:
Tip: 10 things to do after installing Linux Mint 21 Vanessa
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.
User avatar
SMG
Level 23
Level 23
Posts: 18954
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: No Video after LM21 upgrade.

Post by SMG »

ronsmeyer wrote:
Sun Sep 25, 2022 10:34 pm
Shouldn't the upgrade have removed any Nvidia drivers if they don't come with the upgrade?
The Nvidia-340 driver is a proprietary driver. It does not come with any version of Linux Mint (regular install or upgrade). You installed that driver separately after you installed Linux Mint.

I do not know specifically how the upgrade program handles proprietary drivers. I thought I recalled seeing someone else's upgrade and their system had been switched to the open-source driver when they upgraded, but I do not recall for sure if that is what happened.
Image
A woman typing on a laptop with LM20.3 Cinnamon.
User avatar
SMG
Level 23
Level 23
Posts: 18954
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: No Video after LM21 upgrade.

Post by SMG »

rambo919 wrote:
Mon Sep 26, 2022 9:12 am
He has a point though, checking the video driver should have been part of the automated upgrade process.... it's just that no one thought to add it probably due to pressure from people to get the upgrade out fast as possible.
I see no evidence to support your statement that no one thought to check the driver. Others who have had the Nvidia-340 installed have not run into this issue.
Image
A woman typing on a laptop with LM20.3 Cinnamon.
rambo919
Level 5
Level 5
Posts: 620
Joined: Wed May 22, 2013 3:11 pm

Re: No Video after LM21 upgrade.

Post by rambo919 »

SMG wrote:
Mon Sep 26, 2022 9:23 am
rambo919 wrote:
Mon Sep 26, 2022 9:12 am
He has a point though, checking the video driver should have been part of the automated upgrade process.... it's just that no one thought to add it probably due to pressure from people to get the upgrade out fast as possible.
I see no evidence to support your statement that no one thought to check the driver. Others who have had the Nvidia-340 installed have not run into this issue.
You seem to be trying to argue two contradicting conclusions at the same time here:
The driver which is compatible with LM20.3 but incompatible with LM21 IS the problem that popped up due to the upgrade
The driver which is compatible with LM20.3 but incompatible with LM21 IS NOT the problem that popped up due to the upgrade
User avatar
Pjotr
Level 23
Level 23
Posts: 18163
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland) 🇳🇱
Contact:

Re: No Video after LM21 upgrade.

Post by Pjotr »

rambo919 wrote:
Mon Sep 26, 2022 9:30 am
SMG wrote:
Mon Sep 26, 2022 9:23 am
rambo919 wrote:
Mon Sep 26, 2022 9:12 am
He has a point though, checking the video driver should have been part of the automated upgrade process.... it's just that no one thought to add it probably due to pressure from people to get the upgrade out fast as possible.
I see no evidence to support your statement that no one thought to check the driver. Others who have had the Nvidia-340 installed have not run into this issue.
You seem to be trying to argue two contradicting conclusions at the same time here:
The driver which is compatible with LM20.3 but incompatible with LM21 IS the problem that popped up due to the upgrade
The driver which is compatible with LM20.3 but incompatible with LM21 IS NOT the problem that popped up due to the upgrade
No, SMG is right here.

The nvidia-340 may well have been tested by the devs beforehand, and may well have caused no issues in that upgrade test. Because, as SMG rightly pointed out, others who have had the Nvidia-340 installed have not run into this issue.

So we simply can't state that rejecting that driver should have been part of the upgrade process, like you do. Nor state that such a rejection was skipped because of time pressure.

Anyway, it's a moot point. As I already said: a fresh installation of Mint 21 is best in all cases. :mrgreen:
Tip: 10 things to do after installing Linux Mint 21 Vanessa
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.
User avatar
SMG
Level 23
Level 23
Posts: 18954
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: No Video after LM21 upgrade.

Post by SMG »

rambo919 wrote:
Mon Sep 26, 2022 9:30 am
You seem to be trying to argue two contradicting conclusions at the same time here:
The driver which is compatible with LM20.3 but incompatible with LM21 IS the problem that popped up due to the upgrade
The driver which is compatible with LM20.3 but incompatible with LM21 IS NOT the problem that popped up due to the upgrade
No, I am not.

The OP did not provide any data from their upgrade. I have no idea what showed up. All I know is they said they had no video. They only provided inxi information from their LM20.3 install.

I never said it was required to remove the driver. I only asked if they had removed the driver before upgrading because I know that driver is not supported with the newer kernel and graphics stack.

I do not know why they didn't have video which is why I am asking questions. I have not yet provided any theories of what might have happened. I am still in the information gathering phase.
Image
A woman typing on a laptop with LM20.3 Cinnamon.
rambo919
Level 5
Level 5
Posts: 620
Joined: Wed May 22, 2013 3:11 pm

Re: No Video after LM21 upgrade.

Post by rambo919 »

Fair enough.
User avatar
JerryF
Level 15
Level 15
Posts: 5881
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: No Video after LM21 upgrade.

Post by JerryF »

ronsmeyer wrote:
Sun Sep 25, 2022 9:39 pm
I'm telling you...to whoever is responsible for Timeshift, you've saved me a number of times! Thanks.
You can thank Tony George aka TeeJeeTech. He created it, but now is unable to maintain it with all the other projects he's got. Now Linux Mint is maintaining Timeshift.
ronsmeyer
Level 2
Level 2
Posts: 55
Joined: Thu Aug 13, 2015 5:28 pm

Re: No Video after LM21 upgrade.

Post by ronsmeyer »

SMG wrote:
Mon Sep 26, 2022 10:01 am
rambo919 wrote:
Mon Sep 26, 2022 9:30 am
You seem to be trying to argue two contradicting conclusions at the same time here:
The driver which is compatible with LM20.3 but incompatible with LM21 IS the problem that popped up due to the upgrade
The driver which is compatible with LM20.3 but incompatible with LM21 IS NOT the problem that popped up due to the upgrade
No, I am not.

The OP did not provide any data from their upgrade. I have no idea what showed up. All I know is they said they had no video. They only provided inxi information from their LM20.3 install.

I never said it was required to remove the driver. I only asked if they had removed the driver before upgrading because I know that driver is not supported with the newer kernel and graphics stack.

I do not know why they didn't have video which is why I am asking questions. I have not yet provided any theories of what might have happened. I am still in the information gathering phase.
The upgrade completed successfully. When I restarted, I got the GRUB screen and the LM logo. Then the screen went black. That's all.

But the upgrade apparently does do something with nvidia. Of the 22,713 lines that went to the terminal, these are lines containing the word 'nvidia'.

So I will completely remove the nvidia 340 driver before the next try.

Code: Select all

EDIT---|/home/ron/Mint21-Upgrade.txt =u(22-09-22 21:31)-----------------------------------------------------------------------------------------------------------------
===>                                                                                                                                                                    
*******|*u*t**l*** TOP OF FILE *******Lig:OFF, Unicomb: SPLIT **********************************************************************************************************
-------|-   3462 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
0346300|  nux-tools nvidia-340 nvidia-opencl-icd-340 nvidia-prime nvidia-prime-applet                                                                                  
0346400|  nvidia-settings ocl-icd-libopencl1 ocl-icd-libopencl1:i386 odbcinst                                                                                          
-------|-    580 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
0404500|Get:470 http://packages.linuxmint.com vanessa/main amd64 nvidia-prime-applet all 1.3.4 [37.1 kB]                                                               
-------|-    160 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
0420600|Get:631 http://archive.ubuntu.com/ubuntu jammy/restricted amd64 nvidia-340 amd64 340.108-0ubuntu8 [6,452 B]                                                    
-------|-   1595 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
0580200|Get:2227 http://archive.ubuntu.com/ubuntu jammy/main amd64 nvidia-prime all 0.8.17.1 [9,956 B]                                                                 
-------|-    954 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
0675700|Get:3182 http://archive.ubuntu.com/ubuntu jammy/multiverse amd64 nvidia-opencl-icd-340 amd64 340.108-0ubuntu8 [6,476 B]                                        
-------|-      1 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
0675900|Get:3184 http://archive.ubuntu.com/ubuntu jammy/main amd64 nvidia-settings amd64 510.47.03-0ubuntu1 [960 kB]                                                   
-------|-    682 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
0744200|  nvidia-settings ocl-icd-libopencl1 ocl-icd-libopencl1:i386 odbcinst                                                                                          
-------|-    248 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
0769100|  neofetch netbase ntp-doc nvidia-340 nvidia-opencl-icd-340 nvidia-prime                                                                                       
0769200|  nvidia-prime-applet odt2txt openclipart-libreoffice openclipart-png                                                                                          
-------|-   1939 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
0963200|Preparing to unpack .../584-nvidia-340_340.108-0ubuntu8_amd64.deb ...                                                                                          
0963300|Stopping nvidia-persistenced                                                                                                                                   
0963400|nvidia-persistenced: no process found                                                                                                                          
-------|-      3 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
0963800|Unpacking nvidia-340 (340.108-0ubuntu8) over (340.108-0ubuntu5.20.04.2) ...                                                                                    
0963900|dpkg: warning: unable to delete old directory '/usr/lib/nvidia-340': Directory not empty                                                                       
0964000|Preparing to unpack .../585-nvidia-opencl-icd-340_340.108-0ubuntu8_amd64.deb ...                                                                               
0964100|Unpacking nvidia-opencl-icd-340 (340.108-0ubuntu8) over (340.108-0ubuntu5.20.04.2) ...                                                                         
-------|-      2 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
0964400|Preparing to unpack .../586-nvidia-prime_0.8.17.1_all.deb ...                                                                                                  
0964500|Unpacking nvidia-prime (0.8.17.1) over (0.8.16~0.20.04.2) ...                                                                                                  
-------|-      4 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
0965000|Preparing to unpack .../589-nvidia-prime-applet_1.3.4_all.deb ...                                                                                              
0965100|Unpacking nvidia-prime-applet (1.3.4) over (1.3.1) ...                                                                                                         
-------|-    415 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
1006700|Setting up nvidia-340 (340.108-0ubuntu8) ...                                                                                                                   
-------|-    126 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
1019400|Setting up nvidia-prime (0.8.17.1) ...                                                                                                                         
-------|-    181 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
1037600|Setting up nvidia-opencl-icd-340 (340.108-0ubuntu8) ...                                                                                                        
-------|-    661 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
1103800|Setting up nvidia-prime-applet (1.3.4) ...                                                                                                                     
-------|-    706 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
1174500|  nvidia-settings ocl-icd-libopencl1 ocl-icd-libopencl1:i386 odbcinst                                                                                          
-------|-   5770 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
1751600|Preparing to unpack .../677-nvidia-settings_510.47.03-0ubuntu1_amd64.deb ...                                                                                   
1751700|Unpacking nvidia-settings (510.47.03-0ubuntu1) over (470.57.01-0ubuntu0.20.04.3) ...                                                                           
-------|-   1104 line excluded -----------------------------------------------------------------------------------------------------------------------------------------
1862200|Setting up nvidia-settings (510.47.03-0ubuntu1) ...
------|-   4111 line excluded -----------------------------------------------------------------------------------------------------------------------------------------       
Upgrade successful! You can now close this terminal and reboot your computer.
*******|*u*t**l*** END OF FILE *******Lig:OFF, Unicomb: SPLIT *******************************************************************
User avatar
SMG
Level 23
Level 23
Posts: 18954
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: No Video after LM21 upgrade.

Post by SMG »

ronsmeyer wrote:
Mon Sep 26, 2022 2:36 pm
The upgrade completed successfully. When I restarted, I got the GRUB screen and the LM logo. Then the screen went black. That's all.
That sounds like a graphics driver related issue, but hard to say what the issue might have been without any data.

Did you try switching to a terminal or rebooting into recovery mode? Booting in recovery mode adds the nomodeset kernel parameter which usually (but not always, depending upon the issue) will give software rendering graphics so troubleshooting work can be done.
ronsmeyer wrote:
Mon Sep 26, 2022 2:36 pm
But the upgrade apparently does do something with nvidia.
I would think that it would. Even if the Nvidia GPU is supported in LM21, I would expect the packages used would change from the Ubuntu 20.04 packages (LM20.3) to the Ubuntu 22.04 packages (LM21) if one is using proprietary Nvidia drivers from the package management system.

I did a quick pass through the mintupgrade code and it references checking the old and new repositories for what you have installed. The code does not specifically check for nvidia. However, if you have a proprietary nvidia driver installed, that would be listed in your "old" repositories.

It's my understanding from nvidia-graphics-drivers-340 340.108-0ubuntu8 source package in Ubuntu the 340 packages became transitional to the nouveau driver packages in Ubuntu 21.04 (Hirsuite). I see on that same page they were also applied for Jammy (Ubuntu 22.04-LM21). Notice the specific number which ends in 0ubuntu8.
ronsmeyer wrote:
Mon Sep 26, 2022 2:36 pm
Of the 22,713 lines that went to the terminal, these are lines containing the word 'nvidia'.
The nvidia-prime-applet is a Linux Mint package which is included in all installs (even if one does not have Nvidia). I believe that is also still true for nvidia-prime. So those two would switch regardless of whether one has nvidia.

Looking through the rest of what you posted, I see the following (one example):

Code: Select all

 0963800|Unpacking nvidia-340 (340.108-0ubuntu8) over (340.108-0ubuntu5.20.04.2) ... 
The one being unpacked is the same number as the one in the link I provided which says it is now a transitional package to nouveau. (Notice the 0ubuntu8 at the end.) It is going over the package which would be the one you have installed from LM20.3 (based on the 20.04.2 at the end of its number). So this would seem to indicate the mintupgrade program would be switching you to the open-source driver (based on our understanding of the package numbers). Whether or not the transitional packages worked properly is not something I can guess from this output.

If you switch to the open-source nouveau driver before upgrading, then your upgrade would not pass through the transitional packages. It would go from LM20.3 nouveau to LM21 nouveau. I would guess that would be a cleaner change than going through transitional packages, but maybe there is no real difference.
Image
A woman typing on a laptop with LM20.3 Cinnamon.
Post Reply

Return to “Installation & Boot”