Error dual boot Linux Mint Cinnamon (Dell Notebook)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
andrs75
Level 1
Level 1
Posts: 9
Joined: Tue Mar 01, 2022 2:59 pm

Error dual boot Linux Mint Cinnamon (Dell Notebook)

Post by andrs75 »

Dear all,

I´m not an expert on informatics, but still think that Linux Mint is a very interesting O.S. I have a Dell Notebook running Windows 11 and Linux Mint 21 Cinnamon in dual boot mode. It was made a clean install of Linux Mint. Both O.S. are working well. Nevertheless, I´m becoming two error messages:

1) Low space in efi partition (6MB out of 100 MB) once I login to LInux Mint.
2) During booting, I see this message on the screen: "GNU GRUB version 2.06. Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device of file completions. grub>"

In order to skip those errors, for the first one I click on ignore. For the second one, I type reboot after grub>. In any case, this is really annoying and does not motivate me to keep using Linux Mint. Do you have any idea about how to solve this in a simple-easy way?

Kind regards.
Andrés.
deepakdeshp
Level 20
Level 20
Posts: 11293
Joined: Sun Aug 09, 2015 10:00 am

Re: Error dual boot Linux Mint Cinnamon (Dell Notebook)

Post by deepakdeshp »

Log into the Linux Mint, navigating to the /boot/efi/EFI directory, list its contents and deleting the unwanted folder(s), using the commands shown in the following code block. Just be absolutely sure that you do not delete the Microsoft folder. The same goes for the folder of the existing Linux distribution.:
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help.
Regards,
Deepak

Mint 20.3 Cinnamon 64 bit with AMD A6 / 8GB
Mint 20.3 Cinnamon AMD Ryzen3500U/8gb
bendipa
Level 4
Level 4
Posts: 358
Joined: Sat Jan 04, 2020 8:02 pm
Location: NW London. UK

Re: Error dual boot Linux Mint Cinnamon (Dell Notebook)

Post by bendipa »

From your USB drive boot into Live Mint, run the command sudo parted -l and then paste the output.
Computer: Dell Vostro 470
Systems: Linux Mint 21 Xfce (Vanessa), Manjaro 22.0 Xfce (Sikaris), Windows 10 (21H2) Pro.
andrs75
Level 1
Level 1
Posts: 9
Joined: Tue Mar 01, 2022 2:59 pm

Re: Error dual boot Linux Mint Cinnamon (Dell Notebook)

Post by andrs75 »

Thank you very much for your answers. Actually I read EFI folder and appeared the following folders: Boot, Dell, Microsoft and Ubuntu. Therefore, there is nothing to delete. Probably expanding that folder could solve low space problem, but I don´t know how. After running the command sudo parted -l appears the following:

mint@mint:~$ sudo parted -l
Model: ATA Crucial_FCCT1000 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 106MB 105MB fat32 EFI system partition boot, esp
2 106MB 123MB 16.8MB Microsoft reserved partition msftres
3 123MB 288GB 288GB ntfs Basic data partition msftdata
4 288GB 550GB 261GB ntfs Basic data partition msftdata
5 550GB 1000GB 451GB ext4

Model: ATA WDC WDS500G2B0B (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 500GB 500GB primary ntfs

Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sdc: 15.4GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 32.8kB 2445MB 2445MB ISO9660 hidden, msftdata
2 2445MB 2449MB 4350kB Appended2 boot, esp
3 2449MB 15.4GB 12.9GB ext4
bendipa
Level 4
Level 4
Posts: 358
Joined: Sat Jan 04, 2020 8:02 pm
Location: NW London. UK

Re: Error dual boot Linux Mint Cinnamon (Dell Notebook)

Post by bendipa »

OK. Looking at your hard drives, I see Mint has been installed, on sda5, on the same disk that you installed Windows, whereas you really should have installed it on your other drive (sdb).

A second issue is that you used msdos for disk partitioning of sdb instead of GPT (GUID Partition Table). GPT is the modern way of formatting disks. On your Windows sda disk (1000GB) you used GPT, and you should have done the same for disk sdb. I would re-install Linux on sdb as follows:-

1) Boot to your Mint USB drive. Then open the terminal window and run command sudo gparted.

2) When gparted opens, on the top right side drop-down box and select /dev/sdb. Then at the top menu choose the tab - Device --> Create Partition Table --> click the drop-down arrow and select gpt. When you do this you are re-formatting the whole disk, and everything will be wiped. If there is any important data already on sdb, make sure you backed it up first before you proceed. Do the same for any data in your Mint partition, sda5.

3) Once sdb has been reformatted as GPT, you can delete partition sda5 and re-install Mint making sure that you install it on the /dev/sdb disk. Choose option Something else to install it. Follow the procedure here, but skip stages 7 & 8 as you already have an EFI partition on your first disk (see 4 below). Do not make a separate efi partition. Also no need for a swap partition either.

4) You must make a root / primary partition first (step 9), not less than 50 GB and format as ext4. It's advisable to make a separate Home primary partition too and format as ext4. This is where all your app configs will be stored, as well as all your personal files, and some people use it to store their data as well. You should now see 2 partition sdb1 and sdb2. Finally, you should also see a drop-down box where to install your boot/efi files. Make sure it's showing sda, even though you installed Mint on sdb.Then complete installation and reboot.
Computer: Dell Vostro 470
Systems: Linux Mint 21 Xfce (Vanessa), Manjaro 22.0 Xfce (Sikaris), Windows 10 (21H2) Pro.
andrs75
Level 1
Level 1
Posts: 9
Joined: Tue Mar 01, 2022 2:59 pm

Re: Error dual boot Linux Mint Cinnamon (Dell Notebook)

Post by andrs75 »

Dear Bendipa,

First of all I'm sorry for my late answer. Anyways, I followed your suggestions and Linux Mint Cinnamon was properly installed in sdb, thank you very much for your support. Nevertheless, after choosing Linux Mint as O.S. during booting, I still get the message "Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions". After typing grub>reboot, I can skip this message and log in normally to Linux Mint, but it is really annoying to do this every time. Once I'm in Linux Mint, it still appears "Low Disk space on efi" window. I was always happy with dual boot Windows/Linux Mint and did not have these problems before. But right now I'm quite disappointed. Do you have any ideas about how to solve this? Thanks in advance. Andres.
bendipa
Level 4
Level 4
Posts: 358
Joined: Sat Jan 04, 2020 8:02 pm
Location: NW London. UK

Re: Error dual boot Linux Mint Cinnamon (Dell Notebook)

Post by bendipa »

Hi, andrs75.

As you have a Dell computer, when you start to boot up, (as Dell logo appears) tap the F12 key several times. This should bring up he UEFI boot menu. What boot entries are shown there? If there is more than 1 Linux entry, (eg Ubuntu, linuxmint) try booting from each one to see if you can boot to your login page. Note which one (if any) boots you to the grub prompt.

You mention that you know how to boot to Mint 21 from the grub prompt. That's an encouraging start. If so it saves me the trouble of explaining that side of things as well as showing your system is sound, apart from the EFI issue. So you can boot up again either from the grub prompt or the first method above, which is preferable.

Please run lsblk -o name,partlabel,fstype,pttype,fsuse%,uuid,mountpoint | grep sd[a-b] and print the output, so I can see the up-to-date situation of your partitions now. When you've done that, we'll have a look at your 'low EFI space', and it should be a relatively simple task to fix grub properly from there.
Computer: Dell Vostro 470
Systems: Linux Mint 21 Xfce (Vanessa), Manjaro 22.0 Xfce (Sikaris), Windows 10 (21H2) Pro.
andrs75
Level 1
Level 1
Posts: 9
Joined: Tue Mar 01, 2022 2:59 pm

Re: Error dual boot Linux Mint Cinnamon (Dell Notebook)

Post by andrs75 »

Hi again,

After pressing F12, boot options are: ubuntu; Windows Boot Manager; UEFI Crucial...
Crucial is my SSD where Windows is installed.

After running run lsblk -o name,partlabel,fstype,pttype,fsuse%,uuid,mountpoint | grep sd[a-b], the following information appears:

sda gpt
├─sda1 EFI system partition vfat gpt 96% 86EF-EECB /boot/efi
├─sda2 Microsoft reserved partition gpt
├─sda3 Basic data partition ntfs gpt C8CA5E45CA5E3044
└─sda4 Basic data partition ntfs gpt 108282B682829FB8
sdb gpt
└─sdb1 ext4 gpt 22% 543dc50d-78a7-4a4e-879b-0c5b869238c0 /

Thank you very much for your support.

Kind regards.
bendipa
Level 4
Level 4
Posts: 358
Joined: Sat Jan 04, 2020 8:02 pm
Location: NW London. UK

Re: Error dual boot Linux Mint Cinnamon (Dell Notebook)

Post by bendipa »

OK. Your Linux/Windows partitions look fine. No issues there. We now need to look at your ESP (EFI System Partition).

This UEFI Crucial entry in your ESP (listed by F12 boot menu) looks like a potential issue. I would expect to see 'Windows boot manager' and 'ubuntu' as the UEFI entries for Windows and Mint respectively, but don't know what relevance that Crucial entry has, that it may be surplus to requirements and in conflict with the ubuntu entry.

* You didn't quite answer my question on the F12 boot-menu procedure - ie can you boot respectively to Windows and Mint by: F12 -->select 'Windows Boot Manager'. Then restart -->F12 -->select 'ubuntu'? What happens if you select the 'Crucial' entry as a boot?

Finally, can you supply output for the following (from a full Mint boot-up):
sudo du -hd1 /boot/efi/EFI
sudo cat /boot/efi/EFI/ubuntu/grub.cfg

* Note: if you can't boot from the F12 'ubuntu' selection, (you haven't confirmed yet that you can), then go back to the grub prompt and boot from there.
Computer: Dell Vostro 470
Systems: Linux Mint 21 Xfce (Vanessa), Manjaro 22.0 Xfce (Sikaris), Windows 10 (21H2) Pro.
andrs75
Level 1
Level 1
Posts: 9
Joined: Tue Mar 01, 2022 2:59 pm

Re: Error dual boot Linux Mint Cinnamon (Dell Notebook)

Post by andrs75 »

Hi again,

I have checked UEFI entries and after selecting ubuntu, then appears Grub menu entry; Windows boot manager, then windows as expected; but after selecting Crucial, nothing happens, so I'm about to delete that entry.
This is the output of the command lines you suggested me:

sudo du -hd1 /boot/efi/EFI
28M /boot/efi/EFI/Microsoft
1,9M /boot/efi/EFI/Boot
3,4M /boot/efi/EFI/ubuntu
61M /boot/efi/EFI/Dell
93M /boot/efi/EFI

sudo cat /boot/efi/EFI/ubuntu/grub.cfg
search.fs_uuid 543dc50d-78a7-4a4e-879b-0c5b869238c0 root hd1,gpt1
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg

Thank you.
bendipa
Level 4
Level 4
Posts: 358
Joined: Sat Jan 04, 2020 8:02 pm
Location: NW London. UK

Re: Error dual boot Linux Mint Cinnamon (Dell Notebook)

Post by bendipa »

OK. Your ESP grub.cfg file is completetely in order, and we now have proven this, as when you selected ubuntu from the UEFI boot menu (F12) it took you to the grub menu. So the question remains why aren't you being automatically directed there in the first place when you start/reboot?

Secondly, you clearly have a problem folder in your ESP - titled 'Dell'. It is that folder which is taking up unnecessary space, being 61MB in size, way bigger than Microsoft which is only 28MB in size, normal for a Windows boot loader. Likewise the 'ubuntu' (grub boot) folder is 3.4MB, which is normal size for loading the grub boot menu. As you boot up, i'm wondering if UEFI is being directed to this Dell folder. One obvious way this could happen is if UEFI had this as the first boot. It's likely that the Dell folder is the container for the Crucial entry in UEFI, which we now know boots to nothing. Anyway I suggest this folder be removed. So run the command sudo rm -R /boot/efi/EFI/Dell.

* When you've done that reboot into UEFI (F2 button), look for the 'boot' tab at he top, and open it. In the boot Window make sure that 'ubuntu' is shown as the first boot. If not, move to 'first boot option, hit Enter, and it should show the choice of 'ubuntu' or 'Windows'. Select 'ubuntu' then 'Save and Exit'. With a bit of luck you should boot straight into the grub menu. If not, come back, and we'll try an alternative method.

* Instead, you may find that to change the boot order there is a separate 'Hard Drive' config on the same page which needs to be entered to change the boot order.
Computer: Dell Vostro 470
Systems: Linux Mint 21 Xfce (Vanessa), Manjaro 22.0 Xfce (Sikaris), Windows 10 (21H2) Pro.
Post Reply

Return to “Installation & Boot”