LM13 SUPER SLOW on Dell Inspiron M5010

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
pcdf

LM13 SUPER SLOW on Dell Inspiron M5010

Post by pcdf »

Hi,

I've been using linux mint as my primary OS since mint 9 and I love it. I decided to install LM13 mate on my girlfriend's laptop, a Dell Inspiron M5010.

I have LM13 mate/cinnamon running perfectly on my dimension & XPS desktops and my XPS laptop. So it was a bit of a surprised when it took over 2h hours to install it on the Inspiron laptop. It did install in the end though, but it now takes around 20min to boot up and it's very sluggish all around. Opening firefox for example can easily take up to 1min. Moving the cursor with a mouse is jerky as well, but the track pad is more responsive.
I've installed the ATI additional driver but that hasn't improved anything so I decided to re-install everything again. I experienced exactly the same problems, i.e. it took forever to install, takes far too long to boot up and it's very sluggish all around.

That laptop runs Windows 7 (dual-boot) smoothly enough and should be able to run LM13 specs-wise. I've done all sorts of hard disc and memory checks and they came back good.
I'm lost. Any idea on what could be causing this laptop to be sooo slow? How can I make it work smoothly?

Inspiron specs:
AMD Athlon II Mobile Processors Dual-core P360 (2.3GHz, 1MB) - 64-bit
4 GB Dual Channel DDR3 SDRAM at 1333MHz
AMD Radeon HD 4250 graphic card
500 GB SATA Hard Drive

Looking forward to getting it working properly.

Best,

Pat.
oobetimer

Re: LM13 SUPER SLOW on Dell Inspiron M5010

Post by oobetimer »

What does a terminal command top tells?
pcdf

Re: LM13 SUPER SLOW on Dell Inspiron M5010

Post by pcdf »

Not much, the 2 CPUs are below 2% and the RAM is barely used.

I thought It might have been some sort of HD issue since even the install took forever.
I've removed compiz and kept everything to a minimum but it's still incredibly slow to boot up and run.

I've even tried setting SATA to ATA (instead of AHCI) in the bios but it didn't change anything.
http://ubuntuforums.org/showthread.php?t=1982570

BTW, it's 2Gb of RAM, not 4Gb.

Thanks for your help though.
pcdf

Re: LM13 SUPER SLOW on Dell Inspiron M5010

Post by pcdf »

I've actually removed LM13 and installed LM11 and it works almost perfectly.
It's superfast to boot and load up windows/programs. The only thing is that I had to set acpi=off in the grub for mint to boot up. That means the the laptop doesn't have a battery indicator and doesn't power off completely on shut down. Any work around for that? It's not ideal as the computer just dies out when the battery is depleted, without any warning.

In short, LM13 was super slow but gave me acpi and LM11 is super fast but no acpi.

PS: I've tried setting acpi=noirq too but same issue.
pcdf

Re: LM13 SUPER SLOW on Dell Inspiron M5010

Post by pcdf »

Well, it is working perfectly with LM11 now! :-)
I had to set both nomodeset and acpi=noirq in the grub file.

I'd still like to know why I couldn't get LM13 to work but I'm happy with LM11 for now, it's faster anyway.
Ronshere
Level 2
Level 2
Posts: 57
Joined: Tue Oct 25, 2011 9:37 pm

Re: LM13 SUPER SLOW on Dell Inspiron M5010

Post by Ronshere »

By any chance did you install the 32 bit instead of the 64 bit version of LM13?
Give LM13 Mate 64 bit a try. It works perfectly on every machine I have installed it to
so far.
The hangup could possibly be due to the 32 bit not using/seeing the 2nd core in your cpu
so it hangs and runs slow. You should NOT use 32 bit on that Dell regardless of the amount of ram
you have in it.
Also you may want to use a program to erase the harddrive first.
I use MHDD (do a google for it) to erase drives.
It zeroes them flawlessly. Then use MHDD to FDISK the drive which gives it a partition.
Then install Linux Mint to the drive. Burn MHDD to a CD and run it from there.
A lot of times a hang or slow boot is due to the older OS not being erased or overwritten properly.
barryp
Level 2
Level 2
Posts: 55
Joined: Wed Sep 24, 2008 5:14 am

Re: LM13 SUPER SLOW on Dell Inspiron M5010

Post by barryp »

Hi all,

I just installed Maya-Mate 64 bit on an identical machine (this one has 4g RAM) & have appalling boot times - 9-10 minutes.

I used Gparted to wipe the drive & create system & home partitions prior to installing Mint from a (unetbootin) USB stick. I tested the stick before installing.

CPU is not overloaded. Both cores are in use. Application launches are also very slow. I've installed the ati-amd driver to no avail.

My 7 year olf Toshiba, which just died ran Mate 13 very snappily. How can this be?

==
Later, interrupted during my first post.

Code: Select all

barry@Inspiron ~ $ inxi -F
System:    Host: Inspiron Kernel: 3.2.0-23-generic x86_64 (64 bit) Desktop: N/A Distro: Linux Mint 13 Maya
Machine:   System: Dell (portable) product: Inspiron M5010 version: A12
           Mobo: Dell model: 0WTVYR version: A12 Bios: Dell version: A12 date: 07/19/2011
CPU:       Dual core AMD Athlon II P360 (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 sse4a svm) 
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz
Graphics:  Card: Advanced Micro Devices [AMD] nee ATI RS880M [Mobility Radeon HD 4200 Series] 
           X.Org: 1.11.3 drivers: ati,fglrx (unloaded: vesa,fbdev,radeon) Resolution: 1366x768@60.0hz 
           GLX Renderer: ATI Mobility Radeon HD 4200 Series GLX Version: 3.3.11627 - CPC
Audio:     Card-1: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) driver: snd_hda_intel
           Card-2: Advanced Micro Devices [AMD] nee ATI RS880 HDMI Audio [Radeon HD 4200 Series] driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture ver: 1.0.24
Network:   Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver: r8169 
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 78:2b:cb:e9:29:f2
           Card-2: Broadcom BCM4313 802.11b/g/n Wireless LAN Controller driver: brcmsmac 
           IF: wlan0 state: down mac: ec:55:f9:4d:7b:57
Drives:    HDD Total Size: 500.1GB (1.6% used) 1: /dev/sda ST9500325AS 500.1GB 
Partition: ID: / size: 6.0G used: 4.3G (75%) fs: ext4 ID: /home size: 196G used: 3.2G (2%) fs: ext4 
           ID: swap-1 size: 4.19GB used: 0.00GB (0%) fs: swap 
Sensors:   System Temperatures: cpu: 66.4C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 144 Uptime: 19 min Memory: 497.9/3699.5MB Client: Shell inxi: 1.7.33 
Hmm it looks rather hot.


Cheers!
Barry
Post Reply

Return to “Installation & Boot”