<SOLVED> Failed to Start the X server

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
User avatar
phidias81
Level 1
Level 1
Posts: 43
Joined: Sun Feb 10, 2013 9:21 am

Re: Failed to Start the X server (your graphical interface)

Post by phidias81 »

oobetimer wrote:I got the same error and I resolved it this way:

1. When the message about viewing the X server output came, I pressed Ctrl Alt F2
2. Now on the new shell I ran command sudo Xorg -configure
3. Then I copied /home/oobe/xorg.conf.new to /etc/X11/xorg.conf
sudo cp /home/oobe/xorg.conf.new /etc/X11/xorg.conf
4. At last I started X using command startx
For new user as me, you should change oobe with you username here! /home/oobe/xorg.conf.new
Anyway, for me this solution didn't work. I started the x server, and mint booted, but I got a totally different and messed up interface with the bar on top, and I couldn't click anything.
At Nomad Travellers you find my travel stories, unusual places and amazing photos: visit my new website and travel from your chair! Make yourself comfortable and start your Nomad Travel! Davide
uncle
Level 1
Level 1
Posts: 11
Joined: Sat Nov 19, 2011 4:58 pm

Re: <SOLVED> Failed to Start the X server

Post by uncle »

This post should be a sticky in the Installation section. I just installed Mint 13 on 2 laptops, both of which suffered from this bug. Please consider. Thanks.

And very much thanks to the posters of the solutions!
lpdirect
Level 1
Level 1
Posts: 1
Joined: Sat Aug 03, 2013 9:32 pm

Re: <SOLVED> Failed to Start the X server

Post by lpdirect »

Thanks for this post. It helped me solve this problem when installing mint.
weinerwhiner
Level 1
Level 1
Posts: 1
Joined: Tue Aug 06, 2013 7:02 am

Re: <SOLVED> Failed to Start the X server

Post by weinerwhiner »

Thank you thank you thank you from an ubernoobi!
chuckd
Level 1
Level 1
Posts: 7
Joined: Wed Aug 07, 2013 11:45 pm

Re: <SOLVED> Failed to Start the X server

Post by chuckd »

Awesome!!!! Thanks oobertimer!!!

Wasn't able to boot mint at all without the liveUSB. Then no screen either on brand new Sony Vaio Pro 13".

This allowed me at least to get to a GUI to reinstall Mint 15.

Thanks again.
spbo
Level 1
Level 1
Posts: 1
Joined: Fri Jan 31, 2014 11:18 am

Re: <SOLVED> Failed to Start the X server

Post by spbo »

Hi guys! I have the same problem such as "Number of created screens does not match bla bla bla...Configuration failed but it allowed me to do a copy paste.
Then i press startx but i get a black screen with only this "-" and freeze. Any ideas? Sorry for my bad english.
kirgo4720z
Level 1
Level 1
Posts: 1
Joined: Tue Mar 11, 2014 3:42 pm

Re: <SOLVED> Failed to Start the X server

Post by kirgo4720z »

1. When the message about viewing the X server output came, I pressed Ctrl Alt F2
2. Now on the new shell I ran command sudo Xorg -configure
3. Then I copied /home/oobe/xorg.conf.new to /etc/X11/xorg.conf
sudo cp /home/oobe/xorg.conf.new /etc/X11/xorg.conf
4. At last I started X using command startx

That was helpful to me
User avatar
kukamuumuka
Level 16
Level 16
Posts: 6699
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: <SOLVED> Failed to Start the X server

Post by kukamuumuka »

kirgo4720z wrote:1. When the message about viewing the X server output came, I pressed Ctrl Alt F2
2. Now on the new shell I ran command sudo Xorg -configure
3. Then I copied /home/oobe/xorg.conf.new to /etc/X11/xorg.conf
sudo cp /home/oobe/xorg.conf.new /etc/X11/xorg.conf
4. At last I started X using command startx

That was helpful to me
Just a comment: Replace oobe using your own username.

Code: Select all

sudo cp /home/your_username/xorg.conf.new /etc/X11/xorg.conf
bushy
Level 3
Level 3
Posts: 110
Joined: Sat Oct 15, 2011 6:29 pm

Re: <SOLVED> Failed to Start the X server

Post by bushy »

I have this problem, I've tried to solution in this thread w/o success. I have Mint 13 on a DELL laptop. It has worked well for over a year and just failed today. I was able to read an error that says there is an API mismatch NVIDIA kernal module version 173..14.49 Invidia driver component is 304.116.
ALF13
Level 3
Level 3
Posts: 152
Joined: Mon Feb 20, 2012 3:02 pm
Location: Bulgaria
Contact:

Re: Failed to Start the X server (your graphical interface)

Post by ALF13 »

oobetimer wrote:I got the same error and I resolved it this way:

1. When the message about viewing the X server output came, I pressed Ctrl Alt F2
2. Now on the new shell I ran command sudo Xorg -configure
3. Then I copied /home/oobe/xorg.conf.new to /etc/X11/xorg.conf
sudo cp /home/oobe/xorg.conf.new /etc/X11/xorg.conf
4. At last I started X using command startx
Great comment! Thanks

But, for those who receive this error after trying to boot from live flash or cd type this:

1. When the message about viewing the X server output came, I pressed Ctrl Alt F2
2. Now on the new shell I ran command sudo Xorg -configure
3. Then I copied /home/mint/xorg.conf.new to /etc/X11/xorg.conf
sudo cp /home/mint/xorg.conf.new /etc/X11/xorg.conf
4. At last I started X using command startx
Gregschollo
Level 1
Level 1
Posts: 1
Joined: Sun Mar 13, 2016 7:31 pm

Re: <SOLVED> Failed to Start the X server

Post by Gregschollo »

The original method did not work for me. Instead I used the commands "apt-get update" "apt-get install Xorg" then I used "reboot" and my system boot right up! I hope this helps this that the above methods do not help!
guipeev
Level 1
Level 1
Posts: 1
Joined: Fri Mar 11, 2016 8:16 pm

Re: <SOLVED> Failed to Start the X server

Post by guipeev »

kirgo4720z wrote:1. When the message about viewing the X server output came, I pressed Ctrl Alt F2
2. Now on the new shell I ran command sudo Xorg -configure
3. Then I copied /home/oobe/xorg.conf.new to /etc/X11/xorg.conf
sudo cp /home/oobe/xorg.conf.new /etc/X11/xorg.conf
4. At last I started X using command startx

That was helpful to me
I also wanted to thank you. It also worked for me after I messed up my graphic card's drivers.
Locked

Return to “Installation & Boot”