<SOLVED> Upgrade to maya still showing as lisa ...

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 21
Joined: Fri Jan 13, 2012 7:58 pm

<SOLVED> Upgrade to maya still showing as lisa ...

Post by rcrath » Wed Jun 27, 2012 5:27 am

I upgraded to Maya from Lisa via the apt method. http://community.linuxmint.com/tutorial/view/62 Everything went smoothly except somewhere in the system, it is still saying that it is Lisa and Oneiric in some places. Synaptic shows pretty much the right versions...everything I have seen is precise, or became so with a little nudging. But when I invoke the system monitor, it says thet it is v. 12 Lisa. The other place it turns up is in PPAs. I removed all the PPAs and removed all the gpg keys for them as well, leaving just the basic sources.list (appended below), but as I repopulated the PPAs I need, they show up in /etc/apt/sources.list.d with oneiric in the filenames and in the contents.

I ran:

Code: Select all

sed -i 's/oneiric/precise/g' /etc/apt/sources.list
find /etc/apt/sources.list.d -type f -exec sed -i 's/oneiric/precise/g' {} \;
sed -i 's/lisa/maya/g' /etc/apt/sources.list
find /etc/apt/sources.list.d -type f -exec sed -i 's/lisa/maya/g' {} \;
and the right releases seem to have stuck inside the list files, but when I install a new PPA, it comes in filenamed oneiric and I have to change the contents to precise. I thought it was the gpg keys, which is why I deleted them all and all the ppa sources and started over.

I have sorted out all the dependency problems as far as I can tell, and no packages are held back. As far as I know, all the packages are precise, and everything but adding PPAs and the name in the system monitor seems to be alright.
Happy to supply more info. One suggestion to rule out is a clean install at this point, for various good reasons. It is pretty much working except for this one problem and it would take me a couple of days to get my software back in order if my previous clean installs serve as a guide.

The only bad effect that I have seen so far is that some dependencies might get borked by seeing oneiric instead of precise. I had this happen with cairo dock plugins, which were not visible to cairo dock because it was showing the oneiric ppa while they were precise, even though the version numbers otherwise matched exactly. So far that was the only one like that, but I guess other problems like it might be lurking which is why I'd like to sort it out and get the numbers and sources to show the right version.


Code: Select all

deb http://packages.linuxmint.com/ maya main upstream import
deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ precise partner
deb http://packages.medibuntu.org/ precise free non-free

# deb http://archive.getdeb.net/ubuntu precise-getdeb apps
# deb http://archive.getdeb.net/ubuntu precise-getdeb games

deb http://packages.linuxmint.com/ maya main upstream
Last edited by rcrath on Sat Jun 30, 2012 3:48 am, edited 1 time in total.

Level 1
Level 1
Posts: 1
Joined: Wed Jun 27, 2012 10:10 am

Re: Upgrade to maya still showing as lisa in system settings

Post by royboy626 » Fri Jun 29, 2012 9:42 am

Mini command line tutorial for those finding this on the web. Hope this helps.

Operating system information is coming from /etc/linuxmint/info. In a terminal window as user "root"
#cat /etc/linuxmint/info
#dpkg -l | grep mint-info (Lower case "L" is switch)
For me, this returned "mint-info-gnome". This does not exist in 13. On 120629 the apt-file command below
returned four possibilities... cinnamon, kde, mate, xfce
#apt-get install apt-file
#apt-file search /etc/linuxmint/info (it may ask you to run a command to create the search database. Do so, then reexecute command)

Assuming you indeed have mint-info-gnome installed and wish to use mate...
#apt-get remove mint-info-gnome
#apt-get update
#apt-get install mint-info-mate (or kde, cinnamon, xfce)
If you get questions regarding installing a new configuration file, accepting the maintainer's version over installed is best for most users.
#apt-get upgrade

/etc/lsb-release seems to get created automagically (after a reboot?). Files such as /etc/issue and /etc/issue.net may need manual editing.
Might also want to run "apt-get check"
Then if using mate you can check out installing "mate-desktop" and other "mate" packages from one of the software manager GUIs (synaptic etc...)

Level 16
Level 16
Posts: 6713
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Upgrade to maya still showing as lisa in system settings

Post by AlbertP » Fri Jun 29, 2012 10:05 am

Mint 13 does not have the Gnome 3 desktop but Mate or Cinnamon. You should install either mint-meta-mate or mint-meta-cinnamon and remove the mint-meta-gnome and mint-info-gnome packages.
Registered Linux User #528502
Feel free to correct me if I'm trying to write in Spanish, French or German.

Level 1
Level 1
Posts: 21
Joined: Fri Jan 13, 2012 7:58 pm

<SOLVED> Re: Upgrade to maya still showing as lisa...

Post by rcrath » Sat Jun 30, 2012 3:47 am

Thank You Royboy and AlbertP. Your instructions got me most of the way there. I had to do a few extra things regarding dependencies and reinstalls (see below) to get things working right, but it seems to be good now. Here is what I needed to do in addition in case anyone else gets into this particular jam.

I was running Cairo dock and compiz (loves my wobbly windows, hates Unity ;)), with no gnome shell, cinnamon, or Mate. I also keep fluxbox around for certain tasks where I need all the resources for the task. This was handy, because once I removed gnome shell, I had only cairo-dock session or fluxbox to log in to. Dependency problems prevented installing Cinnamon, so it was off to dependency hell. I don't know if Mate would have installed, but cinnamon would not, and I bet if I had tried to reinstall Gnome it would have borked too. So if you are in this situation, you might want to install fluxbox or some other low-resources window manager as a backup plan unlesss you are ok with no WM.

I ran RoyBoy's steps but held packages (linux-image-3.2.0-26-generic, linux-image-generic, and linux-generic) caused problems, although gnome-meta got removed ok. Tried to install cinnamon, but said it needed xchat, and xchat would not install because the apt sources were still pointing to the ubuntu version rather than the mint version, and the mint version would not upgrade because of the held packages.

Code: Select all

  Depends: xchat-common (=2.8.8-4linuxmint1) but 2.8.8-3ubuntu8-1linuxmint1 is to be installed
I hand edited lsb-release, issue, issue.net changing "12" to "13" and "Lisa" to "Maya"
and ran upgrade after a reboot, but the three held packages held things up. The dpkg messages indicated a dependency problem with grub2. reinstalled all grub and grub2 files via synaptic (careful not to reboot here until done!), then reinstalled the three kernel packages no problem. Install -f and update ran with nothing to fix or change. reboot just to make sure.

install cinnamon:
cinnamon meta wouldn't install for the same reason as above, but now the mint package was there for the upgrading, which it was not before. (wonder why upgrade did not catch this?)
Updated xchat common (wonder why upgrade did not get this?), then xchat and cinnamon meta installed. As far as I know, everything is fine now. Thank you both for the directions. Marking solved.

Post Reply

Return to “Installation & Boot”