Grub failed to install fatal error

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
slenkar
Level 1
Level 1
Posts: 4
Joined: Fri Aug 17, 2012 5:59 pm

Grub failed to install fatal error

Postby slenkar » Fri Aug 17, 2012 6:02 pm

I have a 12gig partition called sda6 which I installed linux mint to from a CD
I installed it on the mount point / (ext2 file system)
I also have a 1gig swap space which it recognized

after a lengthy install process it said failed to install grub and now wont show up on the grub menu on boot

I told linux mint to install grub to dev/sda which I think is the MBR where my grub is currently installed to.

User avatar
karlchen
Level 16
Level 16
Posts: 6826
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Grub failed to install fatal error

Postby karlchen » Fri Aug 17, 2012 6:20 pm

Hello, slenkar.

I should be /dev/sda, note the initial slash, not dev/sda. The missing slash may make the difference between failed and successful installation of Grub.
You installed Mint to /dev/sda6. Which OSes can be found on /dev/sda1 to /dev/sda5?
If there is another Linux flavour on the disk, launching that Linux and running

Code: Select all

sudo update-grub
may make your latest Mint installation appear mysteriously in the boot menu.

Kind regards,
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

slenkar
Level 1
Level 1
Posts: 4
Joined: Fri Aug 17, 2012 5:59 pm

Re: Grub failed to install fatal error

Postby slenkar » Fri Aug 17, 2012 6:28 pm

sda1 is windows recovery
sda2 is windowsxp
sda3 contains the other partitions:
sda4 boot? (left over from an install of arch linux) very small
sda5?
sda6 12 gig partition (which used to contain linux but I wiped and replaced it with Mint)
sda7 swap

the /sda/dev place was generated by mint so thats not the problem


I dont have any other linuxes installed so thats a no go, although I do have access to sda6 in windows

User avatar
karlchen
Level 16
Level 16
Posts: 6826
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Grub failed to install fatal error

Postby karlchen » Fri Aug 17, 2012 6:39 pm

Though the trouble does not seem to have been caused by Windows, this instruction seems to offer the right approach nonetheless: RecoveringUbuntuAfterInstallingWindows
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

slenkar
Level 1
Level 1
Posts: 4
Joined: Fri Aug 17, 2012 5:59 pm

Re: Grub failed to install fatal error

Postby slenkar » Fri Aug 17, 2012 7:46 pm

ok I ran it from terminal and it said
grub-probe: error: cannot find a device for /boot (is /dev mounted?).
Probing devices to guess BIOS drives. This may take a long time.
Could not find device for /boot: Not found or not a block device.

slenkar
Level 1
Level 1
Posts: 4
Joined: Fri Aug 17, 2012 5:59 pm

Re: Grub failed to install fatal error

Postby slenkar » Fri Aug 17, 2012 8:12 pm


User avatar
karlchen
Level 16
Level 16
Posts: 6826
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Grub failed to install fatal error

Postby karlchen » Sat Aug 18, 2012 6:33 am

Hello, slenkar.

Great to learn you have solved your problem. - And yes, there are quite a few instructions out there and not every instruction will cover any specific situation. Thanks for pointing us to the one that helped you.

Have a nice weekend,
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.


Return to “Installation & Boot”

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot] and 10 guests