Mint 14: 'grub-efi' package failed to install

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 13
Joined: Thu Nov 22, 2012 7:28 am

Re: Mint 14: 'grub-efi' package failed to install

Postby louisgv » Thu Nov 29, 2012 7:39 pm


Success booting rEFInd!!!

Thanks you so much! And it appear that rEFInd also show LinuxMint :D

It seem after moving all rEFInd directory in and out without rEFInd on, I tried to clean the sda1 and sda3 up, then replace and rename refind_x64.efi to Microsoft/boot/bootmgfw.efi

After that, I boot my computer and see rEFInd on. It seem Sony have done something so that their system find only the bootloader residence inside /boot/Microsoft :-?..

rEFind successfully boot Linuxmint, but I would like to ask you to guide me tidy things up a bit. It seems rEFInd boot the grub, then grub boot linuxmint :-?

Best Regard!


Level 6
Level 6
Posts: 1389
Joined: Mon Feb 27, 2012 1:42 pm

Re: Mint 14: 'grub-efi' package failed to install

Postby srs5694 » Thu Nov 29, 2012 11:55 pm

I'm glad you've finally gotten it working. You can clean up the boot menu by starting rEFInd and identifying the boot files that belong to each of the icons in the menu. (Selecting an icon should produce a description below it of what file it is and on what disk, by volume name. There are a few exceptions to this rule, but mostly this works.) If you locate two boot loaders that do the same thing, you can use that information to delete one of them. I recommend you back up the contents of both /dev/sda1 and /dev/sda3 before you delete anything, though; that way if you make a mistake you can easily restore it. (A file-level backup is fine; EFI doesn't use code in a partition's boot sector.)

From there, you can either keep using it the way it is (using rEFInd to boot GRUB, which then boots a Linux kernel) or start up again with the procedure I outlined in this post. You'd start with step #5 (or #7, if you've already done #5). The end result of that juggling should be the ability to boot Linux without GRUB's involvement.

Level 16
Level 16
Posts: 6507
Joined: Tue Jul 07, 2009 2:29 pm

Re: Mint 14: 'grub-efi' package failed to install

Postby zerozero » Fri Nov 30, 2012 1:07 pm

zerozero wrote:to everyone in this topic: there's one issue with the 64bit isos (see this comment in the blog
Srikanth K Says:
November 23rd, 2012 at 12:21 am


There is no UEFI installation support in Linux Mint 14.

Edit by Clem: UPDATE, we found the issue, it’s specific to Ubiquity in Mint 14 (i.e. it doesn’t affect Ubuntu). We’ll respin the 64-ISOs and make an announcement. For a rough ETA, this should take approximately a week.

the new nadia respins were just released addressing not only this (but also) issue. see the blog post for more info >>

[ bliss of ignorance ]

Level 1
Level 1
Posts: 4
Joined: Wed Nov 28, 2012 2:16 am

Re: Mint 14: 'grub-efi' package failed to install

Postby tuxter » Fri Nov 30, 2012 10:33 pm

I'm not sure if you guys found a simple solution, but I had a similar problem, but on my Mac. To fix it, I just update grub, grub2, and grub-efi before installing and it worked fine. Everything I had tried before that didn't work. The grub-efi package is broken and missing dependencies if I'm remembering right. But you have to upgrade the packages individually or it gives you an error for some reason.

Return to “Installation & Boot”