Mint 14 :GRUB operating system not found.

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
nistalks
Level 1
Level 1
Posts: 4
Joined: Sun Dec 30, 2012 12:02 pm

Mint 14 :GRUB operating system not found.

Post by nistalks » Sun Dec 30, 2012 12:10 pm

I didn't find the solution of this on the net, so posting here.
I am a newbie to Linux, and recently installed Linux Mint 14 64-bit Cinnamon alongside Windows 7. But after the setup completed, and Restarted, I got black screen; 2-3 mins later, it showed Operating System Not Found. After pressing Alt+Ctrl+Del, it took a restart and I landed on grub, showing the os select. That session worked fine and I was able to login to Nadia. But again after restart same problem occurred. Now the case is, my laptop (Dell Inspiron 14R 7420) does not start normally and shows the Operating System not found screen but after a few(2-3 to 7-8) restarts, it works. Please Help.

User avatar
Fornhamfred
Level 6
Level 6
Posts: 1241
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Mint 14 :GRUB operating system not found.

Post by Fornhamfred » Sun Dec 30, 2012 2:05 pm

Hi
This sounds like a grub problem. When you installed Mint did you install grub in the mbr?

Could you post the output of:
cat /boot/grub/grub.cfg

nistalks
Level 1
Level 1
Posts: 4
Joined: Sun Dec 30, 2012 12:02 pm

Re: Mint 14 :GRUB operating system not found.

Post by nistalks » Sun Dec 30, 2012 9:50 pm

This is the output:

Code: Select all

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="0"

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_msdos
insmod ext2
set root='hd0,msdos6'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos6 --hint-efi=hd0,msdos6 --hint-baremetal=ahci0,msdos6  cd5dcca3-85db-4d18-9cbb-a8c1b82ad236
else
  search --no-floppy --fs-uuid --set=root cd5dcca3-85db-4d18-9cbb-a8c1b82ad236
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_IN
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/06_mint_theme ###
set menu_color_normal=white/black
set menu_color_highlight=white/light-gray
### END /etc/grub.d/06_mint_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
	set gfxpayload="$1"
	if [ "$1" = "keep" ]; then
		set vt_handoff=vt.handoff=7
	else
		set vt_handoff=
	fi
}
if [ ${recordfail} != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
menuentry 'Linux Mint 14 Cinnamon 64-bit, 3.5.0-17-generic (/dev/sda7)' --class linuxmint --class gnu-linux --class gnu --class os {
	recordfail
	gfxmode $linux_gfx_mode
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos7'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos7 --hint-efi=hd0,msdos7 --hint-baremetal=ahci0,msdos7  130b755b-bd92-45a1-8bc9-39830e5edd5d
	else
	  search --no-floppy --fs-uuid --set=root 130b755b-bd92-45a1-8bc9-39830e5edd5d
	fi
	linux	/vmlinuz-3.5.0-17-generic root=UUID=cd5dcca3-85db-4d18-9cbb-a8c1b82ad236 ro   quiet splash $vt_handoff
	initrd	/initrd.img-3.5.0-17-generic
}
menuentry 'Linux Mint 14 Cinnamon 64-bit, 3.5.0-17-generic (/dev/sda7) -- recovery mode' --class linuxmint --class gnu-linux --class gnu --class os {
	recordfail
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos7'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos7 --hint-efi=hd0,msdos7 --hint-baremetal=ahci0,msdos7  130b755b-bd92-45a1-8bc9-39830e5edd5d
	else
	  search --no-floppy --fs-uuid --set=root 130b755b-bd92-45a1-8bc9-39830e5edd5d
	fi
	echo	'Loading Linux 3.5.0-17-generic ...'
	linux	/vmlinuz-3.5.0-17-generic root=UUID=cd5dcca3-85db-4d18-9cbb-a8c1b82ad236 ro recovery nomodeset 
	echo	'Loading initial ramdisk ...'
	initrd	/initrd.img-3.5.0-17-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/10_lupin ###
### END /etc/grub.d/10_lupin ###

### BEGIN /etc/grub.d/20_linux_xen ###

### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos7'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos7 --hint-efi=hd0,msdos7 --hint-baremetal=ahci0,msdos7  130b755b-bd92-45a1-8bc9-39830e5edd5d
	else
	  search --no-floppy --fs-uuid --set=root 130b755b-bd92-45a1-8bc9-39830e5edd5d
	fi
	linux16	/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos7'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos7 --hint-efi=hd0,msdos7 --hint-baremetal=ahci0,msdos7  130b755b-bd92-45a1-8bc9-39830e5edd5d
	else
	  search --no-floppy --fs-uuid --set=root 130b755b-bd92-45a1-8bc9-39830e5edd5d
	fi
	linux16	/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows 7 (loader) (on /dev/sda2)' --class windows --class os $menuentry_id_option 'osprober-chain-30E431B6E4317F62' {
	insmod part_msdos
	insmod ntfs
	set root='hd0,msdos2'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  30E431B6E4317F62
	else
	  search --no-floppy --fs-uuid --set=root 30E431B6E4317F62
	fi
	chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

User avatar
Fornhamfred
Level 6
Level 6
Posts: 1241
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Mint 14 :GRUB operating system not found.

Post by Fornhamfred » Mon Dec 31, 2012 1:13 pm

Looking at the output it looks as though the system is confused. I assume that you would like to use the Mint grub which would then be installed to MBR (SDA1) and your windows 7 is on SDA2. What partitions did you setup when you installed Mint?

Good practice is to have a root partition (/) a swap partition and a home partition.The root partition could be 20gb and the swap double the size of your physical ram. The size of the home partition depends on what you are going to keep on it but minimum should probably be 20gb. I keep a separate Data partition which is formatted NTFS so that I can access files easily from both Mint and windows.

During installation of Mint it asks where to install grub and I would install to MBR although this is not everyones choice. After installation you can install Startup Manager to select which operating system to boot by default.

Please give the partition info , whether you have more that 1 hard drive and where you installed grub to.

nistalks
Level 1
Level 1
Posts: 4
Joined: Sun Dec 30, 2012 12:02 pm

Re: Mint 14 :GRUB operating system not found.

Post by nistalks » Tue Jan 01, 2013 1:35 pm

I did not know these, What I've done is a 100 GB ext3 root, 3 GB swap(I have 8 GB ram), and 4 GB ext3 drive for /boot(I guess grub is installed there.). What should I do?

User avatar
oobetimer
Level 7
Level 7
Posts: 1879
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle
Contact:

Re: Mint 14 :GRUB operating system not found.

Post by oobetimer » Tue Jan 01, 2013 1:44 pm

I thing that this is a grub2 related problem, because I had almost the same problem with this computer. My solution was to use Lecacy grub, which works fine.

You could run commands sudo os-prober and sudo update-grub. The first command seeks the operating systems and the second updates the bootloader config file (/boot/grub/grub.cfg).

mintybits
Level 6
Level 6
Posts: 1123
Joined: Fri Jan 27, 2012 5:09 pm

Re: Mint 14 :GRUB operating system not found.

Post by mintybits » Tue Jan 01, 2013 5:28 pm

nistalks wrote:I did not know these, What I've done is a 100 GB ext3 root, 3 GB swap(I have 8 GB ram), and 4 GB ext3 drive for /boot(I guess grub is installed there.). What should I do?
You have a separate boot partition on a separate drive from root? Why?

Reinstall without a separate boot partition. To avoid overwriting the MBR on your hard disk you can still install Grub on your 4GB drive; specify this during Mint install.

nistalks
Level 1
Level 1
Posts: 4
Joined: Sun Dec 30, 2012 12:02 pm

Re: Mint 14 :GRUB operating system not found.

Post by nistalks » Wed Jan 02, 2013 12:31 pm

I have tried sudo update-grub many times, nothing changes. The situation was worse when there wasn't a boot drive. With a boot drive, I find grub works 'better'(it appears with less number of restarts). I wasn't asked about location to install grub, does such an option exist in my version?

Post Reply

Return to “Installation & Boot”