errno 5 [input/output error on install]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 3
Joined: Tue Jan 01, 2013 6:33 pm

errno 5 [input/output error on install]

Postby Stu_the_scot » Tue Jan 01, 2013 8:01 pm

Hey everyone.
I am a complete newbie to Linux and forums and am having real trouble installing mint 14.1 cinnamon to my computer. This is my first non-windows install and although the live boot works and the o/s seems to be exactly what I am looking for, I cannot get it to install to the Hard drive. I am sure I am missing something obvious.

I have raked a good few forums including this one looking for solutions and as a result I have tried both the 16 and 32 bit versions (slow burn speed) having validated the checksum on both downloads, I have replaced the motherboard battery, tested on two different hard drives, tried installation with a memory module removed, and I have also replaced the DVD drive to see if this is the problem. I have also tested the hard disks and tried a few different partition options using ultimate boot disk. I have yet to established whether processor is PAE enabled (as far as I can see it is). I am unable to boot from usb stick as there is no option in my bios. Despite all these recommendations in each instance(when the installer doesn't crash) I get to the copying files part of the installation and get the following error: [errno 5] Input/output (see image attached)
Screenshot from 2013-01-01 23_37_36.png
screen dump of installation crash
Screenshot from 2013-01-01 23_37_36.png (250.87 KiB) Viewed 4502 times

I also get a greeter application crash on booting via DVD occasionally – don’t know if this is relevant. Usually requires reboot as it then asks for login details I don’t have!

System is a bit of a hotchpotch but was running windows seven until about a week ago when I started this saga.
Spec is as follows:
ECS Livermore board with Intel Pentium D 3ghz dual core processor running bios 5.11 (American megatrends/HP)
1gb memory
40gb sata Hard drive (western digital)
80gb IDE hard drive (western digital)

Thanks in advance for your help/suggestions.

Level 1
Level 1
Posts: 3
Joined: Tue Jan 01, 2013 6:33 pm

Re: errno 5 [input/output error on install]

Postby Stu_the_scot » Fri Jan 04, 2013 7:38 pm

I have been playing around with the dvd live file system trying to solve this problem and have noticed that i dont actually have permission to copy anything to the hard drives when mounted. Anyone know if this could be part of the problem? any way i can change the permissions and try to reinstall after? Thanks

User avatar
Level 1
Level 1
Posts: 44
Joined: Sun Aug 08, 2010 6:49 pm
Location: Seaside, CA

Re: errno 5 [input/output error on install]

Postby fbachofner » Wed Jan 16, 2013 4:20 am

Hi Stu_the_scot:

Welcome to Mint. You are going to love it!

Sorry no one answered your question earlier. Your system spec seems more than adequate. Try apic=off in the startup options when first booting from the live DVD.

I have been running into this problem quite a bit over the past week as I am reconditioning some older machines with Mint . . . previously I tried different DVDs, USB drives, etc. thinking the given error was realistic.

The apic option is discussed quite well here: viewtopic.php?f=46&t=36764

Good luck!

various Intel NUC machines and an HP Pavilion DM1Z
each LinuxMint 18 with Cinnamon
i7 self-built server --> Ubuntu 16.04 (with Cinnamon, for the rare local login)

Level 1
Level 1
Posts: 3
Joined: Tue Jan 01, 2013 6:33 pm

Re: errno 5 [input/output error on install]

Postby Stu_the_scot » Wed Jan 16, 2013 4:05 pm

Hi Felix,
Thanks for taking the time to reply. Have tried the apic=off and unfortunately no success - installer just crashes after starting. Thanks though. Have reinstalled Win xp onto the system (windows 7 was not my copy) and now also having problems with that. Begining to seriously doubt the hardware. have been unable to install evernote, openoffice and thunderbird (all downloads) and cannot even install ms office from original cd. However i succesfully installed dropbox, firefox and chrome. Really confused.

Booted mint and mounted sata hard disk with xp installation to see if i could run a benchmark on it with write testing as even updating firefox on xp is not happening now and got the following error:

'Error opening /dev/sda: Device or resource busy (udisks-error-quark, 0)'

can write individual libreoffice files to same drive just wont take installation of some programs.

reattempted mint installation for dual boot instead of for entire drive (created partition on IDE drive) and still get to copying files part of installation before i get Errno5 again. I dont get it.

Thanks again,


Level 1
Level 1
Posts: 1
Joined: Fri Jun 14, 2013 12:00 am

Re: errno 5 [input/output error on install]

Postby linyuansen » Fri Jun 14, 2013 12:03 am

I have the same problem, found this is the "make usb tools" problem.

try Universal-USB-Installer- and unetbootin-windows-584 but fail,

and lucky use the "laomaotao" to install mint 14 kde sucessfully.

![enter image description here][1]

![enter image description here][2]


good luck! :):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):)

Return to “Installation & Boot”

Who is online

Users browsing this forum: Clangeddin and 6 guests