Solve boot problems with AMD and NVIDIA graphics cards

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Mon Mar 28, 2016 10:36 pm

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by kahukowhai »

I have a Nvidia GTX750i card (Gigabyte NV75) and had to use the compatibility mode to get the 17.3 installer to run. Without this mode all it would do is draw some pretty pictures on the screen and then say it was logging in within a few seconds, then after logging in it would just draw the next picture and repeat the cycle. If you left it running like this after a while there would be a popup saying it had crashed 6 times in the last 90 seconds or whatever.

So then try pressing the left shift key during boot like the first post says - doesn't work!
So then try a combination of these instructions ... m-a-livecd
Using the first answer to mount up the boot volume under a livecd.
Then once all the mount commands have been followed then switch to using the mount directory as the root partition
Then open the grub settings file /etc/default/grub and find the line that reads GRUB_CMDLINE_LINUX_DEFAULT and add "nomodeset xforcevesa" to the end of it. Save the file
Then run update-grub to update the settings

The first time I did the install (practice!) I let it reboot and crash before I got into changing the boot menu. After I did a reinstallation to fix some other issues with the first install then I just did all the editing after installation was completed, before rebooting the system.

Level 1
Level 1
Posts: 2
Joined: Sat Apr 02, 2016 12:49 pm

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by gahhh »

Note!!! Boot will fail right after selecting either option if your USB stick happens to be formatted NTFS.

Level 1
Level 1
Posts: 18
Joined: Sun Mar 27, 2016 6:43 pm

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by dmmackay »

it does appear that I had to use the LIVE DVD and Run it in Compatability mode..
Now re-installing on HD> Hopefully it will boot up
Thanks Laurent85

Level 1
Level 1
Posts: 1
Joined: Thu Apr 21, 2016 4:33 pm

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by haahu »

Possible workaround. I struggled with "Attempting to boot from hard disk" problem with Linux Mate 17.3 Rosa (Quadro FX 560 and HP xv4400). I didn't succeed with earlier instructions. Before giving up I decided to check Cinnamon version. For some reason I didn't face any problems with that version.

User avatar
Level 1
Level 1
Posts: 45
Joined: Sat Dec 10, 2011 3:39 pm

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by golf4fun »

On the live DVD of Mint 17.3 KDE I had a similar nvidia problem and fixed it by selecting drivers from the pop up welcome screen and installing the recommended older nvidia driver. Wasn't easy to do because the screen was messed up a bit but I persevered during the live DVD to get it installed and once again after the system booted. All is well now.

Don't know if the welcome menu appears on all Mint versions but it does show up on KDE.
Mint KDE 64 bit.


Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by ladyonthemoon »

xenopeek wrote:If you have an AMD or NVIDIA graphics card, you may not be able to boot successfully from the Linux Mint installation DVD or USB stick. Or you may have been able to boot successfully and install Linux Mint, but it won't boot successfully after installation.
[*]Press the 'e' key to edit the boot parameters. Using the cursor keys of your keyboard scroll down to the line that starts with "linux" (red box in the screenshot) and go to the end of that line (red arrow in the screenshot).
[*]Add the boot parameters "nomodeset xforcevesa" ... Press Ctrl+X or F10 to continue to boot.
This worked for me, thanks!

User avatar
Level 21
Level 21
Posts: 12702
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by karlchen »

<moderator on>
Guess it is time to turn the last few posts into a new "help request" thread. :wink:
New thread here by ladyonthemoon:
LM18 AMD graphics cards - xforcevesa needed?
Feel free to change the thread title if you like, ladyonthemoon.
<moderator off>
Linux Mint 19.2 64-bit Cinnamon, Total Commander 9.22a 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

Level 2
Level 2
Posts: 77
Joined: Sat Nov 12, 2016 11:33 pm

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by jpenguin »

When I got by card it was to new for nouveau to handle, untill I got the binary driver installed- I had to boot with modeprobe.blacklist=nouveau

Level 1
Level 1
Posts: 35
Joined: Wed Feb 15, 2017 6:57 am

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by BeHarley »

stelil wrote:Just in case this helps someone from spending the hours I did looking around.. I have the issue where the Mint 14 live CD worked, install went OK but then on booting to HDD there was no grub menu and just a black screen and blinking cursor. Convinced it would be a graphics card thing I played around with editing grub with replacement to "no splash" but no joy.

Then I found an old post about mint 11 (I am trying to install mint 14) and xenopeek suggested boot-repair.

Original Post was

And the solution that worked for me and got me into Mint 14 was to boot to a live CD, the run

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair
sudo boot-repair

I just accepted the defaults when running the utility, it seemed to know exactly where my HDD was and fixed the grub on that /dev/sda.

I'm so happy

Thanks man. It helped. I was having this issue, but now I am gonna try this.

Level 1
Level 1
Posts: 47
Joined: Thu Aug 14, 2014 1:39 am
Location: Queensland, Australia

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by Spinner912 »

I have suffered most of these problems over the last few months. Linux and the Computer are lucky to have survived a pending trip to the dump!

But today I stumbled across a bit of information suggesting that half of my problem is caused by the monitor, a Samsung S22A300B, not sending any EDID data to the Graphics Card at boot.

It was revealed that Samsung has issued a Firmware update which will fix the problem. But it only runs in Windows and with two monitors connected to the graphics card. I will show the URL as it does not relate to Linux as such.

Since installing this firmware update all the Failed to load X server problems have gone. The only remaining problem is that there is no nvidia-settings available nor can the Displays function find the monitor, and the monitor is running at a default resolution well below the 1920x1080 of which it is capable.

The monitor is sending the required information now as it is clearly available on Windows 10, the optional boot disk.

I am running a MSI GeForce 730 Graphics Card with the GeForce Nvidia 375.66 drivers installed from Synaptic. All on Mint 17.3 Rosa MATE, updated.

How can I get firstly, the nVidia Settings function, then the Display recognising the actual monitor and presenting the available resolution modes, and lastly, the ability to select the optimum resolution, 1920x1080, which I need, and which was the reason for purchasing this monitor in the first place.

Level 1
Level 1
Posts: 1
Joined: Fri May 12, 2017 10:32 am

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by dafost922 »

I need to boot to several workstations at once over a network. Is there a way I can install the nvidia driver to the image I'm using, that way, it will be pushed out to all of the workstations to begin with when the OS is installed over the network?

Level 1
Level 1
Posts: 1
Joined: Sat Jun 24, 2017 8:59 am

Mint 18.1, Mate experience Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by ustaknow »

I see this thread goes back to 2013, till today June 2017. I found my fix on Ubuntu, my search for help did not bring me here. I clicked in after solving and relaxing to read more. I read the "please read how to post first"... I believe I comply, if even a bit long, narrative in style. (If you don't like "narrative" style, don't read it, you won't like this one.)

--- Hello all, new here, first post, -- read the above thread quick but mostly; amazing great work, kudos all. I write the below in narrative style, since seems may be the most useful since all experiences will be different, yet "helpful" if know it's the same fix, different syntax.

I'm using an Amazon Purchased Linux2DVD, --- Linux Mint 18.1, with MATE - Special Edition, 64-bit, on a 9 year old dual chip Pentium with 4Mb ram.

This laptop has the AMD, NVIDIA issues, -- the specs are so generic and change for nearly all models shipped, this I feel generally fits. Nonetheless, from the aluminum label mounted to the keyboard of the Laptop -- ASPIRE 7535-5020, AMD Athlon 64x2 QL 65 2.1GHz; ATI Radeon HD3200 Graphics 1919 HyperMemory, 17.3 HD LED, 320 GB HDD. (The "Bios", and drivers NEVER changed since initially configured, as received from TigetDirect purchase online.)

The Live CD review went well, -- so decided to migrate from Windows 7 and MS Office since nearly incapable of being used, and I work every day on-line with this unit. The online financial sites have so much "krappe-code" running, et al., etc. no browser known to man or dog made a difference and etc. -- and I tried many, some obscure.

I tried to dual boot install, -- didn't work at all.

I tried to check if using automatic, as-is partitioning mattered, -- made no different. Install failed, apparently on the partition element of install.

I copied over (7hrs) all my data content to a 1Tb USB, and allowed the * delete all install, --- why not? (Really... what was I loosing.)

It installed as advertised/stated, smoothly, in like 15-20 min, BUT then,
--- booted to a [ _ ] cursor, and me-curser-ing.

[This appears to be such a common issue, I don't know why some of these are not flagged in documentation, or more easily found for new-new-newbie to "this". I'm a tech, but, nonetheless new to "this". I am not "new" on-line, etc. I found no "warnings" common install issues, etc. However, after this, --- on AskUbuntu for much older editions found the very simple, compared to the above (s), solution, for me
--- modify GRUB with boot-repair, nomodeset. I saw the Ubuntu 4.x... flash on some load message, going by sooo fassst, -- so figured would apply here, -- it did.

Fortunately, I could *still boot (config'd F12 after F2 on boot to get manual boot item pick), to the live CD, and WiFi, Ehernet worked. So entered their get instructions, like the above thread, diff syntax for me/you?, (didn't buy a modify GRUB with boot-repair, nomodeset USB -- unnecessary; if you can still get online; otherwise, yes likely necessary.) Again, all the above goes over this "common issue fix", so won't restate it, -- search online for [ GRUB, boot repair, nomodeset, ubuntu, AMD ATI Radeon ] -- what you need in several publishings on-line will be there for "you", especiall for me at the AskUbuntu site (they "allow" Mint to Ubuntu relevant questions).

--- Again, flying blind and learning as I go here, across 2-days, --and NO comments right off about what to expect, it "fixed" it.

However, I had "squashed graphics" (which I hate, flatened 16:9 HDD), --and one very wrong HD configuration with "unrecognized" in the monitor config area.

-- I "instinctively, did an update all, not knowing this SHOULD be done. AND --remove the nomodset and you will have a then, "perfect" install.

Look for a "What to do NEXT after your install", e.g. 8 - 10 Steps after the initial install. I happened to do them out of instinct, "experience-?"... luck... That would have "fixed" the nomodset thing if flagged, so applies here IMO.

Also, on AskUbuntu (here?), --they have some fine tuning to the Kernel mods, after install, for/relevant to your "base" cache's, HD read/writes, use/wear, "Internet Browser" performance (very snappy Chromium - yet careful of any delay w/o a "working" icon which results with multiple session windows if a "quick clicker" like me).

I now love Linux, again after so many years. One in the basement of Belllabs running an initial Linux-Windows hybrid, pre-2000.

--- Honestly I don't get why the initial install didn't just, --not load graphics, then, "Banner Message" -- *now Update all drivers (graphics is done), and reboot with the second GRUB removing the mod on first boot after install. So much pain could be avoided.

If I had even been prepared for the above, not just relying on 2-decades of stuff not working, with no known reason/help why, -- I would have otherwise gave up again on Linux as an alternative, and just bought a MacBook Pro (*which I had done!, in all of this, a used one, and then *returned after this *success, -- it, the "Apple", wasn't that great with other issues too).

I believe I could have been done with this Migration to Linux, end to end in like 3 - 4 hours max -- what it took across 2-days of searching and reading, 3-4 days if include the MacBook alternative solution to Linux failure.


-- "Admin/Moderator", feel free to delete or move, etc. as you like if somehow "wrong" "here", as a new person ... I had the time to write this in flow of thought, and felt if some of more inductive folks "here", need/get this, well, there you go, or not. Again, TLTR, -- delete it, won't hurt my feelings.

Thanks all! Finally a Great alternative to Mac/Win! Now I have to learn Command Line again... but fun in a Window :)

Level 4
Level 4
Posts: 411
Joined: Tue Aug 05, 2014 7:52 pm

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by fruitkiller »

For some reason I got the 4 green dots of death and X-server didn't work. I turned the computer off and then back on and then everything was fine, it was using the proprietary AMD driver and no trouble? How can that be? It's enough that some level 4 update messed up the previous installation of the driver and now amd catalyst controls can't be accessed, can't modify anything from there, I get a long error message telling me that the driver isn't installed, or if it's installed something else is wrong. Not the first time this happened to me, but when a new driver came up and I installed it once, it turned everything back like it used to be. I assure you next time things are 100% right, I'm learning how to use clonezilla to make an image of my LM17.3 partition.

Also related but not for now, can I burn a DVD-RW for Linux Mint 17.3 to use for installation (don't tell me about usb keys, I know about all of that, they're all used except for one, also a disc if well stored is permanent, while usb sticks can break out of nowhere, although this 8gb one I bought at a pharmacy of all places is alive and well since 2011 working perfectly. I ask because if you burn a windows iso on a DVD-RW you've got to burn it at 2x max or it won't work, well, even then, since win7 (the only one I use sporadically), you can't use a DVD-RW, it has to be a DVD-R or DVD+R, burned at 1x-2x max. Is it the case with Mint ? I forgot, I have a disc here of Mint 17, the original and it's on a DVD-RW and it works, but now it's too old, doing all the updates would take much longer than with a Mint 17.3 disc.

Sorry for cutting off the ongoing conversation, but I think such questions have to be put in this thread, right?

Level 1
Level 1
Posts: 1
Joined: Mon Sep 18, 2017 9:37 am

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by josh60 »

I solved my problem in that way:
After downloaded the Iso Image I set my usb stick and (happily :-() I begun the setup process.. But the live refused to run! So I tried by dvd but nothing to do.. Nor modifying the Bios (where, obviously, the fast boot was disabled).. After that looking for help everywhere, finally, surfing on the Ubuntu help pages, I found out the existence of the boot parameters..
So, after a while (trying different combinations among them) I succeeded to make the live run (Uefi) writing (after pressing “e” and editing the boot) NOLAPIC and NOMODESET (something about interrupts the first and no specific drivers for the video card). As soon as I could I installed Mint in my SSD.
But on the first boot… Same problem.. To tell the truth I thought into myself in that moment “all I can do.. It’s crying”!.. Bur never give up! So I run Mint in safe mode and as soon as I was in, I immediately installed the N-vidia drivers and Intel cpu drivers instead of the existing ones.. .
Now my Mind Sonya is ok… It’s beautiful, operational and I think stable too.
Linux Mint has just acquired a new fun!
But…. Why don’t offer the possibility, at the beginning of the process, to choose proprietary drivers? As I can say they are offered for free by the different companies that put the peripheral devices on the market…
- CPU Intel i7-4790K
- Graphic Card N-vidia Ge Force 970GTX
- Motherboard Asrok Extreme 6/3.1
- 3 SSD and 3 HDD Sata disks too
- 32 GB Ram
Thanks … and hello to everybody…………
Ah! sorry fir my unorthodox way to explain my point .. But I'm a perfect beginner!

Level 1
Level 1
Posts: 4
Joined: Sat Sep 30, 2017 3:11 am

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by arnvdx »

I tried and it worked but the shutdown started to hang. I updated the kernel and now I am back to square one.

Level 2
Level 2
Posts: 81
Joined: Mon May 04, 2015 5:36 pm

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by rodrigs »

I installed Linux Mint in a Lenovo with Nvidia Geforce. As soon as it showed issues, I suspected it would be included in this category of boot problems with AMD and NVIDIA graphics cards. I rebooted from the usb and edited the GRUB menu "quiet splash" to "nomodeset". Though the boot issues were solved; the wireless crashed soon after the boot. I installed Bumblebee but the problem persists. I am lost on what to do after. Can anyone share an idea of what I could have missed or how to solve this?
I am connected to internet through an ethernet cable.

Here is the result of

Code: Select all

inxi -Fxz
System:    Host: elsa-Lenovo-ideapad-310-15IKB Kernel: 4.10.0-33-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.2 Sonya
Machine:   System: LENOVO (portable) product: 80TV v: Lenovo ideapad 310-15IKB
           Mobo: LENOVO model: Torronto 5C2 v: SDK0J40700 WIN Bios: LENOVO v: 3JCN23WW date: 11/10/2016
CPU:       Dual core Intel Core i5-7200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10848
           clock speeds: max: 3100 MHz 1: 599 MHz 2: 600 MHz 3: 599 MHz 4: 599 MHz
Graphics:  Card-1: Intel Device 5916 bus-ID: 00:02.0
           Card-2: NVIDIA Device 134f bus-ID: 03:00.0
           Display Server: X.Org 1.18.4 driver: nvidia Resolution: 1920x1080@60.01hz
           GLX Renderer: GeForce 920MX/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 375.66 Direct Rendering: Yes
Audio:     Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3 Sound: ALSA v: k4.10.0-33-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 5000 bus-ID: 01:00.0
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
           driver: rtl8821ae port: 4000 bus-ID: 02:00.0
           IF: wlp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 1032.3GB (4.4% used) ID-1: /dev/sda model: ST1000LM035 size: 1000.2GB
           ID-2: USB /dev/sdb model: USB_Flash_Drive size: 32.1GB
Partition: ID-1: / size: 911G used: 7.4G (1%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 6.34GB used: 0.02GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 35.5C mobo: N/A gpu: 0.0:31C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 230 Uptime: 12 days Memory: 2096.1/5865.3MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

Level 1
Level 1
Posts: 1
Joined: Wed Nov 29, 2017 4:08 pm

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by dragonlawer »


i tried to install mint 18.3 on my old rig.
HW: fx6300
MB: Ga-A970
Ram: 16gb
Gpu: Amd hd7870 - ghz edition

The problem is, that i cant boot into the live system. Its clearly the amd graphic card because you can see later colour full pixels. Its when the os is switching to some new drivers.
The workaround with combatibility mode isnt working its stuck after ~ 2 minutes.

Its a pain in the ** when the devs decided to obandon the FGLRX drivers.
Has anybody a solution to this problem?

best regards

Level 1
Level 1
Posts: 20
Joined: Mon Nov 13, 2017 6:31 am

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by NickByford »

I found a simple way of installing Mint 18.2 after my Nvidia card sent the screen into paroxisms.

1. boot live DVD/USB in compatibility mode
2. Run install from desktop
3. Reboot
4. Upon reboot, hold shift key and select Advanced options from menu (2nd on list in 18.2)
5. Choose recovery mode (first on list worked for me)
6. When the screen with white background shows, choose enable networking
7. Choose boot
Upon restart, you will get a message in the top-right of the screen that tells you that the graphics are software driven. Click on that to get rid of it then go to system>Drivers
Run this and select the NVidia driver, not the open source one it's recommending
Once that's been done, the computer needs to reboot again, but afterwards, the only thing that doesn't work is the splash screen with the little dots. It doesn't have the LM logo, other than that, it's been right as rain ever since.

Apparently, the card is old and NVidia supplies a legacy driver. It's worked fine though.

Hope this helps someone who, like me, is scared to death of the command line stuff.

I do have to ask why there are no options in resolution though. For people with poor eyesight, it might be nice to be able to enlarge stuff as some of the text can be a bit small (I'm thinking of the owner of the laptop I just upgraded to Cinnamon. She has difficulty seeing).
HP Pavilion P6565uk AMD Phenom II X6 1035T running Linux Mint 19.2

Level 1
Level 1
Posts: 6
Joined: Thu Dec 21, 2017 6:58 pm

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by markfw »

So I installed linix mint 18.3 using the below procedure on an X399 Taichi motherboard and a 1950X TR and duakl 1080TI Nvidia cards. The procedure worked fine on 4 systems with an Intel processor and Nvidia cards:

Code: Select all

First, disable secure boot. The easiest way I found was to delete the keys in key management.

Next, after booting with a linux mint USB or CD, install it. Use an empty disk, or one you don't care if its wiped clean.

Then open a terminal window and do the below commands


sudo dpkg -i python-support_1.0.15_all.deb

sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt-get update

sudo apt-get install nvidia-387 (or if it appears on the linix home page drivers list, you can do it from there.

sudo apt-get install nvidia-opencl-icd-387

sudo apt-get install libcuda1-387

sudo apt-get -y install python-gnome2 mesa-common-dev freeglut3-dev nvidia-settings gedit

Install fah client and console using these links:
Folding at home client (background service)
Folding at home control panel (user interface)

cd /var/lib/fahclient

sudo wget

Then fire up fahcontrol and add the GPU client(will show under education in the menu), and maybe also the remote access by adding , to the two IP places

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration

cd ~

gedit fancontrols

and add and then save (for 2 video cards)

nvidia-settings -a [gpu:0]/GPUFanControlState=1
nvidia-settings -a [fan:0]/GPUTargetFanSpeed=100
nvidia-settings -a [gpu:1]/GPUFanControlState=1
nvidia-settings -a [fan:1]/GPUTargetFanSpeed=100
Sp after I get done, everything works fine. UNTIL I reboot, then I get a black screen with a very nice graphical cursor. Help !!!

User avatar
Level 1
Level 1
Posts: 1
Joined: Mon Jan 15, 2018 8:09 am
Location: Sweden

Re: Solve boot problems with AMD and NVIDIA graphics cards

Post by svendus »

After a lot of experimenting without any Sussex ending up with the black screen with blinking white prompt in upper left corner after reboot
and unable to enter the Grub meny
we lastly solved the problem by un checking this dialog
Install third-party software for graphics and Wi-Fi hardware, Flash, MP3, and other media


for after reboot install the correckt Driver for the NVIDIA Corporation: GF100 [GeForce GTX 470] Graphic Card


and the
intel-microcode (open-source)
Version 3.20180108.0~ubuntu16.04.2
Processor microcode firmware for Intel CPUs

Regards Svendus
Image Image

Post Reply

Return to “Installation & Boot”