Installation hangs

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Mon Jan 14, 2013 5:19 pm

Installation hangs

Postby jshanki » Mon Jan 14, 2013 5:27 pm


I have been using Windows for the past 10 years.. yesterday again Windows 7 broke and then I thought - time to move on to new OS in the new year. So I am pretty new !!!! I created a 'live usb' for the Linux mint 14. My laptop is Intel i3 64 bit. I think the graphis is Intel Graphics 3000. I can go to the boot menu and load linux mint only in compactibility mode wherein I added the option 'nomodeset'. I am not able to load the normal linux mint. It starts and then gives a blank screen.

Once I boot up in the compactibility mode, I tried to install the linux mint. It installs upto point where it says 'Configuring Hardware' and then hangs. I don't know what else options to try. I currently don't have internet connection, but I assume my live CD should complete atleast my installation. If I restart, I am not able to boot. I searched in the net but unable to get a direction on how to resolve. Any help is appreciated.

I am not so well versed with linux as I am with Windows. So if I repeating this question - I am sorry.

Shankara Narayanan.

User avatar
Level 24
Level 24
Posts: 21277
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Installation hangs

Postby xenopeek » Tue Jan 15, 2013 7:11 am

Please boot from the Linux Mint installation USB again. Once booted, open a terminal and run the following command. Share the output here; it may help us provide you with something else that needs doing. You can copy text to/from the terminal, see its Edit menu. You can hopefully have another USB stick on which you can save the file, so you can get the information here?

Code: Select all

inxi -Fxz

Level 1
Level 1
Posts: 1
Joined: Tue Jan 15, 2013 3:32 pm

Re: Installation hangs

Postby montemike » Tue Jan 15, 2013 4:29 pm

Similar problems to the first post - in my case Intel HD 4000 graphics on brand new rig.

Managed to capture the point where it stops "configuring the hardware" using ps.

Stalls at: modprobe --set-version=3.5.0-17-generic --ignore-install --quiet --show-depends i915

Tried a native Ubuntu 12.10 with the same problems.

Have got a basic desktop working using i915.modeset=0

Have since updated the kernel - that also stopped at the modprobe command.

inxi -Fxz on my system gives:

System: Host: host Kernel: 3.5.0-21-generic x86_64 (64 bit, gcc: 4.7.2) Desktop: Gnome Distro: Linux Mint 14 Nadia
Machine: Mobo: Acer model: Revo RL80 version: 1.0 Bios: American Megatrends version: P11-A2L date: 11/20/2012
CPU: Dual core Intel Core i3-2377M CPU (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 5986.6
Clock Speeds: 1: 1500.00 MHz 2: 1500.00 MHz 3: 800.00 MHz 4: 800.00 MHz
Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
X.Org: 1.13.0 driver: vesa Resolution: 1920x1080@0.0hz
GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 0x301) GLX Version: 2.1 Mesa 9.0 Direct Rendering: Yes
Audio: Card: Intel 7 Series/C210 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture ver: 1.0.25
Network: Card-1: Intel 82579V Gigabit Network Connection driver: e1000e ver: 2.0.0-k port: f060 bus-ID: 00:19.0
IF: eth0 state: down mac: <filter>
Card-2: Atheros AR9462 Wireless Network Adapter driver: ath9k bus-ID: 02:00.0
IF: wlan0 state: up mac: <filter>
Drives: HDD Total Size: 493.9GB (9.7% used) 1: id: /dev/sda model: ST9500325AS size: 493.9GB temp: 34C
Partition: ID: / size: 449G used: 45G (11%) fs: ext4 ID: swap-1 size: 4.17GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 150 Uptime: 18 min Memory: 606.1/3837.8MB Runlevel: 2 Gcc sys: 4.7.2 Client: Shell inxi: 1.8.4

Level 1
Level 1
Posts: 2
Joined: Mon Jan 14, 2013 5:19 pm

[SOLVED] Re: Installation hangs

Postby jshanki » Tue Jan 15, 2013 4:47 pm

First off - thanks for taking the time to read and answer.
okay.. after about 18 hours of work (with a sleep of 5 hours) - I got it to work after about 5 installs & I was able to install only ubuntu 12.04.

My Laptop: HP Pavilion g6 Core i3 with Intel graphics (think it is the 3000 series if not mistaken, 64 bit) & wide screen (1366x768 resolution).

Here is what I did to install. Flashed the live usb with ubuntu 12.04. Boot the ubuntu with the "nomodeset" option. If I tried the install directly, it will not work. So you have to boot and then install. Then start the installation and have a good internet connection. The linux mint always stopped at the configuring hardware even though my internet was good and I allowed it to download all the packages

It installs everything. But then there were two issues. One - there was always black screen when it boots & second the resolution was 1024x768 which was awful for my wide screen.

Then go to the Intel Linux drivers website and download the drivers. Make sure you have all the pre-requisite set and install the same. You have to reboot a couple of time. So ensure to update the grub with the nomodeset option. If you are unable then keep on pressing the shift key to get the grub loader, edit it ('e' key) and add the nomodeset option.

Once the installation of drivers is complete, update using the Update manager. It will also provide the Intel graphics driver. I have updated my maching with xorg. Then add a couple of lines in the grub with following options

"acpi_osi=Linux acpi_backlight=vendor".

Make sure this is between the quite and splash. If I had the acpi_osi at the end of the grub it did not work. So let it be inbetween the quiet and spash. With this I was able to get rid of the nomodeset and I have a resolution of 1360x768 which was better and the fonts are also good. I had also copied the true type fonts to the usr/grub to make it work.

Now - the issue is the function key combinations which is not working (e.g. Fn + brightness). I am yet to figure that out. I think I will do another post if that is not working. I am once again not sure why Linux Mint failed to install (which is version of Ubuntu if I am not mistaken) to proceed with installation.

Hope this helps people.

Shankara Narayanan

Return to “Installation & Boot”

Who is online

Users browsing this forum: HACKNEYL, Mattyboy and 8 guests