Page 1 of 1

Installed but can't boot - grub - 'canonical path of /cow'

Posted: Thu Feb 14, 2013 2:30 am
by Zeitgeist

I'm new to using Linux generally, and Mint specifically, although I have played around with it a bit before. I have a new Windows 7 laptop (ASUS R501VM) and I am trying to dual boot it with Linux Mint 14 Cinnamon 64-bit. I have recently installed Mint after following instructions from this forum on how to partition my HD.

Again, I'm new to all this so don't quite understand it, but my problem is that the 'GRUB' bootloader does not seem to work - only the windows bootloader. I tried using EasyBCD toget around this but all this did was add the Mint option which, when selected, did not actually work.

Using the Live DVD, I have tried following online instructions to reinstall GRUB (I think this is what I should be trying to do), but have been getting an error message in the terminal when I try to do the grub install. The error says 'failed to get canonical path of /cow'. I still cannot boot properly from the hard drive.

Does anyone have any suggestions of how to fix this? Let me know if you need more information on the error to work it out and I will try to get it for you.

Thanks in advance!

P.S. My computer uses EFI if that’s an issue

Re: Installed but can't boot - grub - 'canonical path of /co

Posted: Thu Feb 14, 2013 6:20 am
by viking777
:shock: :shock: :shock: :shock:
My computer uses EFI if that’s an issue
:shock: :shock: :shock: :shock:

Wow, you haven't read a lot of this forum have you! We have a 'resident' Uefi expert - srs5694 - on the forum who is about the only person who knows enough about this to be able to help. You could search through his posts or wait for him to answer, he usually will. I won't confuse you with my limited knowledge of the topic, I will almost certainly lead you in the wrong direction. If you are in a hurry (and reading srs's forum posts is not a short term project) you could try installing his own software onto a usb stick - this might at least allow you to boot Mint (via the usb key), but a very easy starting point is to run the command

Code: Select all

ls /boot
It should contain the folder efi. In your case I think it will because you can still boot Windows but if it is not there you will have to start over anyway.

There are also a couple of tutorials over on the Community website:

I can't vouch for either of these, they weren't around when I was doing battle with Uefi installs.

Re: Installed but can't boot - grub - 'canonical path of /co

Posted: Thu Feb 14, 2013 7:09 am
by Zeitgeist
Is UEFI exactly the same as EFI then? I was under the impression that EFI was just a different way of booting (as opposed to BIOS), and UEFI was restricted in terms of security and not allowing you to boot other operating systems? Maybe I was mistaken

Re: Installed but can't boot - grub - 'canonical path of /co

Posted: Thu Feb 14, 2013 11:53 am
by viking777
Uefi is a later development of efi, most systems will have Uefi nowadays. You are getting confused with Secure Boot which is one particular feature of Uefi systems but not always implemented, and certainly not with Windows 7, only Windows 8. The whole issue is a clear as mud, and in some cases remarkably dangerous to your hardware (the only way I could rescue mine was to short the live motherboard with a screwdriver - three times - and then flash the bios from a dos disk - about as user friendly as you can imagine with a brand new laptop :evil: ). You have obviously been lucky (or smart, or both) in that you haven't trashed anything yet. People are working on this problem all the time, but there are so many different ways that hardware vendors have implemented this new feature, that keeping up with the differences is an almost impossible task.

Of course, having said all that your problem might not have anything to do with Uefi. I have been so traumatised by my experiences with Uefi that I now blame it for everything from my leaking radiator to my bad back :lol:

Re: Installed but can't boot - grub - 'canonical path of /co

Posted: Thu Feb 14, 2013 4:50 pm
by Gaytan

I had similar problems on my iMac, which works with EFI. I tried to install Linux Mint, Cinnamon edition, each time leaving me with an inaccessible Linux Mint after installation reboot.

I managed to re-enter Mint by means of the free Grub2 bootdisk, which detects and boots os' s present.

In the end I reinstalled with the 14.1 iso dvd of Linux Mint, Cinnamon edition.
Boot-repair latest version assisted me in correcting Grub2. It now boots ok every time, using rEFInd.

I dual boot OSX with Mint Nadia14 on my 2008 iMac!



Re: Installed but can't boot - grub - 'canonical path of /co

Posted: Fri Feb 15, 2013 8:26 am
by yrrchsebor
Yeah, i managed to dual-boot Windows 8 and Linux Mint 14 on a new Asus X501A. At first it would only boot straight into Windows, but the Boot Repair program in Ubuntu Secure Remix fixed up GRUB to work with UEFI. I didn't seem to have the latest version of Boot Repair so it directed me to use Ubuntu 12.10 Secure Remix.

Re: Installed but can't boot - grub - 'canonical path of /co

Posted: Sat Feb 16, 2013 7:34 am
by viking777
If the suggested boot-repair tool doesn't suit you, I read of someone else with a similar problem who solved it simply by turning off Uefi in the bios settings and installing mint in 'legacy' mode. Not all bios's have this setting - mine doesn't for example, but it is worth a try. I understand it generates dire warnings about not being able to boot windows, but these usually prove to be completely unfounded. If you can't boot windows after doing this then simply boot into the bios settings page again and revert the setting. Another option would be to use a distro with more advanced Uefi support like Ubuntu 12.10 or Fedora 18. (yes I know Mint14 is based on ubuntu 12.10 but it does make a difference, I can tell you from my own experience).