[Solved] Boot to black screen with Mouse Pointer.

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Locked
User avatar
raymerjacque
Level 4
Level 4
Posts: 221
Joined: Fri Jul 06, 2012 8:22 am
Location: Port Elizabeth, South Africa

[Solved] Boot to black screen with Mouse Pointer.

Post by raymerjacque »

When i got home tonight my Linux desktop was frozen. So i rebooted Pc by the power button.

Now when Pc starts up it boots to a black screen. I can move the mouse pointer around but cant do anything else, since its just a black screen with a mouse pointer. My Pc is set to "auto login" and i assume this happens after the login process, is there a way to change auto login to manual login via live DVD ? I can access my main drive from live dvd.

how do i boot into compatibility mode ? when i start PC there is no grub menu that shows up ...

Can someone assist me to fix this problem ?

PC spec's :
Core I5 3470
8Gb DDR3 Ram
500GB HDD + 80GB HDD
Nvidia GT440 1Gb Gfx card
Monitor is a LG D2343 Cinama 3D Monitor

Running cinnamon 14.1 32bit. ( im not dual booting )

All was working fine before and i REALLY DONT want to reinstall, ive spent more than a week just setting everything up...

I managed to boot off the live DVD to get here to make this post... so im stuck with live disc booting at the moment.

Any help will be much apreciated.
Last edited by raymerjacque on Wed Feb 20, 2013 6:40 pm, edited 1 time in total.
MakuluLinux - The Big chief has spoken !.
check this out : http://www.makululinux.com

User avatar
raymerjacque
Level 4
Level 4
Posts: 221
Joined: Fri Jul 06, 2012 8:22 am
Location: Port Elizabeth, South Africa

Re: Boot to black screen with Mouse Pointer. ( please help )

Post by raymerjacque »

i managed to get to terminal by pressing CTRL+ALT+F1

the i logged in and typed "startX"

took me back to the black screen again.

i do see it shows on screen "loading extension XINERAMA"

that is last thing on the screen.
MakuluLinux - The Big chief has spoken !.
check this out : http://www.makululinux.com

User avatar
raymerjacque
Level 4
Level 4
Posts: 221
Joined: Fri Jul 06, 2012 8:22 am
Location: Port Elizabeth, South Africa

Re: Boot to black screen with Mouse Pointer. ( please help )

Post by raymerjacque »

tried to type : glxinfo

get response : unable to open display

so its a gfx issue ?
MakuluLinux - The Big chief has spoken !.
check this out : http://www.makululinux.com

User avatar
raymerjacque
Level 4
Level 4
Posts: 221
Joined: Fri Jul 06, 2012 8:22 am
Location: Port Elizabeth, South Africa

Re: Boot to black screen with Mouse Pointer. ( please help )

Post by raymerjacque »

found terminal commands for reinstalling nvidia driver. so trying that now. reallt hope it works...

[Edit] Nope didnt work. Guess i have to Reinstall :(

but first to back up 73GB wine folder and 20Gb Vmware first :(
MakuluLinux - The Big chief has spoken !.
check this out : http://www.makululinux.com

User avatar
raymerjacque
Level 4
Level 4
Posts: 221
Joined: Fri Jul 06, 2012 8:22 am
Location: Port Elizabeth, South Africa

Re: Boot to black screen with Mouse Pointer. ( please help )

Post by raymerjacque »

As a desperate last move i tried to install an additional desktop "sudo apt-get install gnome-shell" and guess what, It took me back to log in screen where i selected cinnamon as default and then i was able to log back into my PC :)

So not sure what the hell caused this problem, I am guessing there must have been some sort of problem with the GDM, but it seems fixed for now.
MakuluLinux - The Big chief has spoken !.
check this out : http://www.makululinux.com

maddin
Level 1
Level 1
Posts: 1
Joined: Tue Jun 04, 2013 7:26 pm

Re: [Solved] Boot to black screen with Mouse Pointer.

Post by maddin »

You saved my day, man...well, nearly. Was you able to get your old desktop back? I'm not. I can only login to the session 'Cairo-Dock (GNOME)' When trying to choose cinnamon, i'm able to log in, but have the old, standard Wallpaper, no starters, no menu, no nothing :(

Any suggestions?


greetings

tonycstech
Level 1
Level 1
Posts: 45
Joined: Tue Sep 30, 2014 7:37 pm

Re: [Solved] Boot to black screen with Mouse Pointer.

Post by tonycstech »

My screen says: (after pressing ctrl alt f7)
Restoring resolver state [OK]

after pressing ctrl alt f1 i tried to login
Loged in and did the sudo apt-get install gnome-shell
but i have KDE so it didnt really help.
Does that mean that shell is broken (if shell reinstall is the solution) ?
How do i reinstall KDE ?


I picked KDE because main page said "polished". I thought it meant "working" but i was wrong once again.

themacmeister
Level 1
Level 1
Posts: 46
Joined: Sun Jun 21, 2009 7:03 am

Re: [Solved] Boot to black screen with Mouse Pointer.

Post by themacmeister »

I have the same issue with Mint 17 XFCE. Black screen with pointer.

I have installed alternate desktops (Fluxbox/OpenBox) but I would love to know the reason behind this?

When installing one package, I did notice that one OpenCL nvidia extension was removed, but I figured this would not be fatal (as CUDA extensions were still there).

I am only just now coming back to Linux, after giving up on it about 6 months ago. The sad thing is, it was Mint 17 XFCE which caused me to give up on it last time...

I was too frightened to install 17.1 RC2 !!

deaddelgado
Level 1
Level 1
Posts: 1
Joined: Sat Jul 04, 2015 1:49 am

Re: [Solved] Boot to black screen with Mouse Pointer.

Post by deaddelgado »

I have updated from 17.1 (no problems) to 17.2 and now I have this issue again. I havent tried mint since Lisa-update. I left mint for the same problem with X. It was confusing and I didn't find or revive any help. Now i'm back on mint because it seems stable and I wanted to see if anything changed. Anyways I have no idea what's going on with X but it looks like virtualbox is conflicting even thought I uninstalled it?

User avatar
Oscar799
Level 19
Level 19
Posts: 9924
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: [Solved] Boot to black screen with Mouse Pointer.

Post by Oscar799 »

deaddelgado
Tacking a question on to the end of a 16 month old thread that has already been marked solved probably isn't going to get you anywhere
Start a new thread with your question instead
Image

Locked

Return to “Installation & Boot”