Blank desktop after update

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Bad Boy Bubby
Level 1
Level 1
Posts: 30
Joined: Thu Feb 21, 2013 4:02 am

Blank desktop after update

Postby Bad Boy Bubby » Thu Feb 28, 2013 10:33 am


Thought I would post as may be usefull to others.

Installed some updates today which after a reboot I was left with my wallpaper and nothing else no start menu no panel etc. Desktop right click worked so I could get terminal up and from there ran firefox and nemo (cinnamon file manager) I think the updates mentioned libgl which I think are associated with opengl ? anyway I figured that my video drivers were the problem I use ATI propriety drivers to be able to run steam on linux etc. So I did the following.

Force removed the propriety driver using

sudo /usr/share/ati/ --force (I tried without the force but it said something had changed since install)

reboot - Success yay desktop back up

This came backup running the Xorg driver (linux default)

I then installed the approved ATI driver from within mint

menu > preferences > software sources - additional drivers tab and selected fglrx-updates (I have had to do this step before to get the propriety drivers downloaded direct from AMD to work)


go back to drivers in software sources and switch back to the xorg drivers again.


I then re-installed the original driver I had from AMD currently version 13.1

Final reboot back as we were :mrgreen: Steam and counterstrike working.

Running Linux Mint 17 KDE 64bit
Steam for Linux - Counterstike, Source and GO are my main games
Nvidia 750ti
Intel i5 Processor

Level 1
Level 1
Posts: 1
Joined: Thu Feb 28, 2013 11:33 pm

Re: Blank desktop after update

Postby imi » Sat Mar 02, 2013 2:31 pm

Had the same issue here. Thanks for the help !

Level 1
Level 1
Posts: 18
Joined: Sat Mar 02, 2013 3:51 pm
Location: United Kingdom

Re: Blank desktop after update

Postby AlqasimO » Sat Mar 02, 2013 7:41 pm

I had the same problem, but fixed it doing a force install of the proprietary catalyst drivers on top of the existing installation. Wasn't necessary to revert back to open source.

Return to “Installation & Boot”