Partitioning Volume Mounted Issue

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Thu Feb 28, 2013 1:50 pm

Partitioning Volume Mounted Issue

Postby bgk0018 » Thu Feb 28, 2013 2:35 pm


Install Method:
Unetbootin flash drive with Linux Mint 14 XFCE 64 bit

I am installing over an old installation (Jolicloud). I can boot fine into the Mint Environment from the flash drive, the issue arises upon attempting to run 'Install Linux Mint'. The problem, is that upon attempting to partition the hard drive, the volume is mounted during the process and halts us from successfully creating the partition. This happens automatically.

Things I've tried (incoming wall of text):


-Straight forward install over Jolicloud using the entire drive (Second option on installer).
Fails gives the following error message: "The ext4 system creation in partition #1 of SCSI1 (0,0,0)(sda) failed." Follows up with a prompt that states that the volume is mounted and whether or not I would like to attempt to unmount. Additionally a system message pops up stating that "The inserted volume has been mounted automatically."

-Attempted both mounting avenues from the above prompt. Unmounting attempts the partitioning process again after unmounting the volume I'm attempting to install to. This subsequently fails with the same error message above, "The ext4 system...", and prompts for an unmount again. Eventually doing this another time freezes the installer. Leaving mounted shows me a table of partitions that I can install to, attempting to select the partition I would like to install to prompts me with the following error: "No root file system is defined, Please correct this from the partitioning menu."

-Attempted "Something Else Option", deleting the current partition and creating a new one I'm attempting to install to. If I attempt to use the partitions as is, I am greeted with the "No root file" error from above. I create a new partition and I designate all free space to this partition and select '/' as my mount point. I select this for formatting as well. This is then followed up with the "The ext 4 system creation failed" error as mentioned before.

-I used GParted to attempt to generate the partition before running the installer. GParted on partition deletion throws a 'Libparted Bug Found' warning. This warning states:
"Partition 1 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it /they are in use. As a result, the old partitions will remain in use. You should reboot now before making further changes".

-I have attempted the reboot at this point and if I remember correctly it did remove that partition appropriately upon reboot. However attempting to create the new one will fail (As a side note if you unmount the partition in GParted, you are immediately shown a system message saying that the volume has been automatically mounted).

The failure of partition creation in GParted displays this:
Create empty partition
set partition type on /dev/sda1
create new ext4 file system <--- Errors here

Upon expanding the errored command we see:
mkfs.ext4 -j -O extent -L "" /dev/sda1
/dev/sda1 is mounted; will not make a filesystem here.

Additional Info:
The volume is currently mounting to the following Mount Point, "/media/mint/--largehashstringvalue--"
I've run the basic hard drive self tests under 'Disks' and the drive came back fine.
I've attempted a clean USB UNetbootin install of the Mint ISO.
I've rearranged and set to compatibility anything I thought could've been relevant in the BIOS. I can expound on this if need be.

I know what my issue is (the volume is getting automatically mounted, I need it to not do this), but I'm not that linux savvy so I don't exactly know where to go from here. Google has turned up little on automatic mounting outside of people wanting to automatically mount NTFS partitions or something. It did point me to GParted but I haven't had any real success with it. I did a quick search of the forums, but admittedly I've been at this for 4 or 5 hours, and I'm getting tired.

Thanks ahead of time.

Level 1
Level 1
Posts: 2
Joined: Thu Feb 28, 2013 1:50 pm

Re: Partitioning Volume Mounted Issue

Postby bgk0018 » Thu Feb 28, 2013 5:38 pm

Nevermind, I just swapped to Ubuntu and it's working. Shame, I really wanted to try out Mint.

Return to “Installation & Boot”