I deleted my EFI partition.

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 12
Joined: Fri Mar 01, 2013 12:11 am

I deleted my EFI partition.

Postby Ponch0 » Tue Mar 05, 2013 1:28 pm

No bootable device found - when booting from UEFI.

I tried dual boot installing Linux Mint 14 Mate with Windows 8 and in doing so I chopped up my Win8, there were just bits and pieces of it, here and there. I initially tried the recovery disk and it did not help at all it just made the situation worse. So, I came across a suggestion to install Linux Mint 14 KDE, it gives the option of installing over the entire disk, I did not realize however, (it didn't click) that I would delete the EFI partition. By the way, I don't care at this point that I lost my Win8, I would just like to be able to boot Mint from UEFI.

I came across this post https://help.ubuntu.com/community/UEFI
There's a section in there that explains how to create a partition. I followed the steps, created Gparted LiveCD and booted from it, the problem I'm having is that I can't split the main disk and create a seperate partition from it at all. Are there any alternatives, a program that I can run from KDE that works in CSM boot, that will allow me to create an EFI partition. Am I following the wrong post? What can I do?

(KDE Partition Manager doesn't allow me to create new partitions either)

My machine is the Toshiba S855-S5378.

Thank you

Level 1
Level 1
Posts: 10
Joined: Tue Feb 12, 2013 10:40 am

Re: I deleted my EFI partition.

Postby laconic » Wed Mar 06, 2013 12:17 am

I have a C855 and to get the recovery discs that I made with the toshiba recovery disc program required using the format utility first. It takes a rather long time to format for some reason. I dont know what recovery disc came with your laptop but mine only came with the program to create one. You might look for the format option on your recovery disc. To reformat my hard drive took around 4 hours. Once I reinstalled windows 8, I used the windows partion manager to resize the windows partition and instal mint 14 kde in efi mode.

As per your specific questions, I am not sure having an efi partition is going to solve the "No bootable device found" problem you are having.
It sounds like you are trying to convert an existing legacy bios mode mint 14 install to boot in efi mode. Have you read viewtopic.php?f=46&t=97221
I have a small idea on how to convert a legacy bios install to efi mode. You will probably want the ubuntu boot repair utility and rEFInd and the advice of someone more sage than I.

Though if you really want a dual boot, I know that very well.

Return to “Installation & Boot”

Who is online

Users browsing this forum: rene and 12 guests