unwanted language

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
miormior
Level 1
Level 1
Posts: 3
Joined: Tue May 28, 2013 7:24 pm

unwanted language

Post by miormior »

Folks

This is driving me crazy. Mint has taken it upon itself to install menus in German and Chinese. Only one problem-- I do not speak German or Chinese. Take a look at the screenshot for my firewall-- how the heck am I supposed to do anything with this?

The worst thing is that I cannot change this. As you can see from languages.png, according to Mint I do not even have German and Chinese installed... and, of COURSE, English is the LAST language on the list...

Can ANYONE help me get to just having languages I understand? Italian and English???

Thanks
Attachments
language2.png
languages.png
User avatar
catweazel
Level 19
Level 19
Posts: 9885
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: unwanted language

Post by catweazel »

You have two options. Either state what version and flavour of Mint you're using, or learn Chinese.
"There is, ultimately, only one truth -- cogito, ergo sum -- everything else is an assumption." - Me, my swansong.
nomko

Re: unwanted language

Post by nomko »

catweazel wrote:You have two options. Either state what version and flavour of Mint you're using, or learn Chinese.
What a senseless and stupid response!!! if you have nothing sensible to say, then don't react!

@miormior:
I have the same issue when i remove all the english language packages and install the Dutch language packages. When i'm done it always looks like i also installed the Chinese language package which i have never done. And why should i? Dutch is my native tongue, not Chinese. And also like you, in the Language settings menu Chinese is visible but the Chinese language packages aren't installed. Why Mint is doing this, i don't know. I had this issue also when i was using Xubuntu for a while. My best guess is that it is a bug in the language settings manager somehow. I have never seen this issue fixed nor did i saw a solution for it.
User avatar
usbtux
Level 5
Level 5
Posts: 975
Joined: Tue Dec 28, 2010 10:37 am

Re: unwanted language

Post by usbtux »

Sorry as its not in english i cant see what your getting at, but you can use bleachbit to remove additional languages, its in the preferences.
http://goo.gl/DXKgM LinuxMint tutorials.
Running LinuxMint 17.3 Mate. Pepermint 6 & Manjaro 15.12 Capella XFCE
http://goo.gl/WFu0u Installing Mint - the screen cast videos.
linuxcounter #368850
Redondo
Level 1
Level 1
Posts: 41
Joined: Tue Dec 15, 2009 12:19 pm

Re: unwanted language

Post by Redondo »

usbtux wrote:Sorry as its not in english i cant see what your getting at, but you can use bleachbit to remove additional languages, its in the preferences.
I always do that first thing. In fact I unplug the internet right after it collects all needed time and location, so the extra languages don't get in. But I think the OP has other issues and I think it has something to do with running that firewall.
nomko

Re: unwanted language

Post by nomko »

Even with Bleachbit you still get Chinese under Language Settings. Trust me, i know this from experience and i'm using Bleachbit for a long time now. It's a bug in Gnome, that's my best guess.


I found some older postings and, it looks like it, a solution:
This is a post i wrote a year ago: http://forums.linuxmint.com/viewtopic.php?f=46&t=96287. So you know that this problem exists for a very long time.


http://forums.linuxmint.com/viewtopic.php?f=90&t=121907
http://forums.linuxmint.com/viewtopic.p ... 8&t=100050

Solution:
http://community.linuxmint.com/tutorial/view/1267
User avatar
catweazel
Level 19
Level 19
Posts: 9885
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: unwanted language

Post by catweazel »

nomko wrote:What a senseless and stupid response!!! if you have nothing sensible to say, then don't react!
Keep the board civil, and learn to recognise jokes. Failing that, don't read my posts.
"There is, ultimately, only one truth -- cogito, ergo sum -- everything else is an assumption." - Me, my swansong.
miormior
Level 1
Level 1
Posts: 3
Joined: Tue May 28, 2013 7:24 pm

Re: unwanted language

Post by miormior »

Folks, thanks for all your replies. Nomko, you supplied the answer, and for the sake of all those other (many, many all those other) MInt users having the same problem, I posted my own results at:

forums.linuxmint.com/viewtopic.php?f=190&t=100050

...The screwy language stuff is not the result of single programs functioning or not. It is the result of Mint following some hierarchy in determining where to go to get text for a given element (text, menu...) of a program. if your first langauge is Chinese, it will first look for a Chinese langauge file for the element; if it does not find a file in Chinese, it will go to your next indicated langauge. If that happens to be German, and there is a German-language file, it will display that particular element in German. What happens (if the GUI is incompletely translated?) is a mishmash of languages. As another example, here are two screenshots from Kdenlive. "1" (the browser insists on setting the first image after the second image... grrr...) is the langauge-preferences screen. It shows that the primary langauge was set (by default) to German, with the following three backups: Chinese, Italian, English. The result? Check out "2"!

After following the procedure outlined in the link above, I can report that my various programs now are all in a SINGLE language, and those langauges happen to be languages I can actually read!

And yes, catweazel, Chinese is on my list of langauges to learn... though it will be a while... I am currently working at Ibo and Yoruba (and I have Mint12 :wink: ).

Thanks again to all! Hope this helps others!
Attachments
1 LangPrefs
1 LangPrefs
2 UnFrigginBelievable
2 UnFrigginBelievable
Post Reply

Return to “Installation & Boot”