UEFI bios boot options and linux installation

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Mordicon
Level 1
Level 1
Posts: 2
Joined: Wed Jul 24, 2013 1:13 pm

UEFI bios boot options and linux installation

Post by Mordicon » Wed Jul 24, 2013 1:22 pm

I'm using a Asus a55vd-ns51 laptop, currently no OS is installed completely.

I have booted into the Mint demo installation from a USB thumb, and run the installation completely. I have run the installation and completely successfully, but once I restart to boot into my copied files for the second stage of my mint installation, it cannot locate the boot/installation.

Partition are setup as such.
/dev/sda1 EFI 98mb
/dev/sda2 ext4 200gb
/dev/sda3 swap 6gb

In my bios I have disable security boot, disabled fast boot, enabled CSM boot, and enabled PXO boot feature.

Their is an option to "create boot option" in my UEFI bois, but only allows me to input two fields "name", "path". I have tried to path to this installation by using "/dev/sda1", "/dev/sda2", "/sda", "/sda1", "sda2". "/dev/sda".

Prior to attempting this linux installation I had Windows 7 installed and running correctly, which I didn't have to select "create boot option", it simply populated as one of my boot options.

Any help on what I need to do to direct my boot to the second stage of the linux installation would be appreciated.

Mordicon
Level 1
Level 1
Posts: 2
Joined: Wed Jul 24, 2013 1:13 pm

Re: UEFI bios boot options and linux installation

Post by Mordicon » Wed Jul 24, 2013 4:51 pm

Changed to Mint 14 and it worked perfectly. It's just a problem with mint 15.

User avatar
bigj231
Level 5
Level 5
Posts: 790
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere
Contact:

Re: UEFI bios boot options and linux installation

Post by bigj231 » Wed Jul 24, 2013 4:56 pm

Did you install Mint via EFI or BIOS? It depends on how you launched the LiveUSB, and I believe it usually defaults to BIOS (at least it does on my ASUS K53E). If the BIOS is the same, press F12 when you boot then select the "EFI: usb0" or whatever it is. Not the "USB ***" option. Then installing however you want from there works fine.
You might want to have a look at this link. https://help.ubuntu.com/community/UEFI. The installation should be almost the same as their guide.

If you already installed Mint via BIOS and want to fix it to boot via EFI, that page does (did?) show a way to do that, but honestly, reinstalling is easier.

EDIT: Ninja'd by OP. never had that happen before. Glad you got it fixed. I'll leave the rest of my post for future reference.
Running on a 4-slot toaster @ 60Hz

Post Reply

Return to “Installation & Boot”