Page 1 of 1

unable to install Mint due EFI

Posted: Thu Aug 15, 2013 8:15 pm
by dex19dt
Well,
Some days ago I posted a thread here: http://forums.linuxmint.com/viewtopic.php?f=46&t=142095
I tried a lot of things since then but still am not able to install linux on my laptop.
I uninstalled openSuse to test Linux Mint and now I ended up with none.
My laptop has EFI, but the BIOS Legacy is enable and i CAN install damn Windows 7 how many times I want with no problem at all.
But when it comes to Linux (Mint or openSuse, I tried both soooo many times I dont care anymore...) it just dont work.
When I try a normal installation, ignoring EFI stuff it fails on the boot.
When I try it with EFI partition it raises that error that it can't install EFI on 'target' or something.
That's true even if I try to install Linux on the whole Hard Drive.
The fact is that, as I pointed out on the first thread, I had Linux installed on the same laptop since recently and was just ok.
So I dont understand wath the heck is going on.
If you could suggest anything for me to try I'll apreciate.
I want my Linux back.

Re: unable to install Mint due EFI

Posted: Fri Aug 16, 2013 6:29 am
by kc1di
have you read this wiki yet:
https://help.ubuntu.com/community/UEFI
it may be of help to you.

Re: unable to install Mint due EFI

Posted: Fri Aug 16, 2013 10:21 am
by srs5694
Consulting the wiki, as kc1di suggests, is worthwhile. Also, two more things if you still have problems:
  • Always be precise when reporting errors. "It fails on boot" and "can't install EFI on 'target' or something" are both so imprecise as to be useless for diagnostic purposes. Precisely what goes wrong when booting? (How far does the boot process get? Are there error messages?) An "or something" message is useless -- that "something" is likely to be critically important.
  • Running the [url=http://sourceforge.net/projects/bootinfoscript/]Boot Info Script[/url] from a live CD will generate a file called RESULTS.txt. Post that file here, either as a link or between code tags. Do not post the whole thing here without using code tags! The RESULTS.txt file contains lots of details about your system's current configuration, and knowing that current configuration is important for advising you about how to proceed to fix your problem.

Re: unable to install Mint due EFI

Posted: Fri Aug 16, 2013 9:03 pm
by Dngrsone
Are you using the 64-bit Mint desktop?

Re: unable to install Mint due EFI

Posted: Fri Aug 16, 2013 10:38 pm
by dex19dt
Thank you very much kc1di,
I finally made it.
I followed the instructions on the link and found out that I can actually boot the liveDVD in two modes (UEFI and Legacy, the former is the default)
When I booted in Legacy mode the installation went just fine.
Thank you and thanks to WharfRat that help me a lot on the previous post.

Re: unable to install Mint due EFI

Posted: Fri Aug 16, 2013 11:01 pm
by z1p101
I feel your pain.

I installed Mint 15 on a machine using efi boot a few weeks ago and there was a lot of trial and error involved. It was the only OS I was putting on the machine (no Windows) and I had to change some of the BIOS settings. This is what worked for me in the end.

1. Partition the drive the way you want (use GPT table) and install Mint using the regular installer.
2. Boot up using the live disk again and [url=http://superuser.com/questions/376470/how-to-reinstall-grub2-efi]follow these instructions.[/url]
3. Reboot normally and hope everything worked.

Re: unable to install Mint due EFI

Posted: Tue Aug 20, 2013 4:26 pm
by chieffun
The real interesting thing is, that ubuntu 13.04 uefi install just works like it should. You can boot the live stick with uefi, it automatically recognises your efi partition from win and populates it properly, and when you reboot, you can choose ubuntu from the uefi boot menu.

When you try this with Mint, you will end up in a perfect install without an uefi boot entry. When you try to create on with the live medium and efibootmgr, it simply does nothing and echo $? shows 1.

So to sum it up, there must be a bug in the mint installer scripts.

When you install for example arch linux and boot the live medium in uefi mode, then you can do the following in the chroot-env to get a proper grub2 uefi boot:

Code: Select all

# mkdir -p /boot/efi
# mount -t vfat /dev/sdXY /boot/efi
# modprobe dm-mod
# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=arch_grub --recheck
# grub-mkconfig -o /boot/grub/grub.cfg
So I really do not understand whats the problem here and in nearly all the distros around. A simple mount of the efi partiton and the right grub-install command and everything would work.