Black screen after live session starts / SLI NVIDIA

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
glubbar
Level 1
Level 1
Posts: 18
Joined: Wed Sep 21, 2011 10:49 am

Black screen after live session starts / SLI NVIDIA

Post by glubbar »

I'm trying to start a live usb disk of Mint 15 KDE on a new laptop with Chipset Intel HM77, 2 Nividia Geforce 670MX in SLI (thinking it might be related?).


Right before the login screen, my monitor goes black. I hear the fancy sound of KDE login screen in the background, I can set luminosity up and down through my keyboard, but nothing gives, there is no video feed at all.

I can't figure out how to edit live booting options and start

I have tried Mate and XFCE spins as well, same issue. I do notice a red "FAIL" at some point when the loading lines appear, but I can't read fast enough to see what it is.


Everything is fine with Kubuntu and Xubuntu though. Can't even try Mint,for now. :(
Lingula
Level 4
Level 4
Posts: 281
Joined: Tue Apr 23, 2013 12:47 pm

Re: Black screen after live session starts / SLI NVIDIA

Post by Lingula »

What boot options have you tried (such as nomodeset)?

Does your laptop have an external monitor port? If so, have you tried hooking it up?
User avatar
WharfRat
Level 21
Level 21
Posts: 13906
Joined: Thu Apr 07, 2011 8:15 pm

Re: Black screen after live session starts / SLI NVIDIA

Post by WharfRat »

glubbar.

When the countdown starts press the space bar, then the tab key then enter the kernel option e.g., nomodeset then hit enter to continue.
ImageImage
glubbar
Level 1
Level 1
Posts: 18
Joined: Wed Sep 21, 2011 10:49 am

Re: Black screen after live session starts / SLI NVIDIA

Post by glubbar »

Thanks for your replies guys.

I don't have a VGA output, only HDMI and I don't have any cables available for that right now. Having to resort to a second monitor is a strange thing though, it shouldn't happen.


I don't see any countdown at all. Whenever I hit enter for "Run the live session" on my USB stick, it starts immediately.
The only thing I could do is edit the command line with TAB, but I don't see how that would help.
User avatar
WharfRat
Level 21
Level 21
Posts: 13906
Joined: Thu Apr 07, 2011 8:15 pm

Re: Black screen after live session starts / SLI NVIDIA

Post by WharfRat »

glubbar wrote:Thanks for your replies guys.

I don't have a VGA output, only HDMI and I don't have any cables available for that right now. Having to resort to a second monitor is a strange thing though, it shouldn't happen.


I don't see any countdown at all. Whenever I hit enter for "Run the live session" on my USB stick, it starts immediately.
The only thing I could do is edit the command line with TAB, but I don't see how that would help.
When I boot a live cd/dvd the initial screen comes up and a line states that mint will start or boot, something like that, in 9,8,7 etc. At that point I can hit the space bar and a menu comes up with one of the options to start in safe and also mentions hitting the tab key to change the boot line.

This is the mate version, but I don't think the the kde version would be any different.
ImageImage
glubbar
Level 1
Level 1
Posts: 18
Joined: Wed Sep 21, 2011 10:49 am

Re: Black screen after live session starts / SLI NVIDIA

Post by glubbar »

The thing is, I don't have a DVD drive, only USB.

Whenever I load the live image, I don't see any countdown at all.

It's most likely a driver issue, but this only happens with Mint, all Ubuntu spins work fine... :/

I'm out of ideas.
Protheus
Level 1
Level 1
Posts: 13
Joined: Sat Aug 17, 2013 12:53 pm

Re: Black screen after live session starts / SLI NVIDIA

Post by Protheus »

Had the same problems with booting the live cd and after the install of LMDE. Live cd refused to boot, black screen... Just a short message about drm and nouveau, but too fast to realize.

I've edited the bootoption of the live cd with 'nouveau.modeset=0' at the end right behind

Code: Select all

quiet splash -- nouveau.modeset=0
So i was able to boot the live cd and install it. The same after the installation in the grub2 menu cause it refused again to boot. After the system was up and running i've installed the nvidia-glx and kicked out the dumb nouveau driver. Everything is fine now.
glubbar
Level 1
Level 1
Posts: 18
Joined: Wed Sep 21, 2011 10:49 am

Re: Black screen after live session starts / SLI NVIDIA

Post by glubbar »

Thanks guys, and especially thank you Protheus! This worked!

This issue is now solved for me!
Post Reply

Return to “Installation & Boot”