Trying to install EFI LM16, existing /home partition from 15

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
mazzy
Level 1
Level 1
Posts: 7
Joined: Tue Jun 28, 2011 8:10 pm

Trying to install EFI LM16, existing /home partition from 15

Post by mazzy »

So I had a working install of LM15, I am attempting to just reinstall Mint 16 and leave /home intact. The previous system was installed non-EFI, but the new Live CD will not boot for me non-efi (I can get the specific error if necessary...) and I think the installer just goes on however the CD is booted ? (No clue if that's correct). So I manually created a fat32 partition and resized my boot partition so I had a drive partitioned like this (dump from boot-repair here: http://paste.ubuntu.com/6525711/ notice the part about partition 94 and the notice on the EFI partition)

Code: Select all

Device Boot      Start         End      Blocks   Id  System
/dev/sda1          411648     1994751      791552   83  Linux
/dev/sda2         2002942   293046271   145521665    5  Extended
/dev/sda3   *        2048      411647      204800    b  W95 FAT32
/dev/sda5         2002944    17625087     7811072   82  Linux swap / Solaris
/dev/sda6        17627136   259565567   120969216   83  Linux
/dev/sda7       259567616   293046271    16739328   83  Linux
Still no dice at this point, so I deleted the sda1 and sda3 partitions, left the space unallocated, created an EFI partition in the installer and /boot, and reinstalled. Still same error messages in the boot-repair dump: http://paste.ubuntu.com/6525865/

I don't know if there is a way to get that efi partition to start at sector 0 instead of 2048, but it seems like that might be part of the issue. I also found a post here about the first error: http://sourceforge.net/p/bootinfoscript/discussion/905692/thread/c5257932/
I think I found the issue. Creating mbr boot from Ubuntu Saucy 13.10, causes the odd partition#'s. Creating mbr boot from Ubuntu Precise 12.04, everything is normal.

either a change in grub or how the mbr gets written.
There is no potential solution on that page.

So I suppose at this point, I can copy /home and just completely wipe the drive and start fresh but that kind of defeats the purpose of partitioning in this way, given there is no easy upgrade path between releases of Mint.

Any suggestions? I have never installed efi system before so maybe I'm just doing something stupid, hopefully :o
Bradley
Level 1
Level 1
Posts: 6
Joined: Thu Dec 05, 2013 2:51 pm

Re: Trying to install EFI LM16, existing /home partition fro

Post by Bradley »

I don't know if this will help, but I will tell how I have had to install both LM 15 and 16 Cinnamon with a MB that is only EFI. I used the LM live cd on a usb stick. After booting into the live usb and going through the install, the OS cannot be found because of the EFI only MB. I tried to use some of the tips in the release notes found at [url]http://linuxmint.com/rel_petra_mate.php[/url] without success. I then went to my fallback which I had used when I installed LM 15. I downloaded and ran Boot Repair from https://help.ubuntu.com/community/Boot-Repair from a usb stick using LiLiUSB. I used recommended settings as they suggest. After plugging in the stick and rebooting and choosing usb, it takes a few minutes to go through and you have to type some commands. After another reboot, the system comes up with a menu for Ubuntu and something like Ubuntu (Advanced settings). If you do nothing, the first entry is automatically chosen and you move on to the login screen and into LM 16.

I believe you may be able to make Boot Repair skip the screen with the 2 choices, but I believe they advise against it. Also, it doesn't take much time for the automatic selection to take place. As I recall, when I did this on LM 15, the selections said Linux Mint instead of Ubuntu. I may not be correct on that and it doesn't matter because you end up in Linux Mint anyway.

I hope this helps with the boot part of your issue. I have thought of trying to keep my home partition from one install to the next, but never have tried it. I have just backed up my data over the network and along with files (music, docs, etc.) saved my .vnc and .ssh folders so that I would not have to remake them. Then I copied them back after the new install. This worked fine for me and my ssh authorized keys were accepted with no problem. I only had to tell putty to accept the new ssh server info since that had changed. The .vnc was not necessary on this install as it now seems to know that there needs to be a gnome fallback for Cinnamon desktops when tightvnc server is run.
srs5694
Level 6
Level 6
Posts: 1389
Joined: Mon Feb 27, 2012 1:42 pm

Re: Trying to install EFI LM16, existing /home partition fro

Post by srs5694 »

mazzy wrote:So I had a working install of LM15, I am attempting to just reinstall Mint 16 and leave /home intact. The previous system was installed non-EFI, but the new Live CD will not boot for me non-efi (I can get the specific error if necessary...) and I think the installer just goes on however the CD is booted ?
Yes, the installer tries to install for whatever boot mode (BIOS/CSM/legacy vs. EFI/UEFI) was used to boot the installer. There should be a way to force a BIOS/CSM/legacy-mode boot of your installation medium, but the method is likely to depend on your motherboard. Sometimes there are multiple boot options in a built-in boot manager that you can access by pressing Esc or a function key; other times you may need to change options in the firmware's setup utility.

From your Boot Repair output:
mazzy wrote:

Code: Select all

Disk /dev/sda: 150.0 GB, 150039945216 bytes
255 heads, 63 sectors/track, 18241 cylinders, total 293046768 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1    *          2,048       292,863       290,816  83 Linux
/dev/sda2           2,002,942   293,046,271   291,043,330   5 Extended
The presence of an extended partition indicates that you've got a [url=http://en.wikipedia.org/wiki/Master_boot_record]Master Boot Record (MBR)[/url] partition table. This makes an EFI-mode installation tricky or impossible. At the very least, you'll need to use fdisk to change the type code of your /dev/sda1 from 0x83 to 0xEF -- this is the code for an [url=http://en.wikipedia.org/wiki/EFI_System_partition]EFI System Partition (ESP)[/url] on an MBR disk. A better solution (and one that may be required, depending on your motherboard and the level of support in the Mint installer for EFI/MBR installations) is to use GPT fdisk (gdisk) to convert the disk from MBR to [url=http://en.wikipedia.org/wiki/GUID_Partition_Table]GUID Partition Table (GPT)[/url] form. (See [url=http://www.rodsbooks.com/gdisk/mbr2gpt.html]here[/url] for detailed instructions.) If you do this, you'll need to change the type code of /dev/sda1 from 8300 to EF00.
I don't know if there is a way to get that efi partition to start at sector 0 instead of 2048, but it seems like that might be part of the issue.
No, that's both impossible and not the cause of the problem. Sector 0 is the MBR, which is where an MBR-partitioned disk's partition table resides, so if you were to start the first partition at sector 0, anything that overwrote the partition's first sector (such as creating a filesystem) would wipe out the partition table. This would be a bad thing! On a GPT disk, sectors 0-33 are normally occupied, so sector 34 is the earliest one that can possibly be used. As a practical matter, sector 2048 is the default first sector used by most tools today because that helps with performance issues on some types of disks (certain types of RAID array and SSDs). (Modern Advanced Format disks require 8-sector alignment, which the 2048-sector alignment satisfies. If you're not using RAID or SSD, you can use advanced partitioning tool options to begin the first sector of the first partition on sector 40, but it's usually not worth the effort -- the wasted space by starting the first partition at sector 2048 is so minuscule that it's not worth worrying about.)
I think I found the issue. Creating mbr boot from Ubuntu Saucy 13.10, causes the odd partition#'s. Creating mbr boot from Ubuntu Precise 12.04, everything is normal.

either a change in grub or how the mbr gets written.
MBRs contain two things: boot code and a partition table. They're created by different tools. It's unclear if you mean the MBR partition table or the MBR boot code. In any event, as I said, you should either find a way to force a BIOS-mode installation or switch to GPT and do an EFI-mode installation.
Any suggestions? I have never installed efi system before so maybe I'm just doing something stupid, hopefully :o
You may want to read my Web page on EFI-mode installations:

http://www.rodsbooks.com/linux-uefi/
Post Reply

Return to “Installation & Boot”