BIOS only boots Linux Mint now [SOLVED]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Xalaber
Level 1
Level 1
Posts: 7
Joined: Tue Dec 10, 2013 12:18 am

BIOS only boots Linux Mint now [SOLVED]

Post by Xalaber »

Relevant Specs:
Windows XP Professional 32 bit is on my first hard drive C:\
Linux Mint 16 Cinnamon 32 bit is on my third hard drive M:\ (I formatted it and changed the letter first before installing and partitioning)
I have had Windows XP first for I dont know how long, and just recently and successfully installed Linux Mint.
I repeat: I have windows xp and linux mint on 2 separate hard drives.

I am having a problem and been searching all over the internet (with Google), but i tried the solutions that seem to fit my problem with no luck.
My problem is simple, I think I know whats caused it, but I don't know how to fix it.
First of all, I tried 5 times to install Linux Mint and was successful after the 5th time. But that wasn't the problem.
(This is where I think I made a mistake) I partitioned my hard drive correctly at the 5th time with a good tutorial but what I failed to realize was the boot loader thingy. So i just left it as default. So after hours of learning Linux Mint, I decide to do something in Windows. I restart my computer and find out that it goes into Linux Mint automatically. So (like a newb) my first instinct was to go into the boot.ini file and check and see what happened. But after having an epiphany I tried and tried to see how I can get windows back onto the GRUB boot loader thingy with no success. So now I am stuck with 2 options, both of which I am unsure how to accomplish. My first choice could be to add Windows to GRUB boot loader (Don't know what to call it) and then set windows back to default. Or my second choice is to go back and make my computer use Window's boot.ini and make Windows the default OS to be booted up.

Anyways, my goal here is to have a dual-boot computer. But I think I messed up when leaving the boot loader device as default.


I hope that's enough information. If you need any more info, please ask.
Last edited by Xalaber on Wed Dec 11, 2013 11:53 pm, edited 1 time in total.
NuxNubkins
Level 1
Level 1
Posts: 36
Joined: Fri Oct 04, 2013 5:51 pm

Re: BIOS only boots Linux Mint now

Post by NuxNubkins »

Do you recall which disk you installed Grub to? If Windows is on your primary HD, it likely is /dev/sda in Linux's partitioning manager. If you say you installed Mint to your third hard drive, I assume it was installed to /dev/sdc? So, you put GRUB on /dev/sda, and BIOS is pointing to that disk to begin booting?
User avatar
Pierre
Level 20
Level 20
Posts: 10741
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: BIOS only boots Linux Mint now

Post by Pierre »

Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.
Xalaber
Level 1
Level 1
Posts: 7
Joined: Tue Dec 10, 2013 12:18 am

Re: BIOS only boots Linux Mint now

Post by Xalaber »

@NuxBubkins
I'm pretty sure that it was /dev/sda. Later I tried to go into boot menu from BIOS and try to boot from all 3 hard drives, one at a time of course. But it seems only the first one works and it boots into linux mint. Even the third one doesn't boot. I will try what Pierre said... but if it doesn't work, then I will be 100% clueless.
@Pierre
Thanks I will give it a try. I will let you know if it works.

EDIT: I cant figure out the password to the Boot Repair. Every time I boot from my burned DVD, eventually it asks me to type in the password for LInux Mint 16 'Petra'
User avatar
gold_finger
Level 9
Level 9
Posts: 2885
Joined: Mon Mar 11, 2013 11:39 pm

Re: BIOS only boots Linux Mint now

Post by gold_finger »

Just in case it's a simple fix, try this before the boot repair cd. Open a terminal (Menu -> Accessories -> Terminal), copy/paste the following into it and hit enter:

Code: Select all

sudo os-prober
Did it find Windows XP?

Now try:

Code: Select all

sudo update-grub
Reboot computer and see if you have the choice of Win & Mint.

If no luck, open GParted and post a screenshot for each drive -- can select each drive from drop-down in upper-right corner of GParted window.
-- Open GParted: Menu -> Administration (or System) -> GParted
-- Take Screenshot: "PrtScn" key, or Menu -> Accessories -> Screenshot
-- When taking screenshot, use option to only capture active window instead of whole screen.
-- To post pics, use "Upload attachment" tab located beneath where you type on forum interface.

Also post output of this command listing partitions and their formatting:

Code: Select all

sudo parted -l
**Note: if typing command, that is a lowercase "L" at the end.

To post the output of command, hit the "Code" button on forum interface and paste the output between the two code blocks.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.
User avatar
gold_finger
Level 9
Level 9
Posts: 2885
Joined: Mon Mar 11, 2013 11:39 pm

Re: BIOS only boots Linux Mint now

Post by gold_finger »

Xalaber wrote:I'm pretty sure that it was /dev/sda. Later I tried to go into boot menu from BIOS and try to boot from all 3 hard drives, one at a time of course. But it seems only the first one works and it boots into linux mint. Even the third one doesn't boot. I will try what Pierre said... but if it doesn't work, then I will be 100% clueless.
Forgot to explain this in above post. If you indeed installed Mint on second hard drive and didn't purposely point the grub bootloader to that second drive, then by default it ended up on first drive (/dev/sda). That's also where Windows is and where it boots from (according to what you said before). No idea what applies to 3rd drive -- you only referred to 2 hard drives in initial post.

Essentially, if both the Windows and Linux operating systems have their boot loaders set for /dev/sda, then the BIOS won't be able to boot into the other drives -- there is nothing on them to start the boot process with.
Xalaber wrote:Every time I boot from my burned DVD, eventually it asks me to type in the password for LInux Mint 16 'Petra'
If you're being asked for password on live DVD, either leave it blank and hit enter or just wait 10 seconds and it will load the system on its own. (There is no password set for it.)
Xalaber wrote:I cant figure out the password to the Boot Repair.
If running from a separate CD with Boot Repair on it, same probably applies -- no password.

If you are running Boot Repair from your installed system, just enter your password -- the one you set for yourself when installing the system.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.
Xalaber
Level 1
Level 1
Posts: 7
Joined: Tue Dec 10, 2013 12:18 am

Re: BIOS only boots Linux Mint now

Post by Xalaber »

@gold_finger

Code: Select all

sudo os-prober
I tried that but all I got was:

Code: Select all

ERROR: nvidia: wrong # of devices in RAID set "nvidia_edciagfb-0" [1/2] on /dev/sda
ERROR: keeping degraded mirror set "nvidia_edciagfb"
  No volume groups found
No idea what applies to 3rd drive
I have Windows OS on the first drive (C drive) but I also have Windows software, programs, applications, documents, etc. on both the C and D drives. However I only have Linux on the third drive.

Also I assumed each possibility you listed along with researching with no luck. The very first thing I did was this: It booted up from the DVD, I waited almost 3 minutes until I realized by pressing the up arrow it shows a login window. I tried typing in my password but no luck so far. I tried pressing Enter and waiting but it says login password failed. (At this point, anything goes for me) I try typing in my username and hoping it would ask for my password after (Since all I see is a "no avatar" picture, and only one box with I thought I had to type in a password.) Then I tried typing in "mint" (i was researching the problem and thought that it also applied to this version) but no luck either. After all that, I rebooted my computer again, and edited my previous reply:
EDIT: I cant figure out the password to the Boot Repair. Every time I boot from my burned DVD, eventually it asks me to type in the password for LInux Mint 16 'Petra'
If no luck, open GParted and post a screenshot for each drive -- can select each drive from drop-down in upper-right corner of GParted window.
-- Open GParted: Menu -> Administration (or System) -> GParted
-- Take Screenshot: "PrtScn" key, or Menu -> Accessories -> Screenshot
-- When taking screenshot, use option to only capture active window instead of whole screen.
-- To post pics, use "Upload attachment" tab located beneath where you type on forum interface.
I will try that, however I have a windows keyboard, I do not have a Macintosh keyboard so I am going to try 1 of the 3 keys or 2 of the 3 keys that I do have.
Xalaber
Level 1
Level 1
Posts: 7
Joined: Tue Dec 10, 2013 12:18 am

Re: BIOS only boots Linux Mint now

Post by Xalaber »

It seems the Gparted is taking forever to detect device.
Also I did get into the boot-repair by making me automatically log in before I rebooted the computer.
But I clicked recommended and it did not fix the problem.
Here is what I got:
[url]http://paste.ubuntu.com/6558314[/url]
wayne128
Level 10
Level 10
Posts: 3412
Joined: Tue Jul 13, 2010 12:15 am

Re: BIOS only boots Linux Mint now

Post by wayne128 »

As boot repair has done its job... now you have grub2 on mbr of /dev/sda and /dev/sdc

yet you cannot boot into windows?


I think of two things you can do:

1. use another bootable cd/usb iso that is specialised in repairing.

I use RIPLinux for quite some time, it can boot computer and allow you to select which drive and partition to boot, at least I could use it to boot into Windows using this way, so that I could determine if I need to repair Windows partition.

this requires you to be comfortable to learn a new tool, RIPlinux.

2. Repair WinXP boot:

unplug the third drive, making Linux OS out of the picture.
Then, use WinXP CD, let it run repair and return WinXP to bootable conditions.


After that, rethink about how to install Linux on third drive.

One such method is:
Isolate WinXP drive and Linux OS drive (make Windows drives and Linux drive totally separate.

select OS to boot via bios setting
less convenience in OS selection, but system much more reliable because two OSes are independent on each other boot loader!!

to do this:
a. unplug all Windows drives
b. install on Linux drive ( the third drive is now the only hard disk on the system)
c. install boot loader as default, since there is only one drive, it will install to mbr, unless you choose to be different.
d. test that linux will boot well a few times

e. plug back the two windows drives

then, to boot computer and choose the OS, you rely on bios setting

if you wish to run XP most of the time, set bios to make XP drive as first boot drive.


if you wish to run Linux most of the time, set bios to select Linux drive, so each time you reboot it will boot Linux, on occasion when you need to run XP, reboot, go bios, put XP drive as first boot drive, and you are on XP.
Xalaber
Level 1
Level 1
Posts: 7
Joined: Tue Dec 10, 2013 12:18 am

Re: BIOS only boots Linux Mint now

Post by Xalaber »

@wayne128
Thanks for the tip, it looks like it might work but I think I figured it out. I had to go into Boot-Repair and customize the settings a little, after 2 times (The first time still didnt work, but the second I made it work) I managed to get a decent dual-boot. It may not be what I had in mind, but at least it works now. That was my goal after all.
So anyways now all I need to do to get to Linux is press F8 and boot from the third hard drive. If I want to boot from Windows XP, I just let it boot normally.
Thanks so much for all of your help :D :D
Post Reply

Return to “Installation & Boot”