[Solved] Issues with login screen after update to LM 16

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
werder
Level 1
Level 1
Posts: 5
Joined: Sun Aug 04, 2013 3:52 pm

[Solved] Issues with login screen after update to LM 16

Post by werder »

What I Did

I am running a dual boot system with windows and Linux Mint Cinnamon. I recently upgraded to 16 "in place" using the following commands from [url]http://www.tecmint.com/upgrade-linux-mint-15-olivia-to-linux-mint-16-petra/[/url]:

Code: Select all

$ sudo sed -i 's/raring/saucy/' /etc/apt/sources.list
$ sudo sed -i 's/olivia/petra/' /etc/apt/sources.list
$ sudo sed -i 's/raring/saucy/' /etc/apt/sources.list.d/official-package-repositories.list
$ sudo sed -i 's/olivia/petra/' /etc/apt/sources.list.d/official-package-repositories.list

Code: Select all

$ sudo apt-get update && sudo apt-get dist-upgrade
$ sudo apt-get upgrade
What Went Wrong

Everything seemed to go ok, but when I rebooted into mint, instead of the login screen I received an error message saying, "There was an error loading the theme blackandblue". The rest of the screen is blank. I can click [OK] on the error message and the message disappears, but the screen remains black. I can still see and move the cursor. I am writing now from the windows partition.

What I think I know

I was not running the default login theme in LM 15, and so I think that my login-theme ("blackandblue") was not included in LM 16. It seems to me that I just need a way to get past the login screen and then I will be able to change the login theme to something that does exist in LM 16.

My Questions

1. Am I right about what the problem is? If not, what is the problem(s)?
2. Am I on the right track towards fixing the problem? If so, is there a way to get past the login screen?
3. If not, is there any way to get mint up and running again?

Thanks in advance.
Last edited by werder on Thu Dec 12, 2013 7:59 pm, edited 1 time in total.
Jerry
Level 3
Level 3
Posts: 111
Joined: Fri Dec 28, 2012 11:52 pm
Location: Canada

Re: Issues with login screen after update to LM 16

Post by Jerry »

i cant help you much. sorry, but from what i have been reading around the forum here is that there are a number of people who seem to report that mint 16 has some issues.
from what i see in your apt-get commands, those are correct and that would be the normal method of installing/upgrading/syncing repos to your current distro.

I had the same problem a couple of days ago where I experienced the same thing you have. a black screen and still able to see the curser. mind you my problem had a different origin than your did. however, after i went via startx, did a sudo apt-get update/dist-upgrade/upgrade, just like you have and then immediatly that is when i experienced what you have now. black sceen and able to see the cursor.

I couldnt get much help here on the forums as i wasnt able to solicate any help. bear in mind that this forum is not as big as the ubuntu forums where more people are available to help you.

i think that there is something wrong with mint 16. if you dont wind up getting your problem fixed, remember what the blog says about the necessity or not so necessity of upgrading. as for me, i am sticking it with 15 until this problem and a few others that i have read about in this forum, are resolved.
May you have good thermals.
werder
Level 1
Level 1
Posts: 5
Joined: Sun Aug 04, 2013 3:52 pm

Re: Issues with login screen after update to LM 16

Post by werder »

Ok, thanks for your input Jerry. I will continue to try to work around the problem and will post if I have any success.
werder
Level 1
Level 1
Posts: 5
Joined: Sun Aug 04, 2013 3:52 pm

Re: [Solved] Issues with login screen after update to LM 16

Post by werder »

[*Success!!

Here is what I did:

*From grub, I started mint (It read "Ubuntu") in recovery mode.
*I chose the root shell prompt option in recovery mode.
*I made the file system read-write with

Code: Select all

mount -o remount,rw /
*I used cd and ls to navigate to the directory where the login themes are stored, which happens to be /usr/share/mdm/html-themes
*I changed the name of the directory "Clouds" to "BlackNBlue" using mv. (I knew that BlackNBlue was the name of my previous login theme because of the original error message)
*I then booted into Mint 16.

I will change the name of the current theme back to Clouds and change the login theme to something that does exist. Hopefully this might help someone.

Cheers
albin79
Level 1
Level 1
Posts: 1
Joined: Sat Mar 01, 2014 10:29 pm

Re: [Solved] Issues with login screen after update to LM 16

Post by albin79 »

This has just happened to me after updating 15 to 16. Could anyone post out exact terminal instructions to change theme name in dir.... it's my first month using Linux. I can get to terminal prompt after ctrl alt F1 but lost from there to get to the file I need to change to "clouds".

Thanks
Post Reply

Return to “Installation & Boot”