[WorkAround] Boot Fails, confusion between hd/sd

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
spaceboy
Level 1
Level 1
Posts: 34
Joined: Wed Mar 12, 2008 6:16 pm

[WorkAround] Boot Fails, confusion between hd/sd

Postby spaceboy » Sat Jul 26, 2008 3:51 pm

(I'm posting this for reference for others, and correction and cautions are requested, as I am a linux newbie)

{ EDIT: This is Elyssa 5-r1 }

I installed Mint as a triple boot (XP and Ubuntu also), but it would stall out, and after about 5 minutes, drop down to the 'initramfs' prompt.

After reading a thread here on the subject, I determined that Mint had not picked up my drive as IDE, but instead as SATA. I received the following error message right before I got the initramfs prompt (paraphrased):

Code: Select all

check root= bootarg cat /proc/cmdline or missing modules, devices: cat /proc/modules ls /dev

ALERT!  /dev/hda9 does not exist.  Dropping to a shell!

BusyBox v1.1.3 ................

The thread I read suggested that I try and put in the UUID in the menu.lst as a workaround, but I decided to try something else first.

Since Mint picked up my drive as 'sd', I simply changed the device label from hda9 to sda9 in the menu.lst, and it booted right up! No need to hassle with the UUID, apparently.

...........however, if there are other ramifications of this that might be bad, then please let me know, as I'm not exactly a linux expert! :)

User avatar
merlwiz79
Level 10
Level 10
Posts: 3476
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: [WorkAround] Boot Fails, confusion between hd/sd

Postby merlwiz79 » Sat Jul 26, 2008 4:02 pm

The sda is correct ubuntu moved from the old ide drivers to a newer set that makes it sda.
The reason for UUID is for SATA drives.
If you aren't using SATA it should be no problem.
Image


Return to “Installation & Boot”

Who is online

Users browsing this forum: dipstick and 3 guests