Boots to Busybox and not to gui desktop

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Fri Aug 01, 2008 7:59 pm

Boots to Busybox and not to gui desktop

Postby tmcarson1 » Fri Aug 01, 2008 8:02 pm

I just installed Linuxmint, not 5 but 4, Elyssa I think it is called.

Upon trying to boot, it takes a long time, stays at the startup screen, then it goes to a black screen with a (initramfs) prompt.

It also says this:
Busybox Busybox v1.1.3 (Debian 1:1.1.3-5ubuntu12) Built-in shell (ash)

I have no idea what this is or how to get the normal gui desktop to start up.

Any thoughts are appreciated.

Level 1
Level 1
Posts: 1
Joined: Sat Aug 02, 2008 3:19 am

Re: Boots to Busybox and not to gui desktop

Postby AnarchyCow » Sat Aug 02, 2008 3:41 am

I had this same exact problem. Let me guess... =]
You have a ATA (IDE) HDD, along with a SATA HDD...
Anyway, the problem with this is that when you install, a lot of times, the installer seems to get mixed up with sda / sdb and will assign the wrong label to the wrong hard drive.
Also, I'm guessing when you tried booting after the first time, you had to change (hd1,#) to (hd0,#) in Grub.
Here's how I fixed it.
First of all, you need to know the location of your LinuxMint hard drive partition (mine is /dev/sda2). Now, if you are on the live cd, just mount the LinuxMint partition, and in a terminal type:

Code: Select all

sudo gedit /.../boot/grub/menu.lst

The "..." as written in the command should be where you mounted the LinuxMint partition.
Now, take a look down the page, and look for something that looks like this (Should be toward the bottom)

Code: Select all

title      Linux Mint
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.24-19-generic root=/dev/sdb2 ro quiet splash
initrd      /boot/initrd.img-2.6.24-19-generic

Okay, so basically, the problem here is, that once the bootloader directs where to set as root (hd0,1) it looks for the Kernel in /dev/sdb2 in the directory /boot. But, (hd0,1) is not sdb2, it's sda2. So, once you start to load the Kernel, it's not being located correctly.
So, you will need to change the lines of text...

I'm going to type out a short summary (considering that you are like me with a confusion between sda and sdb.)
Heres how to figure out what, on that third line, should come after "root="...
Take the line above that.
If you have (hd0,#), then it should be set as "root=/dev/sda[#+1]" (for the "[#+1]" simply add 1 to the # in the (hd0,#) area and slap it on the end of sda. An example for what it above would be. (hd0,1) which means "root=/dev/sda2" because 1+1 is 2 =P
So, the corrected version of that text should be...

Code: Select all

title      Linux Mint
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.24-19-generic root=/dev/sda2 ro quiet splash
initrd      /boot/initrd.img-2.6.24-19-generic

The third line, starting with "kernel" is the ONLY line that I changed, just to read "root=/dev/sda2" instead of "root=/dev/sdb2"...
Let me know how it works out...


Re: Boots to Busybox and not to gui desktop

Postby NewMexicoMark » Sun Aug 03, 2008 5:03 am

I'm having the same problem. (My Compaq Presario V2565 laptop boots to the Elyssa live CD just fine, but after install only boots to "busybox" from the hdd.) FWIW, the HDD is not the original 80 GB HDD, but a newer PATA 120 GB drive. However, I installed another Linux distro just fine. However, after reading some excellent reviews on Mint, I wanted to give it a serious evaluation. While in the live CD, I was very impressed. It handled the Broadcom wireless (and automated fwcutter) just fine. It had some issues going to the proprietary ATI driver, but I attributed that to Live CD weirdness, and was going to work that issue from the installed version. Overall, it looks very good, but I'll need to get past this boot issue.

In my case, I only have one internal PATA HDD. fdisk -l (from the Live CD boot) shows the following:

Device Boot Start End Blocks ID System
/dev/hda1 * 1 14169 113812461 83 Linux
/dev/hda2 14170 14593 3405780 5 Extended
/dev/hda5 14170 14593 3405748+ 82 Linux swap / Solaris

The default boot (from /dev/hda1/boot/grub/menu.lst) is as follows:

title Linux Mint, kernel 2.6.24-16-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.24-16-generic root=/dev/hda1 ro quiet spash
initrd /boot/initrd.img-2.6.24-16-generic

In order to check the .../boot/grub/menu.lst file from the live CD, I mounted /dev/hda1, so the menu.lst file looks right. Any suggestions on where to go from here?



Re: Boots to Busybox and not to gui desktop

Postby NewMexicoMark » Sun Aug 03, 2008 5:57 am


As I was troubleshooting, I noticed that in busybox ls /dev/, there were no hd* devices, only sd*. I modified the boot command from hda1 to sda1, and it booted. This was for a Compaq Presario V2565US laptop with PATA HDD.

Maybe someone will find this useful.

Return to “Installation & Boot”