initramfs tools - tty: job control turned off

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 3
Level 3
Posts: 117
Joined: Sun Sep 02, 2007 4:52 am

initramfs tools - tty: job control turned off

Postby WinXpNewb » Fri Aug 15, 2008 11:24 pm


*boots into BusyBox

Initramfs tools - tty: job control turned off [insert random number] sdc: assuming drive cache write through


Mint Celena


No idea. I've been trying to tackle how to properly backup all my files on both Mint and Xp (separate hds) so I could reformat both of them when I wanted to access a file in Mint from Xp using Ext2ifs and noticed that the drive was blank. Booted into Mint and got the error. No hardware was changed and this computer used to run Mint well.

Solutions tried:

1) Change the booting instructions in BIOS so that the booting instructions would boot from hd first per the instructions here. Didn't have a blank floppy handy so I thought doing it would be the same. Besides, it was the last setting i remember changing.

2) Had no idea what grub or menu.lst is so I followed some instructions I read somewhere and pressed escape while in the grub view. Got into the text menu thing and tried changing the numbers in the HD (#,#) and it just failed to boot. Tried adding a line about ramdisk=8192 after the kernel texts because I couldn't spot the "boot =" words and it didn't work and tried to see if the problem was the drive letter like the post here but the kernel says sda1 when I checked and I only have two hd so I assumed the Linux one was in sda1 since according to the post it was HD (#,#+1) and I had HD (0,0)

3) Booting into the pc with usb flash drive removed.

Things I didnn't know how to do so I haven't been able to try them

Many of the instructions write mounting, chrooting and stuff like but I don't know how to do them.

Some things I noticed though...

One of the posts writes that they could access their files after they mounted and when I mount the hd from livecd via gparted, I couldn't access any of the files and it was all Recycled + some gibberish locked files.

Solution 1:

Anyways, I tried manually booting through grub (using commands) which showed successful, except when kernel was booted. So I figured maybe the kernel was screwed up somehow. After verifying I could mount the drive successfully all the time I decided to just copy the kernel off the live cd and then proceeded to boot from that kernel (which would be the older one in my grub)

Problem: No idea how to even begin with this one.

Solution 2:

Alright! It was the same issue as in one of the previous threads, where the GRUB was pointing here: root = /by - uid/[whole bunch of hex code] rather than: root = /dev/hda1 just edited the line to show /dev/hda1

Problem: No idea if there's even a hex code or not but it didn't look that way when i checked it in the escape in grub to text view thing which I'm hoping is menu.1st

Solution 3:

I just solved my problem. menu.1st pointed to 0,2 instead of 0,1 and menu.1st has a line called: boot by uuid, and the following number pointed to the uuid of mz swap partition. I simply had to change that number to the one of the boot partition

Problem: As someone commented, they didn't saw any boot by uuid and I didn't either.

Solution 4:

Killed X and ran fsck on that partition

Problem: I have no idea how to kill X or run fsck.

Solution 5:

If yo have multiple drives, try reaarranging them on your mobo.

Problem: I haven't tried this yet for fear that I wouldn't be able to understand the problem so I'm leaving this for last. The poster had 3 drives and it happened during installation and I used to not have problems installing Mint and using it before.

Solution 6:

With one more day of fiddeling around I finally found the solution to my problem. As the suggested in step 5 did I copy the .config and load it when running make menuconfig. As all the harddrives and items like that worked before I compiled the new kernel, I assumed that the .config had all the SATA support it needed. It did not. After a bit of fiddeling about, I got into the Device Driver -> Serial ATA folder and discovered that the ATA Device support was not included. I included this and the nVidia SATA support, and upon recompiling of the kernel, I could finally boot again

Problem: Sounds like doing this without knowledge could break the OS so again I'm just saving this for last or hoping someone can explain this to me. I don't even understand what SATA drives are or compiling kernels.

Solution 7:

It's fairly common, apparently. Basically, the kernel needs a ramdisk bigger than 4096 at boot. Setting it in grub.conf or lilo.conf to 8192 apparently fixes the problem.

Problem: If you are stuck at BusyBox just boot via LiveCD, follow the documentations to mount your root partition, boot partition, and proc, then chroot and edit the conf. System should then boot

I just have no idea where to start with this. I don't know or have forgotten the commands to mount and have no idea which is the root or boot and how to chroot.

Solution 8:

Try to install sysvinit package.

#sudo mount -rw /dev/sda1 /somedir
#sudo chroot /somedir

#sudo apt-get install sysvinit

Problem: When I try the mount command, it writes something like directory cannot be found in fstab or mtab.

Solution 9:

went /boot/grub/menu.1st in my hda1 and noticed there were 2 menu.1st files. Renamed and deleted menu~.1st

Problem: No idea how to see if there's two or one menu.1st

Solution 10:

set root=UUID=yourhduuid in menu.1st (grub) and set the device mount by UUID in fstab.

Problem: Same problem as the above ones. What is fstab? What is UUID?

Solution 11

sudo dpkg-reconfigure volumeid

Problem: Same problem with sysvinit. I don't know whether I have volumeid installed or how to apt-get to it.

Level 3
Level 3
Posts: 117
Joined: Sun Sep 02, 2007 4:52 am

Re: initramfs tools - tty: job control turned off

Postby WinXpNewb » Sun Aug 17, 2008 2:19 am

Here's what I got when I ran fsck on livecd.

fsck 1.40.2 (12-Jul-2007)
e2fsck 1.40.2 (12-Jul-2007)
fsck.ext2: Permission denied while trying to open /dev/sda
You must have r/w access to the filesystem or be root
mint@mint:~$ sudo fsck /dev/sda
fsck 1.40.2 (12-Jul-2007)
e2fsck 1.40.2 (12-Jul-2007)
fsck.ext2: Device or resource busy while trying to open /dev/sda
Filesystem mounted or opened exclusively by another program?

This is both with the drive mounted and unmounted.

Return to “Installation & Boot”