key:Press S to skip mounting or M for manual... [SOLVED]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
geth23
Level 1
Level 1
Posts: 5
Joined: Fri Apr 04, 2014 12:01 pm

key:Press S to skip mounting or M for manual... [SOLVED]

Post by geth23 »

Hello friends, my name is Geth23 and i'm new in this forum.
I'll tell you my problem.
I have re-installed Mint 16 by a problem I had about python but it doesn't matter in this moment.
I came to ask for your help because in this new instalation every time I turn on my pc appears this message
key:Press S to skip mounting or M for manual recovery
I have seen other posts about this theme but I just can't solve this problem.
I'll thank if you can help me to solve this situation or if is it something normal.
If you need info about my pc I'll post it happily
Last edited by geth23 on Sat Apr 05, 2014 1:19 pm, edited 1 time in total.

User avatar
xenopeek
Level 24
Level 24
Posts: 24533
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: key:Press S to skip mounting or M for manual recovery

Post by xenopeek »

Have you set up any mounts in /etc/fstab? The message you get sounds you have made a mistake in /etc/fstab configuration of a mount.
Image

geth23
Level 1
Level 1
Posts: 5
Joined: Fri Apr 04, 2014 12:01 pm

Re: key:Press S to skip mounting or M for manual recovery

Post by geth23 »

xenopeek wrote:Have you set up any mounts in /etc/fstab? The message you get sounds you have made a mistake in /etc/fstab configuration of a mount.
Yeah, my problem is about fstab but I don't know how to repair it.

User avatar
xenopeek
Level 24
Level 24
Posts: 24533
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: key:Press S to skip mounting or M for manual recovery

Post by xenopeek »

Easiest is to run this command:

Code: Select all

lsblk -o +UUID
This shows all the partitions on your computer (see column TYPE = "part"), along with their mountpoint (column MOUNTPOINT) and UUID. One or more of TYPE "part" will not have a mountpoint, so check with your /etc/fstab which is it is and what might be wrong (is the UUID right, or the device path?).

Else share your /etc/fstab contents here, and the output of above command.
Image

geth23
Level 1
Level 1
Posts: 5
Joined: Fri Apr 04, 2014 12:01 pm

Re: key:Press S to skip mounting or M for manual recovery

Post by geth23 »

xenopeek wrote:Easiest is to run this command:

Code: Select all

lsblk -o +UUID
This shows all the partitions on your computer (see column TYPE = "part"), along with their mountpoint (column MOUNTPOINT) and UUID. One or more of TYPE "part" will not have a mountpoint, so check with your /etc/fstab which is it is and what might be wrong (is the UUID right, or the device path?).

Else share your /etc/fstab contents here, and the output of above command.
Thank, this is the info I got.

Code: Select all

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda4 during installation
UUID=90d5ee8e-a6bd-4220-bad9-7c177abd4c8b /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=a8640efd-4248-43fe-a929-420ebd597892 /boot           ext4    defaults        0       2
# /boot/efi was on /dev/sda2 during installation
UUID=3BEC-37D1  /boot/efi       vfat    defaults        0       1
# /home was on /dev/sda5 during installation
UUID=37a94d5b-4ee6-4589-85d7-0b589234a363 /home           ext4    defaults        0       2
# swap was on /dev/sda3 during installation
#UUID=7d931129-fa35-424c-a874-1d173fe7e048 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

User avatar
mbohets
Level 2
Level 2
Posts: 97
Joined: Sun Apr 28, 2013 8:26 am
Location: Belgium

Re: key:Press S to skip mounting or M for manual recovery

Post by mbohets »

I have a dual boot system.
When I hibernate my windows os and start linux, I get this message.
It looks like windows when hibernating prevents the windows partition to be mounted.
When I shutdown windows normally the partition is not blocked and linux boots normally.
Je suis Charlie, how many more people have to die for religion

User avatar
xenopeek
Level 24
Level 24
Posts: 24533
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: key:Press S to skip mounting or M for manual recovery

Post by xenopeek »

xenopeek wrote:Else share your /etc/fstab contents here, and the output of above command.
Ehm... Can't help you if you share only half...
Image

User avatar
austin.texas
Level 20
Level 20
Posts: 12048
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: key:Press S to skip mounting or M for manual recovery

Post by austin.texas »

xenopeek,
Your command lsblk -o +UUID does not work for me.
sudo lsblk -o UUID works, but displays only the UUID numbers.

sudo blkid -o list displays the info you need for fstab edits.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

geth23
Level 1
Level 1
Posts: 5
Joined: Fri Apr 04, 2014 12:01 pm

Re: key:Press S to skip mounting or M for manual recovery

Post by geth23 »

xenopeek wrote:
xenopeek wrote:Else share your /etc/fstab contents here, and the output of above command.
Ehm... Can't help you if you share only half...
Sorry here is the information

Code: Select all

device     fs_type label    mount point    UUID
-------------------------------------------------------------------------------
/dev/sda1  ext4             /boot          a8640efd-4248-43fe-a929-420ebd597892
/dev/sda2  vfat             /boot/efi      3BEC-37D1
/dev/sda4  ext4             /              90d5ee8e-a6bd-4220-bad9-7c177abd4c8b
/dev/sda5  ext4             /home          37a94d5b-4ee6-4589-85d7-0b589234a363
/dev/mapper/cryptswap1
           swap             (not mounted)  6c6d3729-84be-4dba-8483-7590a4f84d4b

User avatar
austin.texas
Level 20
Level 20
Posts: 12048
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: key:Press S to skip mounting or M for manual recovery

Post by austin.texas »

Looking at your fstab, you have a line
/dev/mapper/cryptswap1 none swap sw 0 0
When the boot process tries to run that command it fails, as you can see by the "not mounted" error, and gives you the error "key:Press S to skip mounting or M for manual recovery"
You can correct that by putting a # in front of that line, and then add this line -
UUID=6c6d3729-84be-4dba-8483-7590a4f84d4b none swap sw 0 0

That will point to your actual swap partition by UUID
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

geth23
Level 1
Level 1
Posts: 5
Joined: Fri Apr 04, 2014 12:01 pm

Re: key:Press S to skip mounting or M for manual recovery

Post by geth23 »

Thanks guys, I could finally solve this problem, thanks for your help my pc is OK now

Post Reply

Return to “Installation & Boot”