Page 1 of 1

[SOLVED] Hibernate: Reboots into fresh session (on LMDE)

Posted: Mon May 12, 2014 7:36 am
by Transistor
Hi all,

i assume my topic fits best into this category.

I have LMDE 201403 MATE 64bit installed on my laptop (an Acer Travelmate 5720, Core2Duo 2.2 GHz, 4 GB RAM). My swap partition is 6 GB. Everything runs fine so far, except hibernating.

I've read several posts on the Internet and didn't found much about the symptoms I have. My symptoms are similar to this users's: http://forums.linuxmint.com/viewtopic.p ... te#p852272 except that on my laptop the RAM seems to be really written to disk.

When I Quit and select "Hibernate", I can hear the HDD running and I see the HDD LED being turned on for about 20 seconds, so I assume that the contents of the RAM are written to disk. This behaviour is the same as it was with Windows XP.

But when I power the machine on again, it reboots normally, shows the login screen, and after login, I have a fresh session.
Executing

Code: Select all

sudo pm-hibernate
has the same effect.

I tried to the detect the hibernating capability with

Code: Select all

pm-is-supported --hibernate;echo "Detected $?"
and it returned "Detected 0".

In the "/etc/initramfs-tools/conf.d/" folder the is no "resume" file but only a "splash" file.

Does someone have any ideas for further research? I'm relatively new to Linux and don't know the next things to check.
Thanks!

Re: Hibernate: Reboots into fresh session (on LMDE)

Posted: Fri May 30, 2014 10:18 am
by simplex
I have exactly the same problem. I switched from Mint 16, 32 bit, where hibernate worked fine, to LMDE 201403, 64 bit, without doing any change to my hardware. Hibernate just stopped working. The effect is precisely as described above.

I have the same problem on a different machine, where I updated from Xubuntu 13.10 to 14.04 (both 32 bit). So I assume it has something to do with the kernels installed.

Nobody could help me so far on askubuntu.com or the Ubuntu forums.

S.

Re: Hibernate: Reboots into fresh session (on LMDE)

Posted: Fri May 30, 2014 10:58 am
by wayne128
check this How-to

How to hibernate Linux Mint LMDE XFCE & GNOME

Postby on4aa ยป Wed Mar 21, 2012 3:42 am


http://forums.linuxmint.com/viewtopic.php?f=197&t=97684

Re: Hibernate: Reboots into fresh session (on LMDE)

Posted: Fri May 30, 2014 12:04 pm
by simplex
THANK YOU!!! Finally a solution that works. I have spent so many wasted hours with this problem. Now I am eager to test this solution on my Xubuntu machine. I'll give back my experience to the community.

There is one thing that's not 100% ok: LMDE/Mate "forgets" the brightness level of the screen after the wakeup, but I can live with that.

Thank you again,
S.

Re: Hibernate: Reboots into fresh session (on LMDE)

Posted: Mon Jun 16, 2014 4:09 pm
by Transistor
Thank you very much!
The solution in the linked post works fine! The only difference was that on my machine there was no /etc/initramfs-tools/conf.d/resume file, but I simple created one.

Re: [SOLVED] Hibernate: Reboots into fresh session (on LMDE)

Posted: Tue Jun 17, 2014 8:16 am
by simplex
It is interesting to notice that this solution really only works for the Linux Mint Debian Edition. I have just tried the newest Mint 17 Qiana XFCE - the problem cannot be solved with these instructions. The same holds for the newest Xubuntu 14.10 and Fedora 20 XFCE.