Page 1 of 1

Trouble installing guest additions on LM 17

Posted: Mon Jun 02, 2014 12:40 am
by chirkut.batliwalla
Hi,

I have LM 13 (Maya) installed on a 64bit machine. VirtualBox and guest additions 4.1.12 are installed.

I installed LM 17 64bit as a VM and it boots up fine. I then did the following to install the guest additions.

sudo apt-get update
sudo apt-get purge virtualbox*
sudo ./VBoxLinuxAdditions.run

but this command fails. Here is the log:

Verifying archive integrity... All good.
Uncompressing VirtualBox 4.1.12 Guest Additions for Linux.........
VirtualBox Guest Additions installer
Removing existing VirtualBox DKMS kernel modules ...done.
Removing existing VirtualBox non-DKMS kernel modules ...done.
Building the VirtualBox Guest Additions kernel modules
The headers for the current running kernel were not found. If the following
module compilation fails then this could be the reason.

Building the main Guest Additions module ...fail!
(Look at /var/log/vboxadd-install.log to find out what went wrong)
Doing non-kernel setup of the Guest Additions ...done.
Installing the Window System drivers
Warning: unknown version of the X Window System installed. Not installing
X Window System drivers.
Installing modules ...done.
Installing graphics libraries and desktop services components ...done.


Note that the correct linux-headers *are* installed.

I even tried running the following command before installing guest additions, but that did not help

sudo apt-get install build-essential linux-headers-generic dkms

Anyone else having the same problem? Any clues on how to solve this problem?

TIA
Chirkut

Re: Trouble installing guest additions on LM 17

Posted: Fri Jun 06, 2014 2:24 pm
by supertallrich
Here's what I did after a fresh install of LM17 Cinammon (and updating the system):

> sudo apt-get install build-essential module-assistant
> sudo m-a prepare
> sudo apt-get purge virtualbox*
> sudo ./VBoxLinuxAdditions.run

And it builds without problems. Hope this helps.

Edit: I will say however that after installing the guest additions (I'm running 4.3.12 on Win7 x64) LM runs in software rendering mode and has horrible performance). So I'm reverting back to the default ones.