Boots Only to CLI After Installing LM17 <SOLVED>

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
boblynn
Level 2
Level 2
Posts: 73
Joined: Sun Mar 07, 2010 12:36 pm

Boots Only to CLI After Installing LM17 <SOLVED>

Post by boblynn »

[SOLVED with latest updates/bug fixes on 17 June 2014]
-----------------------------------------------------------------------------------

I just upgraded from LM10 to LM17 on my old AMD Anthlon XP 2400+ PC with S3 graphic chip VT8375 [Pro Savage KM266/KL266]

This pc had a graphic problem with LM10 but I was able to fix that with adding "nomodeset" to grub. This doesn't work with LM17 even with the addition of "forcevesa" to grub.

Current problem: Boots Only to Command Line Interface after displaying the Mint logo during boot.

After login, I tried "startx" and it took me to the graphical welcome screen but blinked on/off shortly after and gave an error message: "Failed to start xserver. It is likely that it is not set up correctly." I clicked through and got another error message: "Fatal server error. Server is already active for display 0..."

After I acknowledged that it seems to work properly, albeit somewhat slow.

Any suggestions?

Thanks for any help you can provide.
Last edited by boblynn on Tue Jun 17, 2014 3:43 pm, edited 2 times in total.
mintybits
Level 6
Level 6
Posts: 1123
Joined: Fri Jan 27, 2012 5:09 pm

Re: Boots Only to Command Line Interface After Installing LM

Post by mintybits »

You might try
sudo ubuntu-drivers autoinstall
boblynn
Level 2
Level 2
Posts: 73
Joined: Sun Mar 07, 2010 12:36 pm

Re: Boots Only to Command Line Interface After Installing LM

Post by boblynn »

Thanks for your prompt reply "mintybits". I tried your suggestion: "sudo ubuntu-drivers autoinstall" but the response: "no drivers found for automatic installation".

I also tried "mdm-recovery" I read elsewhere but that didn't work either.

The Live Disc worked fine (graphically) which led me to believe there was no compatibility issue with my hardware. But unfortunately the graphic interface did not function after installation to the HD. How do I get back to that Live Disc configuration? Is that "compatibility mode"?

The graphic interface works after I run through "startx" and the error messages ending with "...Restart MDM when configured correctly." The default must be "compatibility mode". How do I set that at boot?
User avatar
kukamuumuka
Level 16
Level 16
Posts: 6696
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Boots Only to Command Line Interface After Installing LM

Post by kukamuumuka »

The most easiest way is to boot with some older linux, which makes a proper /etc/X11/xorg.conf file, and copy that file to your system /etc/X11 folder.
Mepis 8 makes a good /etc/X11/xorg.conf file.
http://mepis.mirrorcatalogs.com/released/
boblynn
Level 2
Level 2
Posts: 73
Joined: Sun Mar 07, 2010 12:36 pm

Re: Boots Only to Command Line Interface After Installing LM

Post by boblynn »

Thank you for your reply "administrollaattori". I tried your suggestion: Run Mepis 8 and copy /etc/X11/xorg.conf file. Unfortunately, it had no effect and the problem remains.

I even tried a copy of /etc/X11/xorg.conf.failsafe from my daily pc running LM13 but this had no effect either.

The Live Desktop works properly so I know LM17 will run on the system if it can set to the default (compatibility mode?) graphics configuration at boot.

Also, I don't know why the grub menu doesn't appear at boot since it is only text. Is this related or a seperate problem?

Any other suggestions?

Thank you.
Last edited by boblynn on Tue Jun 10, 2014 10:16 am, edited 1 time in total.
Mintman2014
Level 1
Level 1
Posts: 1
Joined: Sat Jun 07, 2014 12:29 pm

Re: Boots Only to Command Line Interface After Installing LM

Post by Mintman2014 »

BobLynn,

I have a very similar issue, to get around it, i set the nomodeset flag in grub, and when i booted to the command line i ran startx. This allowed the desktop to show, albeit very pixelated. At this point i navigated to System Settings, and opened the device drivers. in there i had a few choices for video drivers, one of which was labeled "recommended". I selected that, and restarted, and now i seem to working perfectly. Perhaps a different video driver will work for you,

Hope that helps.
User avatar
kukamuumuka
Level 16
Level 16
Posts: 6696
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Boots Only to Command Line Interface After Installing LM

Post by kukamuumuka »

boblynn wrote:Thank you for your reply "administrollaattori". I tried your suggestion: Run Mepis 8 and copy /etc/X11/xorg.conf file. Unfortunately, it had no effect and the problem remains.

I even tried a copy of /etc/X11/xorg.conf.failsafe from my daily pc running LM13 but this had no effect either.

The Live Desktop works properly so I know LM17 will run on the system if it can set to the default (compaibility mode?) graphics configuration at boot.

Also, I don't know why the grub menu doesn't appear at boot since it is only text. Is this related or a seperate problem?

Any other suggestions?

Thank you.
Grub2 is too sensible with some hardware, but Legacy grub and LILO are working (just a comment for black grub menu dilemma).

Grub VGA codes could work with grub2 also (I have not tested).
http://www.linuxquestions.org/questions ... -lilo-830/

Basically grub2 menu should appear if you edit the next line from /etc/default/grub

Code: Select all

# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
... change this to
GRUB_GFXMODE=640x480
After editing run

Code: Select all

sudo update-grub
boblynn
Level 2
Level 2
Posts: 73
Joined: Sun Mar 07, 2010 12:36 pm

Re: Boots Only to Command Line Interface After Installing LM

Post by boblynn »

Thank you for your reply "mintman2014". I tried that first but there were no drivers for my chip set. - Thanks anyway.


Thanks for your most recent reply "administrollaattori". I had tried uncommenting GRUB_GFXMODE=640x480 before but that had no effect. I finally got the grub menu to display by commenting out GRUB_HIDDEN_TIMEOUT=0 which defaulted to GRUB_TIMEOUT=10. I was then able to run the recovery mode but that also had no effect.

Where do I insert the vga resolution code in grub so that I can try that suggestion?
Thank you.
Last edited by boblynn on Sun Jun 15, 2014 5:11 pm, edited 1 time in total.
User avatar
kukamuumuka
Level 16
Level 16
Posts: 6696
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Boots Only to Command Line Interface After Installing LM

Post by kukamuumuka »

boblynn wrote: Where do I insert the vga resolution code in grub so that I can try that suggestion?
Thank you.
https://wiki.sabayon.org/index.php?titl ... with_GRUB2
DavidMcCann
Level 1
Level 1
Posts: 1
Joined: Sat Jun 07, 2014 6:16 pm

Re: Boots Only to Command Line Interface After Installing LM

Post by DavidMcCann »

I've just installed Mint 17 on an older machine and I too wound up in the CLI. After a lot of work, I found the answer was a fault in mdm, not in the graphics driver. I replaced mdm with xdm and that fixed things.

PS For those who need more help:
Wait until it stops trying to start X and you get a message saying that it won't try again for 2 minutes
Press Ctrl-Alt-F1 for a command line and log in there
Use the commands

Code: Select all

sudo bash
apt-get remove mdm
apt-get install lightdm
telinit 6
The computer will reboot and you should get a graphical login screen. I've suggested lightdm: I haven't tested it but it should do. I used xdm because it's old and tested, but there was a catch: you have to edit grub to disable plymouth because xdm doesn't turn it off and it's left running all the time.

I not a Mint expert, but I write reviews of Linux distros and I was surprised to find problems: I've been giving it 8 ot 9 out of ten since version 11.
Last edited by DavidMcCann on Thu Jun 12, 2014 12:07 pm, edited 2 times in total.
boblynn
Level 2
Level 2
Posts: 73
Joined: Sun Mar 07, 2010 12:36 pm

Re: Boots Only to Command Line Interface After Installing LM

Post by boblynn »

Thanks for your most recent reply "administrollaattori". - I tried the vga code but that only affected the grub menu and CLI logon displayed resolution. The default (compatibility mode"?) seems to work fine in the Live Desktop session and the fallback after the xwindow(?) crash. How do I set LM17 to the compatibility mode at boot? The /etc/X11/xorg.conf from Mepis 8 had no effect.

RE: "DavidMcCann" - I agree it seems to be a problem with the mdm configuration used in LM17. How did you replace mdm with xdm?
boblynn
Level 2
Level 2
Posts: 73
Joined: Sun Mar 07, 2010 12:36 pm

Re: Boots Only to Command Line Interface After Installing LM

Post by boblynn »

RE: "DavidMcCann" - Thank you for your response to my question of how to replace mdm with xdm. [I checked every day for your reply (new post) but missed it when you edited your original reply with the answer. I finally found it when re-reading the thread to see if I missed anything. :-) ]

I followed your suggestion and removed mdm then installed lightdm with your code but unfortunately that didn't solve my problem. It did however, change the behavior as follows:
* The boot now hangs at the splash screen

Then I used Ctrl-Alt-F1 for a command line prompt to login
* unlike with mdm, the CLI was STABLE (not alternating back and forth to a blank screen)

I proceeded to login and run startx as before to get to the Mate Desktop BUT it does not fail anymore! It goes direct to the Mate Desktop!

It does seem to be "related" to mdm but not the cause of my boot to GUI problem. The computer runs fine from the Live Desktop and after finally getting through the manual startx to the Mate Desktop so I know LM17 will run with my hardware (in compatibility mode?).

What was your graphic card/chip set where replacing mdm with xdm worked for you?

Could it be a problem with the graphic driver specified in the xorg configuration?

Maybe I just need to find a way to run startx after the splash screen?

Thanks
siNner
Level 1
Level 1
Posts: 6
Joined: Fri Jun 06, 2014 8:47 am

Re: Boots Only to Command Line Interface After Installing LM

Post by siNner »

Hello,

I had a simular problem (http://forums.linuxmint.com/viewtopic.p ... 34#p876834) and I was following your post.

My problem disappeared with the update of today, which contained an updated version of MDM.

I hope your problem wil disappear also.

Cheers!
boblynn
Level 2
Level 2
Posts: 73
Joined: Sun Mar 07, 2010 12:36 pm

Re: Boots Only to CLI After Installing LM17 [SOLVED]

Post by boblynn »

Hello siNner!

Thank you for your post. (Saved me time experimenting with how to configure boot to startx via Lightdm :-) )

I downloaded todays LM17 updates and it fixed the problem I was having with booting only to the CLI and having to login and manually run startx.

Note that these updates/bug fixes fixed the problem with the Lightdm display manager I was running instead of MDM. The bug was apparently NOT only in mdm.

I removed Lightdm and reinstalled MDM so I finally have LM17 booting successfully working on my hardware.

Thanks for your help. :-)
unprinted
Level 2
Level 2
Posts: 54
Joined: Wed Jun 09, 2010 6:38 am

Re: Boots Only to Command Line Interface After Installing LM

Post by unprinted »

DavidMcCann wrote:I used xdm because it's old and tested, but there was a catch: you have to edit grub to disable plymouth because xdm doesn't turn it off and it's left running all the time.
I don't seem to have that issue, but I have nomodeset as a kernel option which may have been disabling plymouth anyway.

While lightdm works (at least on the first time I've booted with it), mdm still wasn't even after the 1.6.9 update.

http://forums.linuxmint.com/viewtopic.php?f=46&t=170829
boblynn
Level 2
Level 2
Posts: 73
Joined: Sun Mar 07, 2010 12:36 pm

Re: Boots Only to CLI After Installing LM17 <SOLVED>

Post by boblynn »

RE: DavidMcCann

Lightdm only worked for me AFTER the updates/bug fixes released on 17 June. Before that, it only changed the behavior (and stability) of manually running startx. I reinstalled mdm to see if that now worked also and it did.

Those of us who experienced and posted about this problem had different experiences following the same suggestions while others seem to have no such problem. It must be our graphic hardware differences.

I note that my pc works even after removing "nomodeset" and forcevesa" from grub. This is the only release (that I tried on this pc) since LM10 that did NOT require those grub parameters in order to boot. (Apparently an appropriate driver was included in the LM17 release.)

It would be interesting to know what bugs were fixed in that 17 June update release.

Thanks for your help!
Post Reply

Return to “Installation & Boot”