rEFInd isntallation error: "cannot overwrite directory"

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
lascuba
Level 1
Level 1
Posts: 29
Joined: Fri Sep 26, 2014 4:04 pm

rEFInd isntallation error: "cannot overwrite directory"

Post by lascuba »

It seems I don't have a bootloader and I can't seem to get one installed. After several mistakes on my part (read about it here: http://forums.linuxmint.com/viewtopic.php?f=90&t=179157) I installed 64-bit Mint as my only os, except when I try to reboot I get

"Reboot and Select proper Boot device or Insert Boot Media in selected Boot Device and press a key."

I tried reinstalling grub following ubuntu's instructions for live cd, and it's not happening. I even tried installing ubuntu, hoping for an easy fix and that didn't work. I finally decided to try refind, and after installation I get this:

Code: Select all

Notice: Backed up existing icons directory as icons-backup.
Existing refind.conf file found; copying sample file as refind.conf-sample
to avoid overwriting your customizations.
[b]
cp: cannot overwrite directory ‘/boot/efi//EFI/refind/refind.conf-sample’ with non-directory[/b]
rEFInd has been set as the default boot manager.
Creating /boot/efi/boot/refind_linux.conf; edit it to adjust kernel options.

ALERT:
Installation has completed, but problems were detected. Review the output for
error messages and take corrective measures as necessary. You may need to
re-run this script or install manually before rEFInd will work.
:
I get the same "cp: cannot overwrite [...]" message when I try to install manually instead of with install.sh. Sure enough, when I try to reboot I get "select proper boot device again."

I'm about ready to throw in the towel and just get a new laptop, but I want to make sure I'm doing everything I can with refind first. Thank you.
Jerry
Level 3
Level 3
Posts: 111
Joined: Fri Dec 28, 2012 11:52 pm
Location: Canada

Re: rEFInd isntallation error: "cannot overwrite directory"

Post by Jerry »

HI. I don't know what the problem might be as I've also encountered that same message:

Code: Select all

Reboot and Select proper Boot device or Insert Boot Media in selected Boot Device and press a key.
However, have you checked your BIOS settings and selected the defaults?
In case you have not, can you try to select UEFI enabled and Secure Boot disabled and henceforth try to at least go this route.
May you have good thermals.
lascuba
Level 1
Level 1
Posts: 29
Joined: Fri Sep 26, 2014 4:04 pm

Re: rEFInd isntallation error: "cannot overwrite directory"

Post by lascuba »

double post
Last edited by lascuba on Tue Oct 14, 2014 10:34 pm, edited 1 time in total.
lascuba
Level 1
Level 1
Posts: 29
Joined: Fri Sep 26, 2014 4:04 pm

Re: rEFInd isntallation error: "cannot overwrite directory"

Post by lascuba »

Yes, all my setting are correct. The sadly ironic thing is that when I initially installed Mint I did it all wrong--32-bit, legacy on, secure boot on. And it was actually working ok, I just has issues with windows. Then I decided to just get rid of windows and redo the installation the right way and I haven't been able to boot since.

When I check efibootmgr, refind is there, it just doesn't appear to have any affect on my machine.
Jerry
Level 3
Level 3
Posts: 111
Joined: Fri Dec 28, 2012 11:52 pm
Location: Canada

Re: rEFInd isntallation error: "cannot overwrite directory"

Post by Jerry »

I am really interested in both helping as well as learning what you did as I am also having somewhat of the same issue though not to the same extent that your having. I still have Windows 8 installed and am not having much success in having any EFI capable Linux load up along with Grub2 not showing up.
I also have a newer UEFI laptop which has got Windows on it but am having problems booting it up to LM. I also am thinking, like what you did, by removing Windows completely, and just using Linux which would be just fine by me.

(1) So what I understand is that you eliminated Windows completely, is this correct?
(2) You have rEFInd installed but you still have have Linux on it but rEFInd is not finding Linux, is this correct?
(3) You removed the UEFI component of your BIOS/EFI, does this correct and is current ?

I would suggest that you start over:

(1)I would suggest to leave the EFI enabled. Secure Boot enabled as well. (From what I've been reading, leaving both of those enabled is best as most Linux distros are coming online to being UEFI/Secure Boot capable. The Ubunut Wiki on UEFI has got information on installing Ubuntu on a UEFI computer. I have tried this but to my own experiences it is not working).

(2)I would suggest to partition a seperate FAT32 partition of no more than 300 Mb for Grub2 to be installed into. Even 250 is good.

(3)Install Linux Mint. 64 bit is used for UEFI as 32 bit will not function on UEFI and Secure Boot being enabled. If your machine is 64 bit, use 64 bit .iso.
If your machine is 32 bit, of course use 32 bit .iso and disable both settings in the UEFI/BIOS settings.

(3)Install rEFInd

All in that order. Please do post here your results as I'd like to continue to help you as best as my ideas are able to lead you.
May you have good thermals.
Post Reply

Return to “Installation & Boot”