[SOLVED] Hibernate doesn't save state

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
User avatar
inate71
Level 2
Level 2
Posts: 59
Joined: Sat Aug 10, 2013 11:54 am

[SOLVED] Hibernate doesn't save state

Post by inate71 »

I'm using Mint 17.

As of yesterday, I had been using Mint with a 3GB swap-space. However, I was finding that I was unable to reboot if I had more than 3GB of RAM in-use. So, I booted on a LiveUSB of Gparted, I deleted my swap partition, shrunk my / file system (the default one), and then created a larger swap-space partition.

However, now when I hibernate, the state isn't saved. I've already edited my /etc/fstab file to account for the new UUID of the partition--but it won't work. I've made sure the swap is enabled, ran the command

Code: Select all

swapon -s
and it looked good--I think.

Here are various screenshots of the information I've given.
http://imgur.com/a/IrxmL

I appreciate any and all help! I had hibernation working perfectly prior to my resizing the swap-partition.


SOLUTION
Turns out I needed to edit my resume file!

I followed the instructions found here, and it worked like a charm: http://askubuntu.com/a/196365/123256
Last edited by inate71 on Thu Oct 16, 2014 5:11 pm, edited 1 time in total.
acerimusdux
Level 4
Level 4
Posts: 343
Joined: Sat Dec 26, 2009 3:36 pm

Re: [Q] Hibernate doesn't save state

Post by acerimusdux »

See what it says in the log:

Code: Select all

cat /var/log/pm-suspend.log
If that file is long, you may only need to look at the end of it:

Code: Select all

cat /var/log/pm-suspend.log| tail -150
User avatar
inate71
Level 2
Level 2
Posts: 59
Joined: Sat Aug 10, 2013 11:54 am

Re: [Q] Hibernate doesn't save state

Post by inate71 »

acerimusdux wrote:See what it says in the log:

Code: Select all

cat /var/log/pm-suspend.log
If that file is long, you may only need to look at the end of it:

Code: Select all

cat /var/log/pm-suspend.log| tail -150

This was from an hour ago--I tried running pm-hibernate several times. I think there is something up with the thaw lines.
Pastebin, pm-suspend.log: http://pastebin.com/ptzSnyB2
acerimusdux
Level 4
Level 4
Posts: 343
Joined: Sat Dec 26, 2009 3:36 pm

Re: [Q] Hibernate doesn't save state

Post by acerimusdux »

inate71 wrote:This was from an hour ago--I tried running pm-hibernate several times. I think there is something up with the thaw lines.
Not seeing any errors there though, looks like it *thinks* its waking up fine. :?:
User avatar
inate71
Level 2
Level 2
Posts: 59
Joined: Sat Aug 10, 2013 11:54 am

Re: [Q] Hibernate doesn't save state

Post by inate71 »

acerimusdux wrote:
inate71 wrote:This was from an hour ago--I tried running pm-hibernate several times. I think there is something up with the thaw lines.
Not seeing any errors there though, looks like it *thinks* its waking up fine. :?:
What about now? http://pastebin.com/mu0AGbNh

EDIT:
Would it help if I told you that it doesn't appear that my swap-space partition isn't being utilized at all? Before I did this resizing, the swap-space was being using by some amount. Now, it's always saying it's using 0mb/6.3GiB
Post Reply

Return to “Installation & Boot”